Closed Bug 1005600 Opened 6 years ago Closed 5 years ago

Alt+D keyboard shortcut has no effect

Categories

(Mozilla Localizations :: he / Hebrew, defect)

x86_64
Windows 7
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: yonatan.amir, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140421221237

Steps to reproduce:

See here: https://support.mozilla.org/en-US/questions/997715
1. Install FF29 with Hebrew locale or Hebrew language pack
2. type Alt+D


Actual results:

Nothing happens.


Expected results:

The location bar should be selected.
Yaron, do you know if this shortcut is purposefully different in the Hebrew localization? Did this change recently?
Flags: needinfo?(mvocom)
Hi Gijs,

I have no idea. Sorry.
I've never used that shortcut.
Flags: needinfo?(mvocom)
Forgot to add:
It doesn't work for me either.
(In reply to Yaron from comment #3)
> Forgot to add:
> It doesn't work for me either.

OK. It works for me on an English copy of Firefox, so I presume it's an issue with the Hebrew localization. (Confirming per comment #3)
Status: UNCONFIRMED → NEW
Component: Untriaged → he / Hebrew
Ever confirmed: true
Product: Firefox → Mozilla Localizations
Version: 29 Branch → unspecified
I've CC'ed Tomer. He might know more
(In reply to :Gijs Kruitbosch from comment #4)
> (In reply to Yaron from comment #3)
> > Forgot to add:
> > It doesn't work for me either.
> 
> OK. It works for me on an English copy of Firefox, so I presume it's an
> issue with the Hebrew localization. (Confirming per comment #3)

I have the same problem.
I'm using FF with the hebrew pack for many years. And I've allways used the alt+d shortcut, now in FF29 I'ts dons't work.

Thanks.
Reproduced on 29.0.1
I guess this is the changeset (Feb 6), unless I'm looking at the wrong entity
http://hg.mozilla.org/releases/l10n/mozilla-release/he/rev/f2896e31a77e#l2.288
(In reply to Francesco Lodolo [:flod] from comment #8)
> I guess this is the changeset (Feb 6), unless I'm looking at the wrong entity
> http://hg.mozilla.org/releases/l10n/mozilla-release/he/rev/f2896e31a77e#l2.
> 288

I think you're right, switching the keyboard to Hebrew and typing alt+"ח" sets the focus to the address bar.
Tomer, was this a deliberate change, or can you fix this in the hebrew translation? :-)
Flags: needinfo?(tomer.moz.bugs)
are there is any progress?
Alt-* keyboard shortcuts are accesskeys, and in contrast to Ctrl-* keyboard shortcuts they are not preserved between locales. You can access the Location Bar by using Ctrl-L or F6.

The Alt-D keyboard shortcut is in fact an historical relic implemented to make migration with ease for Internet Explorer users, were D was standing for for the browser address bar, which is known as the location bar on other browsers jargon.
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(tomer.moz.bugs)
Resolution: --- → INVALID
I disagree. The key might have "accesskey" in the name, but in the end is a shortcut and not exposed as a standard accesskey
http://mxr.mozilla.org/mozilla-central/source/browser/base/content/browser-sets.inc#262
(In reply to Francesco Lodolo [:flod] (UTC+2) from comment #13)
> I disagree. The key might have "accesskey" in the name, but in the end is a
> shortcut and not exposed as a standard accesskey
urlbar.accesskey is tricky – It's an accesskey and is used as an keybinding. I guess that most of automation tools won't be able to warn it as such, therefore I'm suggesting renaming the key. 

committed changeset 601:95c0c7fb65f1
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
You need to log in before you can comment on or make changes to this bug.