View source crashes @ _RBSrcCopyRunMask()

VERIFIED WORKSFORME

Status

SeaMonkey
UI Design
--
critical
VERIFIED WORKSFORME
16 years ago
13 years ago

People

(Reporter: hsivonen, Assigned: Paul Chen)

Tracking

({crash})

Trunk
PowerPC
Mac OS X
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
Build ID: 2001091821 FizzillaCFM

Reproducible: always

Steps to reproduce:
1) Load http://www.helsinki.fi/2) View source

Actual results:
Crash.

Expected results:
Expected to see the source.
(Reporter)

Comment 1

16 years ago
Created attachment 49905 [details]
crash.log excerpt
(Reporter)

Comment 2

16 years ago
The URL in step 1) should be http://www.helsinki.fi/

Mozilla ate the line break that was between the steps.
Keywords: crash
worksforme current linux trunk.  Mac-only?

Comment 4

16 years ago
->XP Apps
Component: Browser-General → XP Apps

Comment 5

16 years ago
I get a reproducable crash when I execute View Source on 2001-09-28-21 on Linux.
The crash happens on all URLs, but I tested it on http://www.google.com.

Talkback ID: TB36039868Z

Comment 6

16 years ago
More info: it actually doesn't happen all the time. But google seams to be the
safest bet. If it doesn't crash the first time you do a View Page Source, try it
again. Below I will attach a backtrace.

Comment 7

16 years ago
Created attachment 51404 [details]
Crash when doing a View Page Source on google.com.

Comment 8

16 years ago
Dupe of bug 102376?
No.  Bug 102376 was caused by the chekin for bug 96364, which happened on Sept.
29.  This bug was reported way before that.
change platform to All, this crashes on W2K also: just sent a talkback in.
quick question: is there any info for talkback on the your HD? I'm trying to get
it open but talkback only opens upon a crash.. so that I maybe able to relay TB
id's if needed.  What would be the correct way to get it running to view the logs.
on current build 2001093008 W2K.

Comment 12

16 years ago
not mine.
Assignee: asa → pchen
QA Contact: doronr → sairuh
(Assignee)

Comment 13

16 years ago
View source of http://www.helsinki.fi/ and http://www.google.com/ work for me
using fizilla 2001-10-02 0.9.4 branch commercial build (a.k.a. Netscape 6.2 for
MacOS X) and using mozilla 2001100103 win32 build on win32.  Marking W4M. Please
reopen when you've got a reproducible test case running a recent build. Thanks.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
mass verification of WorksForMe bugs: to find all bugspam pertaining to this,
set your search string to "IfItWorksForSlappyTheSquirrelThenItWFM".

if you think this particular bug is *still* an open issue, please make sure of
the following before reopening:

a. that it's still a problem with ***recent trunk builds*** on the all
appropriate platform[s]

b. provide clear steps to reproduce (unless a good test case is already in the
bug report), making sure it pertains to the original problem (avoid morphing as
much as possible :)
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.