"Developer Tools" should show an warning like about:config does

RESOLVED DUPLICATE of bug 994134

Status

()

Firefox
Developer Tools: Console
RESOLVED DUPLICATE of bug 994134
3 years ago
3 years ago

People

(Reporter: Enzam, Unassigned)

Tracking

29 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140428193838

Steps to reproduce:

Pressed F12 or Ctrl+Shift+I or selected "Web Console" from the menu.


Actual results:

Firefox showed me Developer Console without any warning.


Expected results:

Firefox should warn me about the great power it has, with great power comes great responsibility.
(Reporter)

Updated

3 years ago
Component: Untriaged → Developer Tools: Console
OS: Linux → All
Hardware: x86_64 → All
(Reporter)

Comment 1

3 years ago
Currently a lot of spams are targetting users by attracting them to paste insecure javascript to the developer consoles to spam and/or hack people.
Normal users with no context about what developer consoles is or what can it do follow the instructions.
Firefox should protect its users by warning them about what can happen.
We're aware of the issues with this type of problem in Facebook. Could you provide links to other scams so we can check that our solutions work for as many cases as possible?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 994134
(Reporter)

Comment 3

3 years ago
The example I had was for Facebook and they are being removed, if I find some more, I will post it here (or in the main bug).

Comment 4

3 years ago
As summarized, this is more a dup of bug 953166 or bug 691452, but bug 994134 is our targeted solution for the pasting-based attacks.
You need to log in before you can comment on or make changes to this bug.