[RTSP][V2.0] Crash happened when tested RTSP - B2G 32.0a1 Crash Report [@ nsStandardURL::Release() ]

VERIFIED DUPLICATE of bug 1006530

Status

defect
VERIFIED DUPLICATE of bug 1006530
5 years ago
5 years ago

People

(Reporter: whsu, Unassigned)

Tracking

unspecified
2.0 S1 (9may)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [p=1])

Reporter

Description

5 years ago
* Description:
  I encountered a problem when I tested RTSP streaming.
  Disabling the outgoing network of the hotspot causes a crash.
  Here are the crashID and URL.
  - https://crash-stats.mozilla.com/report/index/28221d5c-83e8-43b6-b9b6-acd242140505
  By the way, the reproduce rate is low (10%~20%)

* Reproduction steps:
  1. Connect to a hotspot
  2. Launch the following page via browser
     - http://goo.gl/FyHFNs
  3. Tap the "Video test page (3GP)"
  4. After FxOS launches the video to play RTSP streaming, please disable outgoing network of the hotspot.

* Expected result:
  The video RTSP streaming stops there and show the warning message

* Actual result:
  A crash happened

* Reproduction build: V2.0 (Buri)
 - Gaia      f55fc5c507312c7aac51ec9bb73061fd4ed5c5fb
 - Gecko     https://hg.mozilla.org/mozilla-central/rev/3285e030d9c0
 - BuildID   20140504160202
 - Version   32.0a1
We had fixed a similar problem in bug 951175 ([RTSP][V1.3] Disabling network on the hotspot will cause a system hang while FxOS is playing RTSP streaming).
However, we had refactored some RTSP codes in v2.0.
I will further clarify the crash of this bug.

BTW, the warning message requirement is tracked by bug 975257.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1006530
Hi William,

As Benjamin marked in comment 3, we think this is a duplicate of bug 1006530 according to the crash report.
Please help to verify the patch in bug 1006530 also remedies the crash in this bug. :)
Whiteboard: [p=1]
Target Milestone: --- → 2.0 S1 (9may)
Reporter

Comment 5

5 years ago
Verified patch.
No crash happened during verification.

* Build Information:
 - Gaia      2f89c43e798ccba631025bedc47a1fb24e830cf2
 - Gecko     https://hg.mozilla.org/mozilla-central/rev/4b6d63b05a0a
 - BuildID   20140512160204
 - Version   32.0a1
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.