distclean target broken, recurses into mfbt/tests twice

RESOLVED FIXED in Firefox 31

Status

()

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: axs, Assigned: froydnj)

Tracking

(Blocks 1 bug)

31 Branch
mozilla32
x86_64
Linux
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox31 fixed, firefox32 fixed)

Details

(Whiteboard: [qa-])

Attachments

(1 attachment)

Needed to fix bug 1005759 (make source-package) for in-sourcetree source-package rolling, but this is a bug in and of itself too.

steps to reproduce:
cd js/src
autoconf-2.13
./configure
make distclean

Result:
make -C config distclean
make[1]: Entering directory `/path/to/mc/js/src/config'
[...]
make[1]: Leaving directory `/path/to/mc/js/src/config'
make -C python distclean
make[1]: Entering directory `/path/to/mc/js/src/python'
[...]
make[1]: Leaving directory `/path/to/mc/js/src/python'
make -C mfbt distclean
make[1]: Entering directory `/path/to/mc/js/src/mfbt'
make -C tests distclean
make[2]: Entering directory `/path/to/mc/js/src/mfbt/tests'
[...]
make[2]: Leaving directory `/path/to/mc/js/src/mfbt/tests'
make -C tests distclean
make[2]: Entering directory `/path/to/mc/js/src/mfbt/tests'
make[2]: *** No rule to make target `distclean'.  Stop.
make[2]: Leaving directory `/path/to/mc/js/src/mfbt/tests'
make[1]: *** [distclean] Error 2
make[1]: Leaving directory `/path/to/mc/js/src/mfbt'
make: *** [distclean] Error 2
Blocks: 1005759
Somehow we ended up with this duplicate rule.  As you can see, it's redundant
with the rule just above it and causes problems by trying to do things twice.
Attachment #8418752 - Flags: review?(mshal)
Attachment #8418752 - Flags: review?(mshal) → review+
Assignee: nobody → nfroyd
https://hg.mozilla.org/mozilla-central/rev/72b41e294442
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla32
Comment on attachment 8418752 [details] [diff] [review]
remove duplicate distclean:: rule in rules.mk

[Approval Request Comment]
Bug caused by (feature/regressing bug #): changes to build system between mozilla-24 and mozilla-31
User impact if declined: 'make distclean' fails in js/src, source package for spidermonkey/mozjs-31 cannot be rolled
Testing completed (on m-c, etc.): confirmed working on aurora and m-c checkouts, locally
Risk to taking this patch (and alternatives if risky): none
String or IDL/UUID changes made by this patch: none
Attachment #8418752 - Flags: approval-mozilla-aurora?
Attachment #8418752 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.