Interaction between java plug-in and about:plugins cause core dump

VERIFIED DUPLICATE of bug 86591

Status

()

Core
Plug-ins
--
major
VERIFIED DUPLICATE of bug 86591
16 years ago
15 years ago

People

(Reporter: psfales, Assigned: av (gone))

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:0.9.4) Gecko/20010917
BuildID:    2001091715

Under both solaris and linux, I can consistently get a core
dump using this procedure:
- Start mozilla
- Visit about:plugins
- Visit http://www.javasoft.com

I'm using JRE 1.3.1 installed as plugin.  I can visit java
enabled sites, including http://www.javasoft.com and the java
works fine, as long as I don't do about:plugins first.

Reproducible: Always
Steps to Reproduce:
1.Start Mozilla
2.Visit about:plugins
3.Visit http://www.javasoft.com

Here's the stack trace 
#0  0x415f3331 in JavaVM5::AllocateEventWidget () from
/misc/exp/lib/mozilla/bin/plugins/jre1.3.1/plugin/i386/ns600/libjavaplugin_oji.so
#1  0x415f3949 in JavaVM5::StartJavaVM () from
/misc/exp/lib/mozilla/bin/plugins/jre1.3.1/plugin/i386/ns600/libjavaplugin_oji.so
#2  0x415f2142 in JavaPluginFactory5::StartupJVM () from
/misc/exp/lib/mozilla/bin/plugins/jre1.3.1/plugin/i386/ns600/libjavaplugin_oji.so
#3  0x415f1bfe in JavaPluginFactory5::GetJavaVM () from
/misc/exp/lib/mozilla/bin/plugins/jre1.3.1/plugin/i386/ns600/libjavaplugin_oji.so
#4  0x415f2521 in JavaPluginFactory5::CreateSecureEnv () from
/misc/exp/lib/mozilla/bin/plugins/jre1.3.1/plugin/i386/ns600/libjavaplugin_oji.so
#5  0x4144126d in NSGetModule () from /misc/exp/lib/mozilla/bin/components/liboji.so
#6  0x41441300 in NSGetModule () from /misc/exp/lib/mozilla/bin/components/liboji.so
#7  0x4143d9b9 in NSGetModule () from /misc/exp/lib/mozilla/bin/components/liboji.so
#8  0x4143e5cf in NSGetModule () from /misc/exp/lib/mozilla/bin/components/liboji.so
#9  0x417208d6 in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#10 0x4171f79b in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#11 0x4171a24a in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#12 0x416f1f35 in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#13 0x416f1d77 in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#14 0x416f1bcf in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#15 0x416f1a6e in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#16 0x416f0730 in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#17 0x416efff9 in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#18 0x416eebec in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#19 0x416f5cc8 in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#20 0x416f57bb in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#21 0x416f1496 in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#22 0x416f03ec in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#23 0x416efff9 in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#24 0x416eebec in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#25 0x416fb6dc in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#26 0x417a7bc9 in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#27 0x416fb6dc in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#28 0x417b7de3 in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#29 0x417b8891 in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#30 0x416fb6dc in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#31 0x417b975c in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#32 0x417bb022 in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#33 0x416fb6dc in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#34 0x417af9cc in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#35 0x417ad564 in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#36 0x416fb6dc in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#37 0x417b44be in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#38 0x417b5e73 in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#39 0x416f5cc8 in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#40 0x416f57bb in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#41 0x416f1496 in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#42 0x416f03ec in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#43 0x416efff9 in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#44 0x416eebec in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#45 0x416f5cc8 in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#46 0x416f57bb in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#47 0x416f1496 in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#48 0x416f03ec in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#49 0x416efff9 in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#50 0x416eebec in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#51 0x416fb6dc in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#52 0x4170a9cc in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#53 0x417d7747 in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#54 0x417d70ba in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#55 0x417d4988 in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#56 0x417be76f in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#57 0x417d4988 in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#58 0x417d93b3 in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#59 0x41746b72 in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#60 0x41746e03 in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#61 0x41746bc1 in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#62 0x417d4988 in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#63 0x417e5d48 in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#64 0x41746155 in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#65 0x416fb6dc in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#66 0x417449b9 in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#67 0x4170b215 in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#68 0x41731cae in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#69 0x41731e2d in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#70 0x41731a20 in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libgklayout.so
#71 0x40134d18 in PL_HandleEvent () at eval.c:41
#72 0x40134c09 in PL_ProcessPendingEvents () at eval.c:41
#73 0x40135e90 in nsEventQueueImpl::ProcessPendingEvents () at eval.c:41
#74 0x40c5f860 in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libwidget_gtk.so
#75 0x40c5f56b in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libwidget_gtk.so
#76 0x4036149a in g_io_unix_dispatch (source_data=0x8111db8,
current_time=0xbffff264, user_data=0x8158050) at giounix.c:135
#77 0x403629d5 in g_main_dispatch (dispatch_time=0xbffff264) at gmain.c:656
#78 0x40362f91 in g_main_iterate (block=1, dispatch=1) at gmain.c:877
#79 0x40363109 in g_main_run (loop=0x81587b8) at gmain.c:935
#80 0x4028d42a in gtk_main () at gtkmain.c:524
#81 0x40c5fdc9 in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libwidget_gtk.so
#82 0x40683d27 in NSGetModule () from
/misc/exp/lib/mozilla/bin/components/libnsappshell.so
#83 0x0804f5bb in NS_CreateNativeAppSupport () at eval.c:41
#84 0x0804ff8c in main () at eval.c:41
#85 0x404a3177 in __libc_start_main (main=0x804fe2c <main>, argc=1,
ubp_av=0xbffff4f4, init=0x804aab4 <_init>, fini=0x8050dec <_fini>,
rtld_fini=0x4000e184 <_dl_fini>, stack_end=0xbffff4ec) at
../sysdeps/generic/libc-start.c:129
(Assignee)

Comment 1

16 years ago
Serge, is this a known problem?

Comment 2

16 years ago
it could be a dup of 86591, at least the test case is the same, though stack 
trace looks slightly different

Comment 3

16 years ago
same backtrace as i got with a non-debug when testing bug 100285
I resolved that one as dup of 86591 based on the similarities in backtraces there.

Comment 4

16 years ago
this is a duplicate of bug 99950, again marked dup of bug 86591 by Peter Lubczynski.



*** This bug has been marked as a duplicate of 86591 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 5

15 years ago
mass duplicate verifications . For filtering purposes, pls use keywd
"massdupverification"

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.