Closed Bug 1006070 Opened 6 years ago Closed 6 years ago

[B2G][1.4][Open_C][Email] Attachment errors display twice

Categories

(Firefox OS Graveyard :: Gaia::Gallery, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v1.3 unaffected, b2g-v1.4 affected)

RESOLVED DUPLICATE of bug 994537
2.0 S1 (9may)
Tracking Status
b2g-v1.3 --- unaffected
b2g-v1.4 --- affected

People

(Reporter: mkruml, Unassigned)

Details

(Keywords: regression, Whiteboard: OpenCrun1.4-3)

Attachments

(1 file)

3.86 KB, text/plain
Details
Attached file double.txt
Description:
If an error is displayed via email attachments, one error will display for the app the opens the file, and one will be displayed for the email app in sequence.

Prereqs: Have an email account set up on device, have an image file attachment in the inbox that is too large for device to display

Repro Steps:
1) Update a OpenC to BuildID: 20140505000201
2) Open the Email app and navigate to Inbox
3) Open email with picture attachment of large resolution
4) Download/view the attachment and observe:

Actual:
The Gallery app throws an error describing that the message is too large to open, then the Email app throws the same error afterwards. The user is then returned to the email app.

Expected:
Only one error is throw, then the user is returned to the email app.

1.4 Environmental Variables:
Device: OpenC 1.4 MOZ
BuildID: 20140505000201
Gaia: fccb15d6940db51615545574877a62d69406b1c2
Gecko: bf937fbec8c1
Version: 30.0
Firmware Version: p821a10-eng_20140410

also occurs on Buri 1.4

1.4 Environmental Variables:
Device: Buri 1.4 MOZ
BuildID: 20140430000201
Gaia: 81e97c3ca58be0487292011bc59efa4cebab30be
Gecko: 123485e733d5
Version: 30.0
Firmware Version: v1.2-device.cfg

Does not occur in Buri 1.3

1.3 Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140501024001
Gaia: 667539f1ed4becc45b182a5f1046221d3eeb9e7c
Gecko: 4b68615ea3e5
Version: 28.0
Firmware Version: v1.2-device.cfg

Repro frequency: 100%
See attached: logcat: double.txt
The email app won't throw errors about this.  In fact, from the log, we can see that the email app got an onsuccess result:
  05-05 11:31:57.827: I/GeckoDump(1118): LOG: "open" activity allegedly succeeded

This sounds like the gallery app is throwing the error twice or there's a system window manager bug where maybe a window.alert is being used and edge-cases relating to returning from the activity cause the error to show up twice.

Turfing to the gallery app, although the the window manager might be the eventual home for this.  Note that this is the type of bug where a video would probably be handy.  (Although this may be a known gallery bug, in which case, maybe wait for them to ask?)
Component: Gaia::E-Mail → Gaia::Gallery
Annoying, but not a blocking regression.
Keywords: regression
Investigated the issue and so far it doesn't look like bug in gallery. Alert for 'image too big' is invoked from below line inside open.js, and there has been no change there in 1.4
https://github.com/mozilla-b2g/gaia/blob/v1.4/apps/gallery/js/open.js#L181

The above alert triggers to show two app modal dialog with first alert window title as Gallery and the second window title as E-Mail. 
https://github.com/mozilla-b2g/gaia/blob/v1.4/apps/system/js/app_modal_dialog.js#L384
The message in both alert window stays same as 'Image is too large to display on this device'

Commenting line181 in gallery/js/open/js, hides both alert windows, indicating for some reason this single alert is generating two events to show two app modal dialog. Setting need info flag for Alive to provide his inputs . Thanks
Flags: needinfo?(alive)
This should be dupe of bug 994537
Flags: needinfo?(alive)
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 994537
Target Milestone: --- → 2.0 S1 (9may)
You need to log in before you can comment on or make changes to this bug.