Closed Bug 1006112 Opened 5 years ago Closed 5 years ago

Regression in signaling unit tests

Categories

(Core :: WebRTC: Signaling, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla32

People

(Reporter: mt, Assigned: mt)

Details

Attachments

(1 file, 1 obsolete file)

Attached patch unregress.patch (obsolete) — Splinter Review
Two issues here from bug 942367

New protections for off-thread access to PeerConnectionMedia constructs are being triggered.

Stream isolation defaults to true, but wasn't being turned off in unit tests because those don't load up libxul and all the principal code.
Attachment #8417625 - Flags: review?(ekr)
Comment on attachment 8417625 [details] [diff] [review]
unregress.patch

Review of attachment 8417625 [details] [diff] [review]:
-----------------------------------------------------------------

lgtm but I suggest converting to SyncRunnable

::: media/webrtc/signaling/test/signaling_unittests.cpp
@@ +1334,2 @@
>      if (local) {
> +      gMainThread->Dispatch(

Suggest using SyncRunnable here, it's better practice.
Attachment #8417625 - Flags: review?(ekr) → review+
r=ekr SyncRunnable it is.
Assignee: nobody → martin.thomson
Attachment #8417625 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #8417650 - Flags: review+
Keywords: checkin-needed
I confirm that this fixes the issue.
https://hg.mozilla.org/mozilla-central/rev/96b197deb91e
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla32
You need to log in before you can comment on or make changes to this bug.