Closed Bug 1006152 Opened 8 years ago Closed 8 years ago

[flame] MozBuild ROM does not use HWComposer

Categories

(Firefox OS Graveyard :: GonkIntegration, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:1.4+, firefox30 wontfix, firefox31 wontfix, firefox32 fixed, b2g-v1.4 fixed, b2g-v2.0 fixed)

RESOLVED FIXED
2.0 S2 (23may)
blocking-b2g 1.4+
Tracking Status
firefox30 --- wontfix
firefox31 --- wontfix
firefox32 --- fixed
b2g-v1.4 --- fixed
b2g-v2.0 --- fixed

People

(Reporter: sotaro, Assigned: sotaro)

Details

Attachments

(1 file, 3 obsolete files)

I built a rom for flame device, the rom does not have "ro.display.colorfill" property. Then HwComposer is disabled.
Confrimed that the patch works on flame device.
Attached file link to pull request (obsolete) —
Attachment #8417671 - Attachment is obsolete: true
Attachment #8417678 - Flags: review?(mwu)
Assignee: nobody → sotaro.ikeda.g
OS: Linux → Gonk (Firefox OS)
Hardware: x86_64 → ARM
Comment on attachment 8417678 [details]
link to pull request

According to http://hg.mozilla.org/mozilla-central/file/7dcb8e0d9668/widget/gonk/HwcComposer2D.cpp#l103 , ro.display.colorfill is only used on ICS. On JB/KK, we query the hwc module to determine colorfill support.
Attachment #8417678 - Flags: review?(mwu) → review-
Mwu, I created the patch because it is still used in the following. Can I have the comment about the following?
 http://mxr.mozilla.org/mozilla-central/source/b2g/chrome/content/settings.js#572
Flags: needinfo?(mwu)
(In reply to Sotaro Ikeda [:sotaro] from comment #4)
> Mwu, I created the patch because it is still used in the following. Can I
> have the comment about the following?
>  http://mxr.mozilla.org/mozilla-central/source/b2g/chrome/content/settings.
> js#572

The following is the correct line.
http://mxr.mozilla.org/mozilla-central/source/b2g/chrome/content/settings.js#565
Ah ok. That behavior shouldn't be relied on with JB and up. On JB and up, I think we should turn compositing on by default in the prefs since we have colorfill and rb swap support detection.
Flags: needinfo?(mwu)
Thanks. That seems reasonable.
Summary: [flame] MozBuild does not set "ro.display.colorfill" → [flame] MozBuild ROM does not use HWComposer
I confirmed the patch works correctly on master flame and master nexus-5.
Attachment #8419411 - Flags: review?(sushilchauhan)
Attachment #8419411 - Flags: review?(dwilson)
Status: NEW → ASSIGNED
Comment on attachment 8419411 [details] [diff] [review]
patch - Do not use "ro.display.colorfill" since JB

     if (typeof(req.result['layers.composer2d.enabled']) === 'undefined') {
-      var enabled = false;
+      var enabled = true;

There is problem here. When MOZ_WIDGET_GONK is not defined, then line # 569 will always set "layers.composer2d.enabled" to True:
navigator.mozSettings.createLock().set({'layers.composer2d.enabled': enabled });

I am not sure on which platforms, MOZ_WIDGET_GONK switch is not defined.
Attachment #8419411 - Flags: review?(sushilchauhan)
(In reply to Sushil from comment #9)
> Comment on attachment 8419411 [details] [diff] [review]
> patch - Do not use "ro.display.colorfill" since JB
> 
>      if (typeof(req.result['layers.composer2d.enabled']) === 'undefined') {
> -      var enabled = false;
> +      var enabled = true;
> 
> There is problem here. When MOZ_WIDGET_GONK is not defined, then line # 569
> will always set "layers.composer2d.enabled" to True:
> navigator.mozSettings.createLock().set({'layers.composer2d.enabled': enabled
> });
> 
> I am not sure on which platforms, MOZ_WIDGET_GONK switch is not defined.

MOZ_WIDGET_GONK is defined only on b2g device that used android base platform. b2g does not have this definition. But HWComposer is only defined only on GONK. Therefore it should not becomes a problem.
Anyway it seems safer to update the patch.
During debugging, I recognized that we can not use ANDROID_VERSION in js code.
Apply comment and remove ANDROID_VERSION.
Attachment #8419411 - Attachment is obsolete: true
Attachment #8419411 - Flags: review?(dwilson)
Attachment #8419564 - Flags: review?(sushilchauhan)
Attachment #8419564 - Flags: review?(dwilson)
Comment on attachment 8419564 [details] [diff] [review]
patch v2 - Do not use "ro.display.colorfill" since JB

LGTM. Please make sure Disable/Enable HWC from Settings, is not broken.
Attachment #8419564 - Flags: review?(sushilchauhan) → review+
Comment on attachment 8419564 [details] [diff] [review]
patch v2 - Do not use "ro.display.colorfill" since JB

Sushil's review is enough for the check-in.
Attachment #8419564 - Flags: review?(dwilson)
Attachment #8417678 - Attachment is obsolete: true
https://hg.mozilla.org/mozilla-central/rev/f49f0bcf49da
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Set "1.4?" flag. Without this fix, MozBuild rom does not use HwComposer on b2g v1.4 flame.
blocking-b2g: --- → 1.4?
Making it 1.4+ based on comment # 18
blocking-b2g: 1.4? → 1.4+
You need to log in before you can comment on or make changes to this bug.