Closed Bug 1006193 Opened 6 years ago Closed 6 years ago

[B2G][Tarako][Marketplace]Home Featured Apps are selectable for download when both Wi-Fi and Data Connection are off

Categories

(Marketplace Graveyard :: Consumer Pages, defect)

Avenir
ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mclemmons, Unassigned)

References

()

Details

(Whiteboard: [tarako-exploratory])

Attachments

(2 files)

Attached file Firewatch Log
User taps Marketplace with both Wi-Fi and Data Connection disabled on device to view the home page of Featured Apps. List includes YouTube, ConnectA2 and Tower Jelly, among others, and all have blue Free buttons selectable for potential download to right of each App. User can select any of the list and get the 'Install failed. Please try again later message' – except for Drawl. It takes sometimes multiple selections for an 'Oh no! A server error occurred. Please try again later' message on a new screen within Marketplace. The expected behavior would be similar to Games, Tools and Lifestyle, where the Free buttons are grayed out and doesn't allow user input until either Wi-Fi or Data Connection is turned on. 

Prerequisites:
1. Have both Wi-Fi and Data Connection disabled

Repro Steps
1) Updated Tarako to BuildID: 20140505173556 
2) Tap Marketplace
3) On Home, observe the blue free buttons to right of each listed App and tap each one.

Actual: 
All apps tapped display a message of 'Install failed. Please try again later message' at the bottom of the device screen, except for Drawl which requires sometimes three to four taps for a new Marketplace screen to display reading  'Oh no! A server error occurred. Please try again later' message

Expected: 
All Free buttons are greyed out and not selectable by user

Notes: 
Repro frequency: (10/10, 100%) 
See attached: Firewatch, Logcat - includes tap attempts on Drawl and other Apps on Home, Video clip = https://www.youtube.com/watch?v=c-bXG3iYHvo

Environmental Variables:
Device: Tarako 1.3T MOZ
BuildID: 20140505173556
Gaia: 48372ff88c712468a77a6f14a97f9978ee56eade
Gecko: 78015cc18d1f
Version: 28.1
Firmware Version: sp6821a_gonk4.0_user.pac
This issue does not reproduce on 1.3 Buri. With Wi-Fi or data disabled, user gets a 'Sorry, you need to be online to access the Marketplace' message before reaching Home. 

Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140505024001
Gaia: 667539f1ed4becc45b182a5f1046221d3eeb9e7c
Gecko: bf3fe474bf50
Version: 28.0
Firmware version: v1.2-device.cfg
The STR here isn't exactly right - if you connected to marketplace without a network connection, then you would get a marketplace offline error page. The STR really is:

1. Open marketplace with a network connection
2. Disable the connection
3. Try to install the featured apps

The errors fired here sound like the right behavior here because the installation is failing to install due to lack of network. I don't think it's worthwhile to have marketplace dynamically update itself if the network goes down, as that seems like overkill for very little value to add a slightly improved experience to improve install.

The server error however sounds like a bug. Can we get STR for that & open a separate bug for it?
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(mclemmons)
Resolution: --- → WONTFIX
(In reply to Jason Smith [:jsmith] from comment #3)
> The STR here isn't exactly right - if you connected to marketplace without a
> network connection, then you would get a marketplace offline error page. The
> STR really is:
> 
> 1. Open marketplace with a network connection
> 2. Disable the connection
> 3. Try to install the featured apps
> 

Actually I forgot that this is the tarako-specific marketplace, so the original STR is correct, since this is a hosted app w/appcache.
(In reply to Jason Smith [:jsmith] from comment #4)
> (In reply to Jason Smith [:jsmith] from comment #3)
> > The STR here isn't exactly right - if you connected to marketplace without a
> > network connection, then you would get a marketplace offline error page. The
> > STR really is:
> > 
> > 1. Open marketplace with a network connection
> > 2. Disable the connection
> > 3. Try to install the featured apps
> > 
> 
> Actually I forgot that this is the tarako-specific marketplace, so the
> original STR is correct, since this is a hosted app w/appcache.

Which then changes the bug's validity actually because we should be getting a graceful offline handling experience here.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Clearing the needinfo checkmark. Please needinfo me if you are requesting additional information.
Flags: needinfo?(mclemmons)
(In reply to mclemmons from comment #6)
> Clearing the needinfo checkmark. Please needinfo me if you are requesting
> additional information.

I did. I asked for a new bug to be filed for the server-side error.
Flags: needinfo?(mclemmons)
(In reply to Jason Smith [:jsmith] from comment #7)
> (In reply to mclemmons from comment #6)
> > Clearing the needinfo checkmark. Please needinfo me if you are requesting
> > additional information.
> 
> I did. I asked for a new bug to be filed for the server-side error.

Please see Bug 1006803.
Flags: needinfo?(mclemmons)
On Tarako:

If you launch the marketplace without an internet connection you see a full screen message saying you need to be online.  If you launch the marketplace and then turn off the internet connection you will either see cached data (browsing), or a network error (if you try to install something).

That is all by design and I think answers this bug so I'm going to close it.
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.