All users were logged out of Bugzilla on October 13th, 2018

Turbo: QuickLaunch is running older build/version, than what was last installed

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
17 years ago
6 years ago

People

(Reporter: jaimejr, Unassigned)

Tracking

Trunk
x86
Windows 98
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [correctness])

(Reporter)

Description

17 years ago
Build ID:  2001-09-19-05-0.9.4
Reproducible: Always

Steps:
1. Install a daily branch build with QuickLaunch enabled.
2. Launch the browser, play for a while, notice bad UI elements, get another build.
3. Install another daily branch build, into a seperate directory

Results: It appears QuickLaunch is launching the older build, instead of the new
one I have installed. Why do I think this? Because it exhibits different
behavior, from between, the new build launched from the short cut on my desktop,
and the what looks like the previous build.

Note: This could affect people testing the QuickLaunch feature.

Comment 1

17 years ago
Did you exit the program (including QuickLaunch) before running the installer? 
If not, did the installer fail to detect the running version?  How is
QuickLaunch running after the install?

Updated

17 years ago
Blocks: 75599

Comment 2

17 years ago
->XP Apps. 
Assignee: asa → pchen
Component: Browser-General → XP Apps
QA Contact: doronr → sairuh
(Reporter)

Comment 3

17 years ago
Answer to Peter's questions:

1) Did you exit the program (including QuickLaunch) before running the
installer? - Yes.

2) If not, did the installer fail to detect the running version? - I think the
installer can detect between versions, like 6.0 and 6.1, but may be having
problems between intra-version detection of daily builds.

3) How is QuickLaunch running after the install? Selected, QuickLaunch to be on
in install dialogue.

Note: QuickLaunch also running after a reboot, irrespective if I exit or disable
it. Filed Bug 101144.

Keywords: nsbranch
(Reporter)

Updated

17 years ago
Whiteboard: [correctness]

Comment 4

17 years ago
See also bug 89781, [rfe] make quick launch compare versions before using 
existing process.  That covers the case of using zip builds instead of 
installer builds, and would also be good for QA wanting to quickly switch 
between two different builds.
(Reporter)

Updated

17 years ago
Depends on: 89781
QA Contact: sairuh → tpreston

Comment 5

17 years ago
Not likely to affect the vast majority of nsbranch users: nsbranch-
Keywords: nsbranch → nsbranch-

Updated

17 years ago
Blocks: 107067

Updated

17 years ago
Keywords: nsbranch-

Comment 6

17 years ago
Trying to reproduce using 2001-10-22-06-trunk and 2001-10-29-06-trunk builds but
not having any success. I install 10-22-06 first, then 10-29-06 (in a different
folder) and don't have any mixups. If there's any other info on how to
reproduce, I'm all ears.

Comment 7

17 years ago
Marking p3 and mozilla1.1, will move in once I can reproduce
Priority: -- → P3
Target Milestone: --- → mozilla1.1

Comment 8

17 years ago
-> default assignee
Assignee: pchen → trudelle
QA Contact: tpreston → sairuh
Target Milestone: mozilla1.1 → ---

Comment 9

17 years ago
->future
Target Milestone: --- → Future
(Reporter)

Comment 10

17 years ago
what is the reason we are futuring this one?

Comment 11

17 years ago
How many users have multiple builds?

Comment 12

17 years ago
Even with multiple builds, this is difficult for developers to reproduce. 
(Reporter)

Updated

17 years ago
No longer blocks: 107067

Updated

17 years ago
No longer blocks: 75599

Updated

17 years ago
Blocks: 75599
Product: Core → Mozilla Application Suite

Comment 13

12 years ago
Quicklaunch is done based on: Bug 383161 – keep in memory (turbo mode?) for
faster startup not working

so this one should be WONTFIX I guess.
Assignee: trudelle → jag
Priority: P3 → --
QA Contact: bugzilla
Target Milestone: Future → ---

Comment 14

10 years ago
(In reply to comment #13)
> Quicklaunch is done based on: Bug 383161 – keep in memory (turbo mode?) for
> faster startup not working
> 
> so this one should be WONTFIX I guess.

Which in turn is a duplicate of:  Bug 361682 -  Remove "turbo mode" from suiterunner builds

Comment 15

10 years ago
=> WONTFIX - turbo is gone after SM v1.1
Status: NEW → RESOLVED
Last Resolved: 10 years ago
QA Contact: ui-design
Resolution: --- → WONTFIX

Updated

7 years ago
Assignee: jag-mozilla → nobody
Component: UI Design → QuickLaunch (AKA turbo mode)
Product: SeaMonkey → Core
QA Contact: ui-design → quicklaunch
(Assignee)

Updated

6 years ago
Component: QuickLaunch (AKA turbo mode) → QuickLaunch (AKA turbo mode)
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.