Closed Bug 1006283 Opened 6 years ago Closed 6 years ago

Set correct datatype in paramlist for web audio nodes in web audio editor

Categories

(DevTools Graveyard :: Web Audio Editor, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 32

People

(Reporter: jsantell, Assigned: jsantell)

References

Details

Attachments

(1 file, 1 obsolete file)

When setting a number AudioParam in the web audio editor, it's displayed as a string in the ParamList. The underlying AudioParam still changes but is displayed as a quoted, or double quoted, string.
Assignee: nobody → jsantell
Attachment #8418226 - Flags: review?(vporof)
Comment on attachment 8418226 [details] [diff] [review]
1006283-paramlist-data-type.patch

Review of attachment 8418226 [details] [diff] [review]:
-----------------------------------------------------------------

r+, but with the concern below.

::: browser/devtools/webaudioeditor/webaudioeditor-view.js
@@ +272,5 @@
> +    let error;
> +
> +    // Cast value to proper type
> +    try {
> +      value = eval(value);

What happens if I eval "alert(1)"? Why not use JSON.parse here?
Attachment #8418226 - Flags: review?(vporof) → review+
Good call -- changed to JSON.parse
Attachment #8418226 - Attachment is obsolete: true
Attachment #8418312 - Flags: review+
Duplicate of this bug: 1006729
https://hg.mozilla.org/integration/fx-team/rev/dfba6113cb02
Flags: in-testsuite+
Keywords: checkin-needed
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/dfba6113cb02
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 32
Product: Firefox → DevTools
Product: DevTools → DevTools Graveyard
You need to log in before you can comment on or make changes to this bug.