Closed Bug 1006352 Opened 5 years ago Closed 5 years ago

Extension does not load on launch

Categories

(Firefox :: Untriaged, defect)

29 Branch
x86
macOS
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: cmhofman, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140421221237

Steps to reproduce:

Launch FireFox (with preset home page and using extensions including Adblock-Plus)


Actual results:

The home page opened, but showing all the ads, which means Adblock-Plus was not activated.

When I close the window and reopen, the ads are gone, so Adblock-Plus was loaded. Just not the first time.


Expected results:

The home page should be shown without the ads, i.e. Adblock-Plus should have been activated.
This is almost certainly an issue with adblockplus, and should be reported to them instead of here.
Blocks: abp
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → INVALID
I don't think so. It used to work in earlier versions of FireFox. But with 29.0 it failed. So it was FF that made the difference, not Adblock.
(In reply to Christiaan Hofman from comment #2)
> I don't think so. It used to work in earlier versions of FireFox. But with
> 29.0 it failed. So it was FF that made the difference, not Adblock.

It's possible that a Firefox upgrade broke ABP, but that's no guarantee that the problem is with Firefox.

Wladimir, any chance you can investigate further and/or is this a known issue at all?
Flags: needinfo?(trev.moz)
This is https://issues.adblockplus.org/ticket/418.
Flags: needinfo?(trev.moz)
For reference, the change in question is https://adblockplus.org/development-builds/faster-firefox-startup (https://issues.adblockplus.org/ticket/117), it was released with Firefox 2.6.
Ouch, I meant Adblock Plus 2.6 in the previous comment of course.
You need to log in before you can comment on or make changes to this bug.