Closed Bug 1006375 Opened 7 years ago Closed 7 years ago

[NFC] NfcManager handleTechnologyDiscovered tests

Categories

(Firefox OS Graveyard :: NFC, defect)

defect
Not set
normal

Tracking

(tracking-b2g:backlog)

RESOLVED FIXED
2.0 S5 (4july)
tracking-b2g backlog

People

(Reporter: tauzen, Assigned: tauzen)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_2) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/34.0.1847.131 Safari/537.36

Steps to reproduce:

As handledTechnologyDiscovered method deals with main NFC functionalities we need to provide tests for it before starting to work on any refactoring in other bugs.
I would like to work on this.
Blocks: b2g-NFC-2.0
Assignee: nobody → kmioduszewski
I've requested editbugs permission for Krzysztof, it should be working now.
Please let me know if you still cannot take the bug.
blocking-b2g: --- → backlog
Depends on: 1016377
Depends on: 1017572
Depends on: 1018308
Attachment #8442675 - Flags: review?(gweng)
Comment on attachment 8442675 [details] [review]
pull-request-1006375.txt

There is no obvious errors and it helps to improve our tests. Unfortunately it conflicts with the current master, so please solve them than I can set the r+. Thanks!
Attachment #8442675 - Flags: review?(gweng)
Comment on attachment 8442675 [details] [review]
pull-request-1006375.txt

When I was uploading the patch the latests changes in gaia were not present. Rebased and resolved conflicts. Travis is green now. Can you take a look once more?
Attachment #8442675 - Flags: review?(gweng)
Blocks: 1027568
Blocks: 1017111
Comment on attachment 8442675 [details] [review]
pull-request-1006375.txt

When I come back it conflict again, which may be caused by some LockScreen patchs that reverted recently. I think once you resolve it we can merge it as soon as possible, thanks.

r+ according to the previous patch, which keeps the major content during the conflict resolving.
Attachment #8442675 - Flags: review?(gweng) → review+
Yes, it was conflicted with the LockScreen revert. I solved the conflicts and pushed the updated version to github. Once Gaia-Try is ok can I add checkin-needed? Or do I have to wait for travis also? It seems that all travis builds are failing right now.
Flags: needinfo?(gweng)
It bothers me as well. However one of my colleague told me that he encountered the similar case once and the patch had been landed according to the TBPL result. So I think it's OK to land your patch.
Flags: needinfo?(gweng)
master: https://github.com/mozilla-b2g/gaia/commit/2d0b102b0f63e19bf2bdb5f6e3a84807c092fc1d
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.0 S5 (4july)
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.