MozillaControl profile appearing

VERIFIED DUPLICATE of bug 76664

Status

SeaMonkey
Startup & Profiles
VERIFIED DUPLICATE of bug 76664
17 years ago
13 years ago

People

(Reporter: Jesse Houwing, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Once in a while mozilla starts and asks me to chose between my default profile
and a prozile called "MozillaControl". But I never made this profile, nor do I
know why it's there.

Is this a bug or a feature? And if it's a feature then what does it do and
shouldn't people be informed about what it does?

Comment 1

17 years ago
what version/build  of Mozilla are you using? I have not seen that profile here- 
ever.  What kind of install? Anything else you can tell us so we can try and 
reproduce?
(Reporter)

Comment 2

17 years ago
I've seen it several times in the last say 6 weeks it seems to happen after
mozilla crashed but I can't reproduce it.

I'm always using win32 talkback zips, and update the nigthly everyday. It
happened yesterday with the 19 september build.

Updated

17 years ago
QA Contact: ktrina → gbush

Comment 3

17 years ago
Are you still seeing this? Check all application data directories in all windows
profiles. See if you see a MozillaControl profile. I've know of explorer crashes
to result in pointing to other windows profiles.
(Reporter)

Comment 4

17 years ago
I'm not going to clear all the applicationdata directories in all the
userprofiles, that way I'll and all the other users will loose all their settings.

I've found that it appears once on a while. Chosing the Mozilla profiel manager
and hitting delete profile on MozillaControl just works. It just shouldn't
appear at all. I've seen thsi happening yesterday (with yesterdays build under
winnt4/wks) and last week twice under win2k.

I've also seen this happen on "fresh" mozilla installs on multiple systems
(Reporter)

Comment 5

17 years ago
Mozilla profile only exist under the rigth Application Data folders. I've
checked that.

I'll upload a archive with the MozillaProfile directory as it is generated once
every week or so :)
(Reporter)

Comment 6

17 years ago
Created attachment 55389 [details]
RAR archive of Mozilla Profile directory containing MozillaControl  profiles

Comment 7

16 years ago
Jesse, if you delete that profile does it still come back? Can you test this
with 0.9.7 or a recent nightly? thanks.
(Reporter)

Comment 8

16 years ago
tried the last 0.9.6... and it still does but less frequently. I haven't seen it
in 0.9.7 but I can't yet say with certainty that it doesn't occur anymore.
(Reporter)

Comment 9

16 years ago
It appeared again (after a crash, it seems to have to do with crashing :)

I can delete it again from the profile manager and go on as usual. this happened
in the 25th January build. It isn't as often though.
(Reporter)

Comment 10

16 years ago
Had it again (this time in 0.9.8) the 1st feb win2k build.

Comment 11

16 years ago
This occurs for me as well.  If the browser is used through its activex control
in Winamp3, Scope, or similar applications, this profile is created for use by
the ActiveX control.
I always have the problem when I start Mozilla.
It started after I installed Winamp3 and did regsvr32 mozctlx.dll so I could use
the minibrowser.
I'm using 0.9.8 (2002020406) on Windows ME.

Comment 13

16 years ago
*** Bug 130021 has been marked as a duplicate of this bug. ***

Comment 14

16 years ago
At least 4 people have seen this bug - resolving as new.

Strangely enough: 3 of those who have reported seeing it are located in the
Netherlands. Coincidense or some weird ActiveX nationalization issue?

Brant Langer Gurganus: Can there be anything to this theory?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 15

16 years ago
I'm using Mozilal in Topstyle, and it too uses the active X control.\

BUT I'm also using Windows 2000 Professional US, so it isn't anything with my
language version, as I'm on a all english system. The only thing in dutch are my
spelling routines in word :)

Comment 16

16 years ago
I'm also using Mozilla in TopStyle 2.5 and (now I remember again), the last time
before the profile was added, i used TopStyle.

Comment 17

16 years ago
The "MozillaControl" profile is created when you run an app that embeds the
Mozilla ActiveX control. The control automatically creates this profile to
provide a place to store its cache data, prefs etc. The alternative is to do
what mfcEmbed does and implement a directory location provider that provides an
alternate location for storing the control profile.

Bug 76664 explains the issue so I'll dupe this bug against that.

*** This bug has been marked as a duplicate of 76664 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 18

16 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.