Closed Bug 1006521 Opened 8 years ago Closed 8 years ago

[Contacts][Facebook] Wrong behavior when removing from an imported FB contact Name or Last name fields

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(tracking-b2g:backlog, b2g-v2.0 fixed)

RESOLVED FIXED
2.0 S2 (23may)
tracking-b2g backlog
Tracking Status
b2g-v2.0 --- fixed

People

(Reporter: noemi, Assigned: crdlc)

References

Details

Attachments

(3 files)

Pre-requisites:
- Have one FB contact imported (with Name and Last name)

*scenario 1: removing Name
STRs:
1- Tap on contacts app
2- Tap on FB contact
3- Tap on Edit
4- Remove Name
5- Tap on Update

ACTUAL RESULT:
In contact details screen still appears Name and Last name information but only Last name info is appearing in the contact list

EXPECTED RESULT:
In both views (contact details and contact list) only Last name info should appear


*scenario2: removing Last Name
STRs:
1- Tap on contacts app
2- Tap on FB contact
3- Tap on Edit
4- Remove Last name
5- Tap on Update

ACTUAL RESULT:
You will remain in Edit contact screen forever (updating process never finishes). It is necessary to kill Contacts app to get rid of it

EXPECTED RESULT:
The contact information is properly shown in contact details and contact list, only the contact name should appear

Environmental variables (today's (5/6) master build):
Device: Hamachi
BuildId: 20140506093558
Gecko: 3ac253f
Gaia: 0639811
Platform version: 32.0a1
blocking-b2g: --- → backlog
Assignee: nobody → crdlc
will do tomorrow if there wouldn't be blockers during next hours
Assignee: crdlc → nobody
I've released it because of someone could want to take it while I am doing other bugs
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
Attached file Github pull request
Attachment #8420020 - Flags: review?(jmcf)
Comment on attachment 8420020 [details]
Github pull request

LGTM, tested and work. please land once travis is green and set the verifyme flag in order QA can test it properly
Attachment #8420020 - Flags: review?(jmcf) → review+
Merged in master:

https://github.com/mozilla-b2g/gaia/commit/e8a1eedb848382323254edbd234baecebc5dc5ca
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Keywords: verifyme
Target Milestone: --- → 2.0 S2 (23may)
This bug has been failed verified on latest Flame v2.0.
See attachments: new_logcat_1343.txt and new_fb_contact.MP4.
Reproduce rate: 5/5.

Repro STR:
1.Import FB contacts.
2.Open a FB contact to view.
3.Tap Edit.
4.Tap X icon to remove "Name" (or "Last name") field.
5.Tap Update.
**It still shows the original name and original last name.--KO
6.Tap < icon to back to contact list.
**It still shows the original name and original last name.--KO
7.Edit FB contact again,input some words to change Name or Last name.
**Name or last name can be changed successfully.

Flame v2.0 build:
Gaia-Rev        2989f2b2bd12fcc0e9c017d2db766e76a55873b8
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/b4c61fd1dcfc
Build-ID        20150126000204
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150126.033406
FW-Date         Mon Jan 26 03:34:17 EST 2015
Bootloader      L1TC000118D0
Flags: needinfo?(whsu)
Hi William,
 
    Could you help with this bug?

Thank you.
(In reply to Shally from comment #7)
> Hi William,
>  
>     Could you help with this bug?
> 
> Thank you.

This patch has been merged six months ago.
It is hard to trace the root cause.
Can we submit a follow-up bug?
Flags: needinfo?(whsu) → needinfo?(lixia)
(In reply to William Hsu [:whsu] from comment #10)
> This patch has been merged six months ago.
> It is hard to trace the root cause.
> Can we submit a follow-up bug?

Yes,I will note this Bug ID later.
Flags: needinfo?(lixia)
See Also: → 1126235
Hi William,

    The follow-up bug is bug 1126235.
Flags: needinfo?(whsu)
Roger that!
Thank you, Shally! :)
Flags: needinfo?(whsu)
QA Whiteboard: [MGSEI-Triage+]
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.