Closed Bug 1006598 Opened 6 years ago Closed 6 years ago

Rename some Ion* frame layout classes to Jit*

Categories

(Core :: JavaScript Engine: JIT, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1102538

People

(Reporter: jandem, Assigned: jandem)

Details

Attachments

(1 file)

Attached patch PatchSplinter Review
This week's Ion -> Jit renaming.

This patch renames all frame layout classes that are also used by Baseline from Ion* to Jit*. It also renames IonBaselineStubFrameLayout to BaselineStubFrameLayout.

I did not change the classes that are only used by Ion, like IonOOLPropertyOpExitFrameLayout.
Attachment #8418101 - Flags: review?(nicolas.b.pierron)
Comment on attachment 8418101 [details] [diff] [review]
Patch

Review of attachment 8418101 [details] [diff] [review]:
-----------------------------------------------------------------

After reading the patch, I found kind of weird that we have most frames starting with Jit* except the Baseline one, as if BaselineStub was not a frame of generated code.

After discussing with jandem over IRC, we should try to remove the "Jit" prefix from trampolines (RectifierFrameLayout, ExitFrameLayout, EntryFrameLayout), and potentially rename JitJSFrameLayout to JitFrameLayout.
Attachment #8418101 - Flags: review?(nicolas.b.pierron)
jandem suggested I take this over in bug 1102538.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1102538
You need to log in before you can comment on or make changes to this bug.