Closed Bug 1006627 Opened 8 years ago Closed 7 years ago

Recent upgrade has introduced a rendering regression on scroll

Categories

(Websites :: wiki.mozilla.org, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: u279076, Unassigned)

References

Details

(Keywords: regression, Whiteboard: [gmo])

Attachments

(1 file)

Ever since the new editor was pushed in a recent update I'm getting a rendering issue when scrolling on Linux. I've attached a screenshot which shows the problem. Basically, when I edit a long section and scroll down in the edit box part of the content disappears momentarily. It reappears after a few seconds.

It's not impossible to work around: I can either use some other text editor or wait-out the rendering glitches. However, this is decreasing my productivity.
Keywords: regression
I can definitely reproduce this easily on my Linux Nightly.
Same on Linux is both nightly and release. Any non-linux users seeing this?
(In reply to Christie Koehler [:ckoehler] from comment #2)
> Same on Linux is both nightly and release. Any non-linux users seeing this?

Not seeing this with today's nightly on Windows 7: Build identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0
I've been seeing this for months, not always on wiki.mo, but most often here.  I'll start paying attention to other places I see it now, although it's definitely reproducible every time on wiki.mo after the latest upgrade.
Meanwhile, on wikimo, the workaround is as follows:

1. Login to wiki.mozilla.org
2. Visit https://wiki.mozilla.org/Special:Preferences#mw-prefsection-editing
3. Uncheck everything under "beta features" and "labs features" and save

This will get you the "old" editing interface.
(In reply to Christie Koehler [:ckoehler] from comment #5)
> Meanwhile, on wikimo, the workaround is as follows:
> 
> 1. Login to wiki.mozilla.org
> 2. Visit https://wiki.mozilla.org/Special:Preferences#mw-prefsection-editing
> 3. Uncheck everything under "beta features" and "labs features" and save
> 
> This will get you the "old" editing interface.

Thanks!
My best guess is that this is a bug of some sort in the upstream WikiEditor code. I can't think of anything server-side that would cause this sort of behavior. Might be improved in newer Mediawiki versions... IIRC WikiEditor version is tied to Mediawiki version, so we probably have to upgrade everything to get updates to WikiEditor.
What theme are people using?

I see the issue using GMO (default), but if I switch to vector in my preferences, scrolling works fine.
Whiteboard: [gmo]
Duplicate of this bug: 1044164
We've de-activated and removed the GMO skin, so I think we can close this bug as WONTFIX.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.