Closed Bug 1006807 Opened 6 years ago Closed 6 years ago

Uninstalling from app permissions does not return you to previous screen

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

x86
macOS
defect
Not set

Tracking

(blocking-b2g:2.0+, b2g-v2.0 fixed)

VERIFIED FIXED
2.0 S3 (6june)
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- fixed

People

(Reporter: nick, Assigned: eragonj)

Details

(Keywords: regression)

Attachments

(1 file)

STR:
1. Install LOL keyboard from marketplace
2. Settings > App Permissions > LOL Keyboard
3. Uninstall App

Expected:
Return to App Permissions listing of installed apps

Actual:
Stay on page, can repeatedly keep clicking uninstall

The expected works on a 1.4 Flame with Git commit info from 2014-05-02
The actual is experienced in 2.0 Simulator with Git commit info from 2014-05-01
Component: Gaia::Keyboard → Gaia::Settings
blocking-b2g: --- → 2.0?
This is a bug in Settings when doing refactor works.

I can help to fix it :)
Assignee: nobody → ejchen
QA Wanted to confirm this is working on 1.4.
Keywords: qawanted
From Comment 0, It looks like the reporter has somehow tested this on 1.4 Flame and seen correct behavior. But for some reason, I'm unable to install the LoL keyboard on any device running anything below v2.0. Tried 2 devices with Flame 5/29 1.4 build and an OpenC 1.3 Base. The keyboard says it installs but is not found anywhere under Settings->Keyboards or in App Permissions.

Looking at the description in the app on the Marketplace, says that "This app ONLY works for devices running firefox os 2.0. It will NOT work on older versions of firefox OS."

On OpenC 2.0, I have verified the bug exists however.
Keywords: qawanted
QA Contact: croesch
Can you try testing this with a different app? Say Wikipedia?
Keywords: qawanted
Using Wikipedia App

On OpenC v2.0 this bug Does Repro. User can keep tapping Uninstall without being taken back to list.

Environmental Variables
Device: OpenC v2.0
Build ID: 20140529040201
Gecko: https://hg.mozilla.org/mozilla-central/rev/1e712b724d17
Gaia: 4142df90c71abdc1e3a87cd37dff1a22d5e38b34
Platform Version: 32.0a1
Firmware Version: P821A10v1.0.0B06_LOG_DL

-----------------------------------------------

On Flame v1.4 this bug does NOT repro. User is correctly taken back to app list once Uninstall is tapped.

Environmental Variables
Device: Flame v1.4
Build ID: 20140529000204
Gecko: https://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/2181cac4d0fc
Gaia: 7bc1c15c67661a0b8e35f18f15a9d03d1d2cfcd5
Platform Version: 30.0
Firmware Version: v10G-2
Keywords: qawanted
blocking-b2g: 2.0? → 2.0+
Comment on attachment 8431302 [details] [review]
patch on master

Arthur,

can you help me review this tiny patch ? 

thanks :)
Attachment #8431302 - Flags: review?(arthur.chen)
Comment on attachment 8431302 [details] [review]
patch on master

r=me, good job!
Attachment #8431302 - Flags: review?(arthur.chen) → review+
Thanks all, landed on Gaia/master: d3239aa7540746eeb4c5eeabf7fdf44632860ec1
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.0 S3 (6june)
Thanks everyone!
I cannot reproduce it on the latest V2.0 build.
Mark it as "VERIFIED"

* Build Information:
 - Gaia      8d865839d932bfbd5e157f376f74d8cb12bfdd51
 - Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/1d4046a8cb6c
 - BuildID   20140610000223
 - Version   32.0a2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.