Closed Bug 1006973 Opened 6 years ago Closed 6 years ago

Fix bustage in casting pageaction

Categories

(Firefox for Android :: Screencasting, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 32
Tracking Status
firefox31 --- fixed
firefox32 --- fixed

People

(Reporter: mfinkle, Unassigned)

References

Details

Attachments

(1 file)

I screwed up when refactoring code during the review process in bug 1001280. Grrr.

This patch fixes a JS error and allows the pageaction to work.
Attachment #8418519 - Flags: review?(wjohnston)
Comment on attachment 8418519 [details] [diff] [review]
fix-pageaction v0.1

Wes is PTO the next two days
Attachment #8418519 - Flags: review?(wjohnston) → review?(blassey.bugs)
Comment on attachment 8418519 [details] [diff] [review]
fix-pageaction v0.1

Review of attachment 8418519 [details] [diff] [review]:
-----------------------------------------------------------------

I'm still alive till Thursday!

::: mobile/android/chrome/content/CastingApps.js
@@ +89,5 @@
>        case "ended": {
>          let video = aEvent.target;
>          if (video instanceof HTMLVideoElement) {
> +          // If playing, send the <video>, but if ended we send nothing to shutdown the pageaction
> +          this._updatePageActionForVideo(aEvent.type == "playing" ? video : null);

===
Attachment #8418519 - Flags: review?(blassey.bugs) → review+
https://hg.mozilla.org/mozilla-central/rev/e37c6d3bc781
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 32
Comment on attachment 8418519 [details] [diff] [review]
fix-pageaction v0.1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 1001280 had a refactor bug
User impact if declined: feature does not work
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): low, and proven to fix the issue
String or IDL/UUID changes made by this patch: none
Attachment #8418519 - Flags: approval-mozilla-aurora?
Attachment #8418519 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.