Closed Bug 1007300 Opened 6 years ago Closed 6 years ago

Rendering of the "Not Now" menu item in popup notifications is messed up

Categories

(Toolkit :: XUL Widgets, defect)

31 Branch
x86_64
Linux
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla32
Tracking Status
firefox31 + verified
firefox32 + verified

People

(Reporter: Aleksej, Assigned: dao)

References

Details

(Keywords: regression, Whiteboard: p=1 s=33.1 [qa!])

Attachments

(1 file)

Steps to reproduce:
1. Save attachment 8418090 [details].
2. Open it in Firefox.
3. Click the field with "Enter your address".
4. In the doorhanger, click the down arrow near "Share Location".

Actual results:
The menu item that appears contains only a red close button.

Expected results:
The menu item contains text "Not Now".


When the page is opened from the Web, the menu contains (note the differing alignment of Not Now):
*  "Always Share Location"
*  "Never Share Location"
-------------------------
* "Not Now [x]"



In both cases here, the menu has dark background here, like normal drop-down menus (a Shiki color theme).


Regression range:
good 2014-04-25-03-02-09-mozilla-central-firefox-31.0a1.en-US.linux-x86_64 b836d89be72b
bad  2014-04-26-03-02-04-mozilla-central-firefox-31.0a1.en-US.linux-x86_64 0e91262606a6
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b836d89be72b&tochange=0e91262606a6

A smaller range:
WFM with 20140425130409 https://hg.mozilla.org/integration/mozilla-inbound/rev/cfe59efce491
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=cfe59efce491&tochange=0e91262606a6
QA Whiteboard: [bugday-20140512]
Summary: Geolocation doorhanger in this file has no text in "Not now" menu item when opened locally (shows icon only). → Geolocation doorhanger in this file has no text in "Not Now" menu item when opened locally (shows icon only).
Could you try to manually narrow down the range using TBPL and the fx-team tree, instead of mozilla-inbound? I suspect the breaking change landed there. Here's a link:

https://tbpl.mozilla.org/?tree=Fx-Team&fromchange=1c2ef0d3d997&tochange=fcf19894d9f3

You can click the "B" next to Linux / Linux 64 (depending on whether you need 32 or 64 bit binaries) in the rows labelled "Opt" or "PGO" (DON'T use the ones labelled "Debug" because they're really slow) and then click "go to build directory" at the bottom left to find a tarball with the right build.


(Unfortunately mozregression doesn't do this for you, it's being discussed here: https://github.com/mozilla/mozregression/issues/79 but so far nobody has managed to make it happen. :-( )
Flags: needinfo?(deletesoftware+moz)
Flags: needinfo?(jaws)
(In reply to [:Aleksej] from comment #2)
> -g
> http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/fx-team-
> linux64/1398428049/
> -b
> http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/fx-team-
> linux64/1398429071/
> 
> https://tbpl.mozilla.org/?tree=Fx-
> Team&fromchange=e91a5803fa7a&tochange=1f5f1fe135b9
> 
>     1f5f1fe135b9 Dão Gottwald – Bug 865826 - Remove the
> browser.tabs.closeButtons pref. r=jaws

Thanks!
Flags: firefox-backlog+
I can't seem to reproduce on Latest Nightly (on Windows 8.1)
(In reply to Tim Nguyen [:ntim] from comment #4)
> I can't seem to reproduce on Latest Nightly (on Windows 8.1)

I expect it to be a Linux theme issue, although I can't be sure without actually checking what's going on on Linux.
(In reply to :Gijs Kruitbosch from comment #1)
> (Unfortunately mozregression doesn't do this for you, it's being discussed
> here: https://github.com/mozilla/mozregression/issues/79 but so far nobody
> has managed to make it happen. :-( )

Aleksej pointed out to me this link is dead. I think it's now tracked in bug 997322.
Attached patch patchSplinter Review
close-icon should only be set on elements that /are/ close buttons rather than on elements want to embed a close icon somewhere. The latter doesn't work with the Linux theme in particular, where close-icon is implemented using background-image instead of list-style-image.
Assignee: nobody → dao
Status: NEW → ASSIGNED
Attachment #8419944 - Flags: review?(jaws)
Flags: needinfo?(jaws)
Flags: needinfo?(dao)
Component: General → XUL Widgets
Product: Firefox → Toolkit
Summary: Geolocation doorhanger in this file has no text in "Not Now" menu item when opened locally (shows icon only). → Rendering of the "Not Now" menu item in popup notifications is messed up
Attachment #8419944 - Flags: review?(jaws) → review+
https://hg.mozilla.org/mozilla-central/rev/4d044c48fd97
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla32
No longer blocks: 1009654
Duplicate of this bug: 1009654
Comment on attachment 8419944 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 865826
User impact if declined: see comment 0
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): no risk
String or IDL/UUID changes made by this patch: none
Attachment #8419944 - Flags: approval-mozilla-aurora?
Attachment #8419944 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
QA Whiteboard: [bugday-20140512] → [bugday-20140512][good first verify]
Hi,

I was able to reproduce it on Mozilla/5.0 (X11; Linux x86_64; rv:32.0) Gecko/20100101 Firefox/32.0 ID:20140507030202 and I can confirm it's fixed on latest Beta (Firefox/31.0 ID:20140619131915) as well as on latest Aurora (Firefox/32.0 ID:20140620004003).

Still some weird behaviour of the geolocation window, but that's related to https://bugzilla.mozilla.org/show_bug.cgi?id=58441.

Cheers,
Francesca
Status: RESOLVED → VERIFIED
QA Whiteboard: [bugday-20140512][good first verify] → [bugday-20140512][good first verify][testday-20140620]
Hi Dao, can you provide a point estimate and I'll add it to the current iteration.
Flags: needinfo?(dao)
Whiteboard: p=0 s=33.1 [qa?]
Flags: needinfo?(dao)
Whiteboard: p=0 s=33.1 [qa?] → p=1 s=33.1 [qa!]
You need to log in before you can comment on or make changes to this bug.