focus changes when browser loads

VERIFIED DUPLICATE of bug 76621

Status

--
trivial
VERIFIED DUPLICATE of bug 76621
18 years ago
14 years ago

People

(Reporter: bannerman, Assigned: saari)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20010917
BuildID:    2001091712

When I load Mozilla with a blank page as default, focus is initially on the
location text field but changes when the application is done loading.

Reproducible: Always
Steps to Reproduce:
1.Change default start page to "blank page".
2.Start Mozilla

Actual Results:  The focus was somewhere not on the location text box.

Expected Results:  When a user sets their default page to blank page, it's so
they can load Mozilla and enter a new web site. They WILL want the focus to be
on the location bar, thus generating an unneeded mouse click every time.
is this a dupe? and/or is this a toolkit/focus issue?
Assignee: pchen → saari
Component: XP Apps → XP Toolkit/Widgets
QA Contact: sairuh → jrgm
Whiteboard: dupeme?
(Reporter)

Comment 2

18 years ago
Identical behavior under Windows 2000.

Comment 3

18 years ago
This might be a duplicate of bug 76621.  bannerman@rocketmail.com, if you open 
the sidebar after the location bar loses focus, does something in the sidebar 
have focus?
Component: XP Toolkit/Widgets → XP Apps
QA Contact: jrgm → sairuh
Whiteboard: dupeme?
(Reporter)

Comment 4

18 years ago
Your right. I must be on crack. Resolved as dupe.

*** This bug has been marked as a duplicate of 76621 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 5

18 years ago
Don't worry about it.  Several other people have encountered this bug and also 
not known that it was because of the sidebar (look at the number of duplicates 
on bug 76621).
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.