Closed Bug 1007512 Opened 6 years ago Closed 6 years ago

OdinMonkey: Assertion failure: data.s.payload.why == why, at dist/include/js/Value.h

Categories

(Core :: JavaScript Engine: JIT, defect)

x86_64
macOS
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla32

People

(Reporter: gkw, Assigned: shu)

References

Details

(Keywords: assertion, regression, testcase, Whiteboard: [jsbugmon:update])

Attachments

(2 files)

Attached file stack
new(function(stdlib, n, heap) {
    "use asm"
    var x = new stdlib.Uint32Array(heap)
    function f() {}
    return f
})

asserts js debug shell on m-c changeset 4c4dcf7533cb with --ion-eager --ion-parallel-compile=off at Assertion failure: data.s.payload.why == why, at dist/include/js/Value.h

My configure flags are:

CC="clang -Qunused-arguments" CXX="clang++ -Qunused-arguments" AR=ar sh /Users/skywalker/trees/mozilla-central/js/src/configure --target=x86_64-apple-darwin12.5.0 --enable-optimize --enable-debug --enable-profiling --enable-gczeal --enable-debug-symbols --disable-tests --with-ccache --enable-threadsafe <other NSPR options>

=== Tinderbox Build Bisection Results by autoBisect ===

The "good" changeset has the timestamp "20140430134811" and the hash "34736c996ff7".
The "bad" changeset has the timestamp "20140430142911" and the hash "a0666ad474fa".

Likely regression window: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=34736c996ff7&tochange=a0666ad474fa

Benjamin, is bug 999790 a likely regressor?
Flags: needinfo?(benj)
No, this is most likely my fault.

We seem to be trying to monitor a magic JS_IS_CONSTRUCTING value.
Flags: needinfo?(benj)
Turns out wasn't my fault, and happily the fix was a one liner.
Attachment #8419218 - Flags: review?(luke)
Comment on attachment 8419218 [details] [diff] [review]
Propagate construct flag correctly when failing to link asm.js module.

Thanks!
Attachment #8419218 - Flags: review?(luke) → review+
https://hg.mozilla.org/mozilla-central/rev/8b70092ccb11
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla32
Assignee: nobody → shu
Depends on: 1025005
You need to log in before you can comment on or make changes to this bug.