Closed Bug 1007761 Opened 7 years ago Closed 7 years ago

firefox failed to exit and an error was produced on the xterm

Categories

(Firefox :: General, defect)

32 Branch
x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1012466

People

(Reporter: iii_iii, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux i686; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 2014042500

Steps to reproduce:

Exit firefox



Actual results:

1399569213832     addons.manager  ERROR   Exception calling provider shutdown: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIObserverService.removeObserver]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: resource://app/modules/experiments/Experiments.jsm :: this.Experiments.PreviousExperimentProvider.prototype<.shutdown :: line 2071"  data: no] Stack trace: this.Experiments.PreviousExperimentProvider.prototype<.shutdown()@resource://app/modules/experiments/Experiments.jsm:2071 < callProvider()@resource://gre/modules/AddonManager.jsm:192 < AMI_unregisterProvider()@resource://gre/modules/AddonManager.jsm:848 < AMP_unregisterProvider()@resource://gre/modules/AddonManager.jsm:2326 < Experiments.Experiments.prototype._unregisterWithAddonManager()@resource://app/modules/experiments/Experiments.jsm:496 < Experiments.Experiments.prototype.uninit<()@resource://app/modules/experiments/Experiments.jsm:442 < TaskImpl_run()@resource://gre/modules/Task.jsm:282 < TaskImpl_handleResultValue()@resource://gre/modules/Task.jsm:338 < TaskImpl_run()@resource://gre/modules/Task.jsm:290 < TaskImpl()@resource://gre/modules/Task.jsm:247 < createAsyncFunction/asyncFunction()@resource://gre/modules/Task.jsm:224 < Spinner.prototype.observe()@resource://gre/modules/AsyncShutdown.jsm:320 < <file:unknown>



Expected results:

Exit firefox.

I have disabled "neer". I have this error twice, only one occurrence of firefox is left in limbo, so I am not sure if the error and the exit are related.

29971 pts/4    Sl     4:23                  \_ /home/user/firefox/firefox

Version 32.0a1 (2014-05-08)
I am not certain about firefox failing to exit. It did eventually exit without me having to kill it.
The agent quoted in the description is wrong because I reported it in a different browser. This occurred with the nightly build Version 32.0a1 (2014-05-08)
I am able to re-create this error as follows:

Launch firefox nightly like this:

xterm -hold -e firefox/firefox -no-remote -P nightly

Then launch firefox like this:

firefox -no-remote

This latter launches firefox with the default profile.

Then exit nightly and exit firefox, the error occurs, and one is left hanging:

12297 pts/1    S+     0:00          |               \_ grep --color=auto firefox
12191 ?        S      0:00          |   \_ xterm -hold -e firefox/firefox -no-remote -P nightly
12237 ?        Ssl    0:08          \_ /usr/lib/firefox/firefox -no-remote
Please check if the issue occurs using Firefox in safe mode (with your addons disabled):
http://support.mozilla.com/kb/Safe+Mode

And on a new, empty profile:
http://support.mozilla.org/en-US/kb/Managing-profiles#w_starting-the-profile-manager
OK first in safe-mode {notice firefox is not left hanging this time}:

firefox/firefox -safe-mode -no-remote -P nightly &
firefox -safe-mode -no-remote &

Then close the nightly window (pressing the X)

:~> 1399665413174	addons.manager	ERROR	Exception calling provider shutdown: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIObserverService.removeObserver]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: resource://app/modules/experiments/Experiments.jsm :: this.Experiments.PreviousExperimentProvider.prototype<.shutdown :: line 2071"  data: no] Stack trace: this.Experiments.PreviousExperimentProvider.prototype<.shutdown()@resource://app/modules/experiments/Experiments.jsm:2071 < callProvider()@resource://gre/modules/AddonManager.jsm:192 < AMI_unregisterProvider()@resource://gre/modules/AddonManager.jsm:848 < AMP_unregisterProvider()@resource://gre/modules/AddonManager.jsm:2326 < Experiments.Experiments.prototype._unregisterWithAddonManager()@resource://app/modules/experiments/Experiments.jsm:496 < Experiments.Experiments.prototype.uninit<()@resource://app/modules/experiments/Experiments.jsm:442 < TaskImpl_run()@resource://gre/modules/Task.jsm:282 < TaskImpl_handleResultValue()@resource://gre/modules/Task.jsm:338 < TaskImpl_run()@resource://gre/modules/Task.jsm:290 < TaskImpl()@resource://gre/modules/Task.jsm:247 < createAsyncFunction/asyncFunction()@resource://gre/modules/Task.jsm:224 < Spinner.prototype.observe()@resource://gre/modules/AsyncShutdown.jsm:320 < <file:unknown>

[2]-  Done                    firefox/firefox -safe-mode -no-remote -P nightly
:~> 
[3]+  Done                    firefox -safe-mode -no-remote
:~> ps axf|grep firefox
30888 pts/0    S+     0:00          |       \_ grep --color=auto firefox
Using new profiles:

user@linux:~> firefox/firefox -safe-mode -no-remote -ProfileManager &
[1] 31489
user@linux:~> firefox -safe-mode -no-remote -ProfileManager &
[2] 31554
user@linux:~> 1399667776620	addons.manager	ERROR	Exception calling provider shutdown: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIObserverService.removeObserver]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: resource://app/modules/experiments/Experiments.jsm :: this.Experiments.PreviousExperimentProvider.prototype<.shutdown :: line 2071"  data: no] Stack trace: this.Experiments.PreviousExperimentProvider.prototype<.shutdown()@resource://app/modules/experiments/Experiments.jsm:2071 < callProvider()@resource://gre/modules/AddonManager.jsm:194 < AMI_unregisterProvider()@resource://gre/modules/AddonManager.jsm:849 < AMP_unregisterProvider()@resource://gre/modules/AddonManager.jsm:2322 < Experiments.Experiments.prototype._unregisterWithAddonManager()@resource://app/modules/experiments/Experiments.jsm:496 < Experiments.Experiments.prototype.uninit<()@resource://app/modules/experiments/Experiments.jsm:442 < TaskImpl_run()@resource://gre/modules/Task.jsm:282 < TaskImpl_handleResultValue()@resource://gre/modules/Task.jsm:338 < TaskImpl_run()@resource://gre/modules/Task.jsm:290 < TaskImpl()@resource://gre/modules/Task.jsm:247 < createAsyncFunction/asyncFunction()@resource://gre/modules/Task.jsm:224 < Spinner.prototype.observe()@resource://gre/modules/AsyncShutdown.jsm:320 < <file:unknown>

[1]-  Done                    firefox/firefox -safe-mode -no-remote -ProfileManager
[2]+  Done                    firefox -safe-mode -no-remote -ProfileManager
I think I will recreate the folder firefox/firefox with a new copy of nightly.

I could not reproduce with two instances of ff29. With two instances of nightly I got more errors:

user@linux:~> firefox/firefox -safe-mode -no-remote -ProfileManager &
[1] 32190
user@linux:~> firefox/firefox -safe-mode -no-remote -ProfileManager &
[2] 32268
user@linux:~> 1399668695432	addons.manager	ERROR	Exception calling provider shutdown: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIObserverService.removeObserver]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: resource://app/modules/experiments/Experiments.jsm :: this.Experiments.PreviousExperimentProvider.prototype<.shutdown :: line 2071"  data: no] Stack trace: this.Experiments.PreviousExperimentProvider.prototype<.shutdown()@resource://app/modules/experiments/Experiments.jsm:2071 < callProvider()@resource://gre/modules/AddonManager.jsm:194 < AMI_unregisterProvider()@resource://gre/modules/AddonManager.jsm:849 < AMP_unregisterProvider()@resource://gre/modules/AddonManager.jsm:2322 < Experiments.Experiments.prototype._unregisterWithAddonManager()@resource://app/modules/experiments/Experiments.jsm:496 < Experiments.Experiments.prototype.uninit<()@resource://app/modules/experiments/Experiments.jsm:442 < TaskImpl_run()@resource://gre/modules/Task.jsm:282 < TaskImpl_handleResultValue()@resource://gre/modules/Task.jsm:338 < TaskImpl_run()@resource://gre/modules/Task.jsm:290 < TaskImpl()@resource://gre/modules/Task.jsm:247 < createAsyncFunction/asyncFunction()@resource://gre/modules/Task.jsm:224 < Spinner.prototype.observe()@resource://gre/modules/AsyncShutdown.jsm:320 < <file:unknown>
*************************
A coding exception was thrown and uncaught in a Task.

Full message: TypeError: self._connection is null
Full stack: createMeasurement@resource://gre/modules/HealthReport.jsm:2760:11
TaskImpl_run@resource://gre/modules/Task.jsm:298:13
TaskImpl@resource://gre/modules/Task.jsm:247:3
createAsyncFunction/asyncFunction@resource://gre/modules/Task.jsm:224:7
Task_spawn@resource://gre/modules/Task.jsm:139:5
createMeasurementOperation@resource://gre/modules/HealthReport.jsm:2756:7
MetricsStorageSqliteBackend.prototype<._popAndPerformQueuedOperation@resource://gre/modules/HealthReport.jsm:3174:7
MetricsStorageSqliteBackend.prototype<.enqueueOperation@resource://gre/modules/HealthReport.jsm:3145:7
MetricsStorageSqliteBackend.prototype<.registerMeasurement@resource://gre/modules/HealthReport.jsm:2755:5
init@resource://gre/modules/HealthReport.jsm:1613:1
TaskImpl_run@resource://gre/modules/Task.jsm:298:13
Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:863:11
this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:742:7

*************************
*************************
A coding exception was thrown and uncaught in a Task.

Full message: TypeError: self._connection is null
Full stack: createMeasurement@resource://gre/modules/HealthReport.jsm:2760:11
TaskImpl_run@resource://gre/modules/Task.jsm:298:13
TaskImpl@resource://gre/modules/Task.jsm:247:3
createAsyncFunction/asyncFunction@resource://gre/modules/Task.jsm:224:7
Task_spawn@resource://gre/modules/Task.jsm:139:5
createMeasurementOperation@resource://gre/modules/HealthReport.jsm:2756:7
MetricsStorageSqliteBackend.prototype<._popAndPerformQueuedOperation@resource://gre/modules/HealthReport.jsm:3174:7
MetricsStorageSqliteBackend.prototype<.enqueueOperation@resource://gre/modules/HealthReport.jsm:3145:7
MetricsStorageSqliteBackend.prototype<.registerMeasurement@resource://gre/modules/HealthReport.jsm:2755:5
init@resource://gre/modules/HealthReport.jsm:1613:1
TaskImpl_run@resource://gre/modules/Task.jsm:298:13
Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:863:11
this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:742:7

*************************
*************************
A coding exception was thrown and uncaught in a Task.

Full message: TypeError: self._connection is null
Full stack: createMeasurement@resource://gre/modules/HealthReport.jsm:2760:11
TaskImpl_run@resource://gre/modules/Task.jsm:298:13
TaskImpl@resource://gre/modules/Task.jsm:247:3
createAsyncFunction/asyncFunction@resource://gre/modules/Task.jsm:224:7
Task_spawn@resource://gre/modules/Task.jsm:139:5
createMeasurementOperation@resource://gre/modules/HealthReport.jsm:2756:7
MetricsStorageSqliteBackend.prototype<._popAndPerformQueuedOperation@resource://gre/modules/HealthReport.jsm:3174:7
MetricsStorageSqliteBackend.prototype<.enqueueOperation@resource://gre/modules/HealthReport.jsm:3145:7
MetricsStorageSqliteBackend.prototype<.registerMeasurement@resource://gre/modules/HealthReport.jsm:2755:5
init@resource://gre/modules/HealthReport.jsm:1613:1
TaskImpl_run@resource://gre/modules/Task.jsm:298:13
Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:863:11
this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:742:7

*************************
*************************
A coding exception was thrown and uncaught in a Task.

Full message: TypeError: self._connection is null
Full stack: createMeasurement@resource://gre/modules/HealthReport.jsm:2760:11
TaskImpl_run@resource://gre/modules/Task.jsm:298:13
TaskImpl@resource://gre/modules/Task.jsm:247:3
createAsyncFunction/asyncFunction@resource://gre/modules/Task.jsm:224:7
Task_spawn@resource://gre/modules/Task.jsm:139:5
createMeasurementOperation@resource://gre/modules/HealthReport.jsm:2756:7
MetricsStorageSqliteBackend.prototype<._popAndPerformQueuedOperation@resource://gre/modules/HealthReport.jsm:3174:7
MetricsStorageSqliteBackend.prototype<.enqueueOperation@resource://gre/modules/HealthReport.jsm:3145:7
MetricsStorageSqliteBackend.prototype<.registerMeasurement@resource://gre/modules/HealthReport.jsm:2755:5
init@resource://gre/modules/HealthReport.jsm:1613:1
TaskImpl_run@resource://gre/modules/Task.jsm:298:13
Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:863:11
this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:742:7

*************************
*************************
A coding exception was thrown and uncaught in a Task.

Full message: TypeError: self._connection is null
Full stack: createMeasurement@resource://gre/modules/HealthReport.jsm:2760:11
TaskImpl_run@resource://gre/modules/Task.jsm:298:13
TaskImpl@resource://gre/modules/Task.jsm:247:3
createAsyncFunction/asyncFunction@resource://gre/modules/Task.jsm:224:7
Task_spawn@resource://gre/modules/Task.jsm:139:5
createMeasurementOperation@resource://gre/modules/HealthReport.jsm:2756:7
MetricsStorageSqliteBackend.prototype<._popAndPerformQueuedOperation@resource://gre/modules/HealthReport.jsm:3174:7
MetricsStorageSqliteBackend.prototype<.enqueueOperation@resource://gre/modules/HealthReport.jsm:3145:7
MetricsStorageSqliteBackend.prototype<.registerMeasurement@resource://gre/modules/HealthReport.jsm:2755:5
init@resource://gre/modules/HealthReport.jsm:1613:1
TaskImpl_run@resource://gre/modules/Task.jsm:298:13
Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:863:11
this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:742:7

*************************
*************************
A coding exception was thrown and uncaught in a Task.

Full message: TypeError: self._connection is null
Full stack: createMeasurement@resource://gre/modules/HealthReport.jsm:2760:11
TaskImpl_run@resource://gre/modules/Task.jsm:298:13
TaskImpl@resource://gre/modules/Task.jsm:247:3
createAsyncFunction/asyncFunction@resource://gre/modules/Task.jsm:224:7
Task_spawn@resource://gre/modules/Task.jsm:139:5
createMeasurementOperation@resource://gre/modules/HealthReport.jsm:2756:7
MetricsStorageSqliteBackend.prototype<._popAndPerformQueuedOperation@resource://gre/modules/HealthReport.jsm:3174:7
MetricsStorageSqliteBackend.prototype<.enqueueOperation@resource://gre/modules/HealthReport.jsm:3145:7
MetricsStorageSqliteBackend.prototype<.registerMeasurement@resource://gre/modules/HealthReport.jsm:2755:5
init@resource://gre/modules/HealthReport.jsm:1613:1
TaskImpl_run@resource://gre/modules/Task.jsm:298:13
Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:863:11
this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:742:7

*************************
*************************
A coding exception was thrown and uncaught in a Task.

Full message: TypeError: self._connection is null
Full stack: createMeasurement@resource://gre/modules/HealthReport.jsm:2760:11
TaskImpl_run@resource://gre/modules/Task.jsm:298:13
TaskImpl@resource://gre/modules/Task.jsm:247:3
createAsyncFunction/asyncFunction@resource://gre/modules/Task.jsm:224:7
Task_spawn@resource://gre/modules/Task.jsm:139:5
createMeasurementOperation@resource://gre/modules/HealthReport.jsm:2756:7
MetricsStorageSqliteBackend.prototype<._popAndPerformQueuedOperation@resource://gre/modules/HealthReport.jsm:3174:7
MetricsStorageSqliteBackend.prototype<.enqueueOperation@resource://gre/modules/HealthReport.jsm:3145:7
MetricsStorageSqliteBackend.prototype<.registerMeasurement@resource://gre/modules/HealthReport.jsm:2755:5
init@resource://gre/modules/Metrics.jsm:1127:1
TaskImpl_run@resource://gre/modules/Task.jsm:298:13
Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:863:11
this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:742:7

*************************
*************************
A coding exception was thrown and uncaught in a Task.

Full message: TypeError: self._connection is null
Full stack: createMeasurement@resource://gre/modules/HealthReport.jsm:2760:11
TaskImpl_run@resource://gre/modules/Task.jsm:298:13
TaskImpl@resource://gre/modules/Task.jsm:247:3
createAsyncFunction/asyncFunction@resource://gre/modules/Task.jsm:224:7
Task_spawn@resource://gre/modules/Task.jsm:139:5
createMeasurementOperation@resource://gre/modules/HealthReport.jsm:2756:7
MetricsStorageSqliteBackend.prototype<._popAndPerformQueuedOperation@resource://gre/modules/HealthReport.jsm:3174:7
MetricsStorageSqliteBackend.prototype<.enqueueOperation@resource://gre/modules/HealthReport.jsm:3145:7
MetricsStorageSqliteBackend.prototype<.registerMeasurement@resource://gre/modules/HealthReport.jsm:2755:5
init@resource://gre/modules/Metrics.jsm:1127:1
TaskImpl_run@resource://gre/modules/Task.jsm:298:13
Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:863:11
this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:742:7

*************************
1399668701453	addons.manager	ERROR	Exception calling provider shutdown: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIObserverService.removeObserver]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: resource://app/modules/experiments/Experiments.jsm :: this.Experiments.PreviousExperimentProvider.prototype<.shutdown :: line 2071"  data: no] Stack trace: this.Experiments.PreviousExperimentProvider.prototype<.shutdown()@resource://app/modules/experiments/Experiments.jsm:2071 < callProvider()@resource://gre/modules/AddonManager.jsm:194 < AMI_unregisterProvider()@resource://gre/modules/AddonManager.jsm:849 < AMP_unregisterProvider()@resource://gre/modules/AddonManager.jsm:2322 < Experiments.Experiments.prototype._unregisterWithAddonManager()@resource://app/modules/experiments/Experiments.jsm:496 < Experiments.Experiments.prototype.uninit<()@resource://app/modules/experiments/Experiments.jsm:442 < TaskImpl_run()@resource://gre/modules/Task.jsm:282 < TaskImpl_handleResultValue()@resource://gre/modules/Task.jsm:338 < TaskImpl_run()@resource://gre/modules/Task.jsm:290 < TaskImpl()@resource://gre/modules/Task.jsm:247 < createAsyncFunction/asyncFunction()@resource://gre/modules/Task.jsm:224 < Spinner.prototype.observe()@resource://gre/modules/AsyncShutdown.jsm:320 < <file:unknown>

[1]-  Done                    firefox/firefox -safe-mode -no-remote -ProfileManager
[2]+  Done                    firefox/firefox -safe-mode -no-remote -ProfileManager
user@linux:~>
Newly downloaded nightly

nightfox/firefox/firefox -safe-mode -no-remote -ProfileManager &
[1] 32696
user@linux:~> nightfox/firefox/firefox -safe-mode -no-remote -ProfileManager &
[2] 304
user@linux:~> 1399669566791	addons.manager	ERROR	Exception calling provider shutdown: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIObserverService.removeObserver]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: resource://app/modules/experiments/Experiments.jsm :: this.Experiments.PreviousExperimentProvider.prototype<.shutdown :: line 2071"  data: no] Stack trace: this.Experiments.PreviousExperimentProvider.prototype<.shutdown()@resource://app/modules/experiments/Experiments.jsm:2071 < callProvider()@resource://gre/modules/AddonManager.jsm:194 < AMI_unregisterProvider()@resource://gre/modules/AddonManager.jsm:849 < AMP_unregisterProvider()@resource://gre/modules/AddonManager.jsm:2322 < Experiments.Experiments.prototype._unregisterWithAddonManager()@resource://app/modules/experiments/Experiments.jsm:496 < Experiments.Experiments.prototype.uninit<()@resource://app/modules/experiments/Experiments.jsm:442 < TaskImpl_run()@resource://gre/modules/Task.jsm:282 < TaskImpl_handleResultValue()@resource://gre/modules/Task.jsm:338 < TaskImpl_run()@resource://gre/modules/Task.jsm:290 < TaskImpl()@resource://gre/modules/Task.jsm:247 < createAsyncFunction/asyncFunction()@resource://gre/modules/Task.jsm:224 < Spinner.prototype.observe()@resource://gre/modules/AsyncShutdown.jsm:320 < <file:unknown>

[1]-  Done                    nightfox/firefox/firefox -safe-mode -no-remote -ProfileManager
[2]+  Done                    nightfox/firefox/firefox -safe-mode -no-remote -ProfileManager
I have found another way to get this error:

Create a new linux user. Install nightly in a directory. Run nightly, and install the lastpass add-on. Change the preferences in the add-on (automatically log off after all browsers are closed for 60 minutes, and automatically log off after idle for 60 minutes). Then exit firefox using the exit button from the menu. The error occurs on the xterm from which firefox was launched.

This makes the error more important, to me at least, if I cannot change my lastpass preferences.
Component: Untriaged → Add-ons Manager
Product: Firefox → Toolkit
Looks like experiments code failing here.
There are at least two bugs in the comments. They sound familiar and I believe they are fixed in at least current Nightly.

Do you still see these errors in today's Nightly?
Flags: needinfo?(iii_iii)
Component: Add-ons Manager → General
Product: Toolkit → Firefox
I am not able to recreate this using the steps in comment 3. There is no error.

Using the steps in comment 9 I get

XPCOMGlueLoad error for file /home/nightly2/firefox/libxul.so:
libdbus-glib-1.so.2: cannot open shared object file: No such file or directory
Couldn't load XPCOM.

:/

As far as I am concerned, you can close this bug.
Flags: needinfo?(iii_iii)
Duping to the experiments bug for comment 0 etc.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1012466
You need to log in before you can comment on or make changes to this bug.