more ssl tests needed

RESOLVED FIXED in 3.4

Status

NSS
Test
P2
enhancement
RESOLVED FIXED
17 years ago
17 years ago

People

(Reporter: Sonja Mirtitsch, Assigned: Sonja Mirtitsch)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Assignee)

Description

17 years ago
Will add new tests as soon as 3.3.1 and JSS 3.1.1 are done

Hi Sonja,  

Presently, on the trunk, the ssl.sh script tests the following ciphersuites
for SSL3:

c    SSL3 RSA WITH RC4 128 MD5
d    SSL3 RSA WITH 3DES EDE CBC SHA
e    SSL3 RSA WITH DES CBC SHA
f    SSL3 RSA EXPORT WITH RC4 40 MD5
g    SSL3 RSA EXPORT WITH RC2 CBC 40 MD5
i    SSL3 RSA WITH NULL MD5
j    SSL3 RSA FIPS WITH 3DES EDE CBC SHA
k    SSL3 RSA FIPS WITH DES CBC SHA
l    SSL3 RSA EXPORT WITH DES CBC SHA   (new)
m    SSL3 RSA EXPORT WITH RC4 56 SHA    (new)

and for TLS, it tests these:

c    SSL3 RSA WITH RC4 128 MD5
d    SSL3 RSA WITH 3DES EDE CBC SHA
e    SSL3 RSA WITH DES CBC SHA
f    SSL3 RSA EXPORT WITH RC4 40 MD5
g    SSL3 RSA EXPORT WITH RC2 CBC 40 MD5
i    SSL3 RSA WITH NULL MD5

For NSS 3.4, I would like to see both TLS and SSL3 test cipher suites 
c-g and i-m, plus the following:

n    SSL3 RSA WITH RC4 128 SHA
v    TLS_RSA_WITH_AES_128_CBC_SHA
y    TLS_RSA_WITH_AES_256_CBC_SHA

Note that the implementations of the last two are not yet checked in.  
I'll let you know when they have been.  



--
Nelson Bolyard
(Assignee)

Updated

17 years ago
Severity: normal → enhancement
Status: NEW → ASSIGNED
Priority: -- → P2
Target Milestone: --- → 3.4
(Assignee)

Comment 1

17 years ago
Created attachment 50623 [details] [diff] [review]
changes to ssl tests
(Assignee)

Comment 2

17 years ago
waiting for Nelson to check in the changes
(Assignee)

Comment 3

17 years ago
checked in the changes, works fine on NT, coredumps on 64 bit Solaris, backing
out QA changes
(Assignee)

Comment 4

17 years ago
Created attachment 50749 [details]
NT output log
(Assignee)

Comment 5

17 years ago
Created attachment 50750 [details]
Sun Solaris 8 output log

Comment 6

17 years ago
Nelson tracked down the cause of the core dump on
64-bit Solaris and checked in a workaround.  You
can check in the QA changes now.
(Assignee)

Comment 7

17 years ago
changes checked in, will break the backward compatibility tests. different bug
already filed
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.