M099 Trunk - Crash editing prefs [@ nsQueryInterface::operator]

RESOLVED DUPLICATE of bug 150769

Status

()

Core
Layout
P1
critical
RESOLVED DUPLICATE of bug 150769
17 years ago
9 years ago

People

(Reporter: greer, Assigned: Blake Ross)

Tracking

({crash, qawanted, topcrash})

Trunk
mozilla1.2alpha
x86
Windows NT
crash, qawanted, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
Most of the crashes occur in M094 with comments relating to startup crashes. 
Some also mention changing skins. 

A few crashes don't share the recurrent calls to CSS, but all in the the same 
top to functions: e.g. (35592539) Comments: emptying my trash

At least one is able to produce the crash with this stack while navigating:
     (35517697) Comments: Navigating around ( www.narain.com/gecko/css/ )

nsQueryInterface::operator   42
                         56136   VERI    FIXE    sfraser@netscape.com    --- 
BBID range: 35350944 - 35603553
Min/Max Seconds since last crash: 0 - 253906
Min/Max Runtime: 1 - 253906
Crash data range: 2001-09-13 to 2001-09-19
Build ID range: 2001091311 to 2001091311

Stack Trace: 

         nsQueryInterface::operator()
[d:\builds\seamonkey\mozilla\xpcom\base\nsCOMPtr.cpp  line 37]
         nsCOMPtr_base::assign_from_helper
[d:\builds\seamonkey\mozilla\xpcom\base\nsCOMPtr.cpp  line 66]
         nsCSSFrameConstructor::ConstructXULFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 5992]
         nsCSSFrameConstructor::ConstructFrameInternal
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 7362]
         nsCSSFrameConstructor::ConstructFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 7269]
         nsCSSFrameConstructor::ProcessChildren
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 11621]
         nsCSSFrameConstructor::ConstructXULFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 5961]
         nsCSSFrameConstructor::ConstructFrameInternal
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 7362]
         nsCSSFrameConstructor::ConstructFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 7269]
         nsCSSFrameConstructor::ProcessChildren
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 11621]
         nsCSSFrameConstructor::ConstructXULFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 5961]
         nsCSSFrameConstructor::ConstructFrameInternal
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 7362]
         nsCSSFrameConstructor::ConstructFrameInternal
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 7329]
         nsCSSFrameConstructor::ConstructFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 7269]
         nsCSSFrameConstructor::ProcessChildren
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 11621]
         nsCSSFrameConstructor::ConstructXULFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 5961]
         nsCSSFrameConstructor::ConstructFrameInternal
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 7362]
         nsCSSFrameConstructor::ConstructFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 7269]
         nsCSSFrameConstructor::ProcessChildren
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 11621]
         nsCSSFrameConstructor::ConstructXULFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 5961]
         nsCSSFrameConstructor::ConstructFrameInternal
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 7362]
         nsCSSFrameConstructor::ConstructFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 7269]
         nsCSSFrameConstructor::ProcessChildren
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 11621]
         nsCSSFrameConstructor::ConstructXULFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 5961]
         nsCSSFrameConstructor::ConstructFrameInternal
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 7362]
         nsCSSFrameConstructor::ConstructFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 7269]
         nsCSSFrameConstructor::ProcessChildren
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 11621]
         nsCSSFrameConstructor::ConstructXULFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 5961]
         nsCSSFrameConstructor::ConstructFrameInternal
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 7362]
         nsCSSFrameConstructor::ConstructFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 7269]
         nsCSSFrameConstructor::ProcessChildren
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 11621]
         nsCSSFrameConstructor::ConstructXULFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 5961]
         nsCSSFrameConstructor::ConstructFrameInternal
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 7362]
         nsCSSFrameConstructor::ConstructFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 7269]
         nsCSSFrameConstructor::ProcessChildren
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 11621]
         nsCSSFrameConstructor::ConstructXULFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 5961]
         nsCSSFrameConstructor::ConstructFrameInternal
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 7362]
         nsCSSFrameConstructor::ConstructFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 7269]
         nsCSSFrameConstructor::ProcessChildren
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 11621]
         nsCSSFrameConstructor::ConstructXULFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 5961]
         nsCSSFrameConstructor::ConstructFrameInternal
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 7362]
         nsCSSFrameConstructor::ConstructFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 7269]
         nsCSSFrameConstructor::ProcessChildren
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 11621]
         nsCSSFrameConstructor::ConstructXULFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 5961]
         nsCSSFrameConstructor::ConstructFrameInternal
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 7362]
         nsCSSFrameConstructor::ConstructFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 7269]
         nsCSSFrameConstructor::ProcessChildren
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 11621]
         nsCSSFrameConstructor::ConstructXULFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 5961]
         nsCSSFrameConstructor::ConstructFrameInternal
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 7362]
         nsCSSFrameConstructor::ConstructFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 7269]
         nsCSSFrameConstructor::ProcessChildren
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 11621]
         nsCSSFrameConstructor::ConstructXULFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 5961]
         nsCSSFrameConstructor::ConstructFrameInternal
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 7362]
         nsCSSFrameConstructor::ConstructFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 7269]
         nsCSSFrameConstructor::ProcessChildren
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 11621]
         nsCSSFrameConstructor::ConstructXULFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 5961]
         nsCSSFrameConstructor::ConstructFrameInternal
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 7362]
         nsCSSFrameConstructor::ConstructFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 7269]
         nsCSSFrameConstructor::ProcessChildren
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 11621]
         nsCSSFrameConstructor::ConstructXULFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 5961]
         nsCSSFrameConstructor::ConstructFrameInternal
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 7362]
         nsCSSFrameConstructor::ConstructFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 7269]
         nsCSSFrameConstructor::ProcessChildren
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 11621]
         nsCSSFrameConstructor::ConstructXULFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp 
line 5961]
 
        Source File :
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/xpcom/base/nsCOMPtr.cpp line
: 37
     (35603553) Comments: Starting Mozilla
     (35592539) Comments: emptying my trash
     (35585288) Comments: Updating preferences for the first time (mail & news
preferences)
     (35566743) URL: http://www.mozilla.org
     (35557780) Comments: Mozilla crashed on startup
     (35557753) Comments: Starting Mozilla When an invalid page fault occured  I
don't know if it is reproduceable  it happened right after installation
     (35528125) URL: Internal Development Url.
     (35528125) Comments: xul popup is shown
using:element.openPopup(...);then:window.location = "<URL>";then it crashes.
     (35517697) URL: http://www.narain.com/gecko/css/
     (35517697) Comments: Navigating around
     (35516771) Comments: restarting mozilla after reapplying the "modern" skin
after "littlemozilla".
     (35505911) Comments: starting the program
     (35499836) Comments: Starting Mozilla after changed skin from Modern to
Classic 
     (35449488) Comments: Starting mozilla.open progs:
seti@home                    seti-driver                    ie
5                    miranda icq                  
     (35441501) Comments: it crashed after opening lots ot windows(50 maybe) and
closing mozilla with ctrl+alt+del. Crash occurred during the startup.
     (35425470) Comments: Edit  Preferences

--------------
N620 incidents:
     (35377106) Comments: crash on launch
     (35377054) Comments: crash on launch

--------------
Trunk incidents:
     (35518880) Comments: opening the browser.. crashed..
     (35345543) URL: https://netreg.net.cmu.edu/
(Reporter)

Updated

17 years ago
Keywords: crash, topcrash

Comment 1

17 years ago
assigning to layout for inital triage.
Assignee: dougt → attinasi
Component: XPCOM → Layout
QA Contact: scc → petersen

Comment 2

17 years ago
Adding qawanted keyword
Keywords: qawanted

Comment 3

17 years ago
Created attachment 50999 [details]
attaching comments from latest crashes
Reassigning to Eric. Eric should this go to Hyatt?
Assignee: attinasi → evaughan

Comment 6

17 years ago
*** Bug 102393 has been marked as a duplicate of this bug. ***
Reassigning to Hyatt, to see if he has any ideas on this one.
Assignee: evaughan → hyatt

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0

Comment 8

17 years ago
I had another crash on startup today in 2001100708 W2K. no talkback data fired up.

Comment 9

17 years ago
unfortunetely I didn't pause to think about saving the crash information on the
dialog box that popped up.  Sorry for the lack of help.

Dennis
(Reporter)

Comment 10

17 years ago
Trunk has 8 incidents in today's data. M094 has 28. However, N620 has none. Here
are the comments.

N610 :        7
(36637363) -  trying to save email to drafts folder
(36674212) -  installing  then executing
---------------
N620 :        0
----------------
M094 :       28
(36298301) - http://www.asus.com.tw/Products/Notebook/award.html clicked on a
hyperlink
(36311217) -  Crashed when started mozilla. Using Win2000.
(36572342) - http://www.hotmail.com i was refreshing this page
(36613211) - http://www.tse.com Looking at a chart (put in a symbol e.g. CSN 
click on "Go" to generate quote  then click on 1 year chart). Tried to stretch
window when it crashed.
(36617859) -  installing netscape 6.1 theme
(36624831) -  just trying to launch navigator from quickstart menu. nothing else
open.
(36626240) -  tried to install Flash player in Mozilla PLUGINS directory. 
Install gave me errors (could not find Netscape.exe).  Tried to run Mozilla and
it crashed.
(36686519) - When opening browser. Double-clicked on shortcut to Mozilla on
desktop (target of the shortcut is "C:\Program
Files\mozilla.org\Mozilla\mozilla.exe").  Crashed right after red Mozilla splash
screen.
----------------
Trunk :        8
(36574550) - gamespy.com's Naminator popup Clicked the dropdown-combo  while the
page wasn't fully loaded
(36678170) -
http://www.fileplanet.com/dl/dl.asp?/planetquake/ztn/nvreffix-setup.exe Clicked
the link to the FilePlanet Xfer 4

Comment 11

17 years ago
I just ran into this twice on the current 094 branch build (10/20). I wasn't
switching skins, just bringing up a new browser window. I was already running
the app and clicked on a link that created a new window in case that helps any.

Comment 12

17 years ago
N620 has 3 crashes with this stack sig today, M095 has 27, and trunk has 12.

Here are the comments from the M095 crashes:
 (36985073)	Comments: Trying to install java
     (36887030)	URL: www.ebay.com
     (36887030)	Comments: crash on load.
     (36877738)	Comments: I just click on the shortcut to start it.
     (36873327)	URL: x.classic.themes.org
     (36873327)	Comments: Downloading and installing graymodern theme from x.themes.org
     (36785619)	Comments: restarting after installation of Java 2 Runtime 1.3 from netscape
     (36648227)	Comments: Launching the Browser for the first time after enabling the
"Modern" Theme.
     (36645632)	Comments: Started Mozilla
     (36641197)	Comments: Just starting it on Windows 2000



Summary: M094 N620 Trunk - Crash on startup / change skin [@ nsQueryInterface::operator] → M095 N620 Trunk - Crash on startup / change skin [@ nsQueryInterface::operator]

Updated

17 years ago
Target Milestone: mozilla1.0 → mozilla1.0.1
(Reporter)

Comment 13

17 years ago
This one is still around with 132 users crashing N620 and 29 on M095. A lot of 
the crashes are ahppening on Win XP ("Windows NT 5.1 build 2600" in talkback). 
I will attach the comments in case that may point to some repro cases.
(Reporter)

Comment 14

17 years ago
Created attachment 57835 [details]
N620 and M095 talkback comments
(Reporter)

Comment 15

17 years ago
Recent talkback Trunk data has 14 incidents of this bug, most comments pointing 
to downloading themes.

Trunk (nsQueryInterface::operator):       14
(38688324) - 2001112713: Windows 98  4.10 build 67766446 fdsafdaa URL: 
http://www.ironmaiden.com
(38709622) - 2001112511: Windows 98  4.10 build 67766446 Looking like a problem 
with themes.org...This time just one window and DL window...  moving on... URL: 
while surfing
(38519093) - 2001112511: Windows NT  5.0 build 2195 Mozill dowload a new skin 
((little ...)and when it try to install it   it crash URL: try to change mozilla 
skin
(38566441) - 2001112610: Windows NT  5.0 build 2195 Trying to install toy 
factory theme.  
(38589588) - 2001112511: Windows 98  4.10 build 67766446 downloading "Little 
Mozilla" theme from geocities link... 
(38565081) - 2001112706: Windows NT  5.0 build 2195 I clicked on the "Install 
Nightly" link to install the "littlemozilla" theme.  I left the checkbox marked 
"Use this theme" when installing.  The whole install seem to go fine.  It seemed 
to download everything  but right before the install box would 
URL: http://members.tripod.lycos.nl/AKayser/skins/themes.htm
(38422380) - 2001112310: Windows NT  5.0 build 2195 Downloading a new theme.  
(38592389) - 2001112511: Windows 98  4.10 build 67766446 downloading American 
theme 6_2 

Comment 16

17 years ago
If this is still happening, and is still a topcrash, we should target for 1.0,
otherwise we should resolve it.  QA?
Keywords: nsbeta1

Comment 17

17 years ago
This stack signature is still showing up in Talkback data with recent
MozillaTrunk builds.  There are around 23 crashes in the last 30 days.  Here are
a couple of the most recent crashes:

 Incident ID 2108620   
Stack Signature  nsQueryInterface::operator() 1189075d
Trigger Time 2002-01-25 08:45:38
Email Address
URL visited http://developer.netscape.com/evangelism/teds-sidebar.html
User Comments Web site icons (favicons) were not being displayed: went to prefs
and saw that they were enabled, unchecked that preference and Mozilla crashed
when I OK's the preference dialogue box. Thanks Mark
Build ID 2002012409
Product ID MozillaTrunk
Platform
Operating System Win32
Module
Trigger Reason Access violation
Stack Trace
nsQueryInterface::operator()
[d:\builds\seamonkey\mozilla\xpcom\glue\nsCOMPtr.cpp, line 52]
nsCOMPtr_base::assign_from_helper
[d:\builds\seamonkey\mozilla\xpcom\glue\nsCOMPtr.cpp, line 81]
nsCSSFrameConstructor::ConstructXULFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 5565]
nsCSSFrameConstructor::ConstructFrameInternal
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 6997]
nsCSSFrameConstructor::ConstructFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 6888]
nsCSSFrameConstructor::CreateAnonymousFrames
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 4899]
nsCSSFrameConstructor::CreateAnonymousFrames
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 4837]
nsCSSFrameConstructor::ConstructDocElementFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 3224]
nsCSSFrameConstructor::ReconstructDocElementHierarchy
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 7148]
StyleSetImpl::ReconstructDocElementHierarchy
[d:\builds\seamonkey\mozilla\content\base\src\nsStyleSet.cpp, line 1428]
PresShell::ReconstructFrames
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5206]
0x80000000
nsPresContext::PreferenceChanged
[d:\builds\seamonkey\mozilla\layout\base\src\nsPresContext.cpp, line 656]
nsPresContext::PrefChangedCallback
[d:\builds\seamonkey\mozilla\layout\base\src\nsPresContext.cpp, line 102]
pref_DoCallback [d:\builds\seamonkey\mozilla\modules\libpref\src\prefapi.cpp,
line 1345]
pref_HashPref [d:\builds\seamonkey\mozilla\modules\libpref\src\prefapi.cpp, line
1109]
PREF_SetCharPref [d:\builds\seamonkey\mozilla\modules\libpref\src\prefapi.cpp,
line 594]
nsPrefBranch::SetCharPref
[d:\builds\seamonkey\mozilla\modules\libpref\src\nsPrefBranch.cpp, line 229]
nsPrefBranch::SetComplexValue
[d:\builds\seamonkey\mozilla\modules\libpref\src\nsPrefBranch.cpp, line 403]
nsPrefService::SetComplexValue
[d:\builds\seamonkey\mozilla\modules\libpref\src\nsPrefService.h, line 57]
nsPref::SetUnicharPref
[d:\builds\seamonkey\mozilla\modules\libpref\src\nsPref.cpp, line 427]
XPTC_InvokeByIndex
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcinvoke.cpp,
line 106]
XPCWrappedNative::CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednative.cpp, line 2000]
XPC_WN_CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativejsops.cpp,
line 1267]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 834]
js_Interpret [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2799]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 850]
js_InternalInvoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 925]
JS_CallFunctionValue [d:\builds\seamonkey\mozilla\js\src\jsapi.c, line 3407]
nsJSContext::CallEventHandler
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp, line 1019]
GlobalWindowImpl::RunTimeout
[d:\builds\seamonkey\mozilla\dom\src\base\nsGlobalWindow.cpp, line 3879]
GlobalWindowImpl::TimerCallback
[d:\builds\seamonkey\mozilla\dom\src\base\nsGlobalWindow.cpp, line 4187]
nsTimerImpl::Process [d:\builds\seamonkey\mozilla\xpcom\threads\nsTimerImpl.cpp,
line 247]
PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 591]
PL_ProcessPendingEvents [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c,
line 524]
_md_EventReceiverProc [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line
1072]
nsAppShellService::Run
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsAppShellService.cpp, line 308]
main1 [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1301]
main [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1628]
WinMain [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 1646]
WinMainCRTStartup()
KERNEL32.DLL + 0x17d08 (0x77e97d08) 


 Incident ID 1659308   
Stack Signature  nsQueryInterface::operator() 9ee800f8
Trigger Time 2002-01-14 17:51:27
Email Address
URL visited http://www.gameshark.com/n64/objects/153628_106.html
User Comments When I changed the image preference to "Accept All Images",
Mozilla crashed when I hit OK.
Build ID 2002011409
Product ID MozillaTrunk
Platform
Operating System Win32
Module
Trigger Reason Access violation
Stack Trace
nsQueryInterface::operator()
[d:\builds\seamonkey\mozilla\xpcom\glue\nsCOMPtr.cpp, line 52]
nsCOMPtr_base::assign_from_helper
[d:\builds\seamonkey\mozilla\xpcom\glue\nsCOMPtr.cpp, line 81]
nsCSSFrameConstructor::ConstructXULFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 5561]
nsCSSFrameConstructor::ConstructFrameInternal
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 6993]
nsCSSFrameConstructor::ConstructFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 6884]
nsCSSFrameConstructor::CreateAnonymousFrames
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 4895]
nsCSSFrameConstructor::CreateAnonymousFrames
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 4833]
nsCSSFrameConstructor::ConstructDocElementFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 3220]
nsCSSFrameConstructor::ReconstructDocElementHierarchy
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 7144]
StyleSetImpl::ReconstructDocElementHierarchy
[d:\builds\seamonkey\mozilla\content\base\src\nsStyleSet.cpp, line 1428]
PresShell::ReconstructFrames
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5206]
PresShell::SetPreferenceStyleRules
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 2079]
nsPresContext::PreferenceChanged
[d:\builds\seamonkey\mozilla\layout\base\src\nsPresContext.cpp, line 656]
nsPresContext::PrefChangedCallback
[d:\builds\seamonkey\mozilla\layout\base\src\nsPresContext.cpp, line 102]
pref_DoCallback [d:\builds\seamonkey\mozilla\modules\libpref\src\prefapi.cpp,
line 1345]
pref_HashPref [d:\builds\seamonkey\mozilla\modules\libpref\src\prefapi.cpp, line
1109]
PREF_SetIntPref [d:\builds\seamonkey\mozilla\modules\libpref\src\prefapi.cpp,
line 603]
nsPrefBranch::SetIntPref
[d:\builds\seamonkey\mozilla\modules\libpref\src\nsPrefBranch.cpp, line 257]
nsPrefService::SetIntPref
[d:\builds\seamonkey\mozilla\modules\libpref\src\nsPrefService.h, line 57]
nsPref::SetIntPref [d:\builds\seamonkey\mozilla\modules\libpref\src\nsPref.cpp,
line 245]
XPTC_InvokeByIndex
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcinvoke.cpp,
line 106]
XPCWrappedNative::CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednative.cpp, line 2011]
XPC_WN_CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativejsops.cpp,
line 1267]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 834]
js_Interpret [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2799]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 850]
js_InternalInvoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 925]
JS_CallFunctionValue [d:\builds\seamonkey\mozilla\js\src\jsapi.c, line 3407]
nsJSContext::CallEventHandler
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp, line 1014]
GlobalWindowImpl::RunTimeout
[d:\builds\seamonkey\mozilla\dom\src\base\nsGlobalWindow.cpp, line 3839]
GlobalWindowImpl::TimerCallback
[d:\builds\seamonkey\mozilla\dom\src\base\nsGlobalWindow.cpp, line 4147]
nsTimerImpl::Process [d:\builds\seamonkey\mozilla\xpcom\threads\nsTimerImpl.cpp,
line 242]
PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 591]
PL_ProcessPendingEvents [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c,
line 524]
_md_EventReceiverProc [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line
1072]
USER32.dll + 0x3c076 (0x77d7c076)
USER32.dll + 0x3c076 (0x77d7c076)
_except_handler3()
kernel32.dll + 0x3bb86 (0x77e9bb86) 

All of the crashes on the MozillaTrunk that have comments mention doing
something in preferences...is it just me or are the preferences really flaky lately?

Comment 18

17 years ago
There are also a lot of crashes with Mozilla 0.9.7...those users also mentioned
preferences a lot in their comments:

2155796     2001122109   MozillaBranch   Windows 98 4.10 build 67766446  
2002-01-26 18:31:07   nsQueryInterface::operator() d2dca563   97054   99749    
After making changes in preferences (such as java script permissions, added DOM
sidebar, cache, and cursive font) I clicked okay and Mozilla Crached         

2099655     2001122109   MozillaBranch   Windows NT 4.0 build 1381   2002-01-25
04:57:53   nsQueryInterface::operator() a2bdbc29   113704   318266  
http://www.iht.com/frontpage.html   changing fonts

1954701     2001122109   MozillaBranch   Windows NT 5.0 build 2195   2002-01-21
22:00:56   nsQueryInterface::operator() 4d8f9814   2963   2963     changing the
size of the fonts in the preferences

1529379     2001122109   MozillaBranch   Windows 95 4.0 build 67109975  
2002-01-11 08:23:18   nsQueryInterface::operator() 501e9a08   38377   38377  
http://people.msoe.edu/~tritt/   While the page was loading, I was Editing
Preferences, Colors, changing the setting to "Use My Chosen Colors"

Those are just a few incidents with helpful comments.

Comment 19

17 years ago
nsbeta1+ per nav triage team
Keywords: nsbeta1 → nsbeta1+

Comment 20

17 years ago
Mass move of nsbeta1+ bugs that didn't have a valid MachV milestone to mozilla1.0.
Target Milestone: mozilla1.0.1 → mozilla1.0

Comment 21

17 years ago
->P1, cc ben for possible pref bulletproofing.
Priority: -- → P1
(Reporter)

Comment 22

17 years ago
Updating summary. Still happening in M098 and the Trunk. No real clues as to how.
Summary: M095 N620 Trunk - Crash on startup / change skin [@ nsQueryInterface::operator] → M098 Trunk - Crash on startup / change skin [@ nsQueryInterface::operator]

Comment 23

17 years ago
I can reproduce a crash when switching themes via the preferences dialog (Win ME
Feb 27 Build - 2002-02-27-03).

1) Loaded this site: http://members.tripod.lycos.nl/AKayser/skins/themes.htm

2) Opened Preferences . Went to Appearance - Themes. Select Modern and Click OK.

3) Opened Preferences . Went to Appearance - Themes. Select Classic and Click OK.

4) Opened Preferences . Went to Appearance - Themes. Selected Modern and Click OK.

5) I recieved a crash after Step 4 was completed

Comment 24

17 years ago
Stack trace from Talkback:

nsTemplateRule::GetContent
[d:\builds\seamonkey\mozilla\content\xul\templates\src\nsTemplateRule.cpp, line 63]
nsStyleContext::Destroy
[d:\builds\seamonkey\mozilla\content\base\src\nsStyleContext.cpp, line 1279]
nsStyleContext::Release
[d:\builds\seamonkey\mozilla\content\base\src\nsStyleContext.cpp, line 187]
nsProperties::ReleaseValues
[d:\builds\seamonkey\mozilla\xpcom\ds\nsProperties.cpp, line 70]
_hashEnumerate [d:\builds\seamonkey\mozilla\xpcom\ds\nsHashtable.cpp, line 199]
PL_HashTableEnumerateEntries [../../../lib/ds/plhash.c, line 430]
nsHashtable::Enumerate [d:\builds\seamonkey\mozilla\xpcom\ds\nsHashtable.cpp,
line 362]
nsSupportsHashtable::~nsSupportsHashtable
[d:\builds\seamonkey\mozilla\xpcom\ds\nsHashtable.cpp, line 866]
nsSupportsHashtable::`scalar deleting destructor'
nsOutlinerBodyFrame::ClearStyleAndImageCaches
[d:\builds\seamonkey\mozilla\layout\xul\base\src\outliner\src\nsOutlinerBodyFrame.cpp,
line 3129]
nsCOMPtr_base::assign_from_helper
[d:\builds\seamonkey\mozilla\xpcom\glue\nsCOMPtr.cpp, line 81]
FlushMiscWidgetInfo
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5288]
FlushMiscWidgetInfo
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5288]
FlushMiscWidgetInfo
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5288]
FlushMiscWidgetInfo
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5288]
FlushMiscWidgetInfo
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5288]
FlushMiscWidgetInfo
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5288]
FlushMiscWidgetInfo
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5288]
FlushMiscWidgetInfo
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5288]
FlushMiscWidgetInfo
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5288]
FlushMiscWidgetInfo
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5288]
FlushMiscWidgetInfo
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5288]
FlushMiscWidgetInfo
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5288]
FlushMiscWidgetInfo
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5288]
FlushMiscWidgetInfo
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5288]
PresShell::ReconstructStyleData
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5327]
PresShell::StyleSheetRemoved
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5371]
nsXULDocument::UpdateStyleSheets
[d:\builds\seamonkey\mozilla\content\xul\document\src\nsXULDocument.cpp, line 1344]
nsChromeRegistry::RefreshWindow
[d:\builds\seamonkey\mozilla\rdf\chrome\src\nsChromeRegistry.cpp, line 1334]
nsChromeRegistry::RefreshSkins
[d:\builds\seamonkey\mozilla\rdf\chrome\src\nsChromeRegistry.cpp, line 1161]
XPTC_InvokeByIndex
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcinvoke.cpp,
line 106]
XPCWrappedNative::CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednative.cpp, line 2022]
XPC_WN_CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativejsops.cpp,
line 1267]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 790]
js_Interpret [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2746]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 806]
js_InternalInvoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 881]
JS_CallFunctionValue [d:\builds\seamonkey\mozilla\js\src\jsapi.c, line 3390]
nsJSContext::CallEventHandler
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp, line 1019]
GlobalWindowImpl::RunTimeout
[d:\builds\seamonkey\mozilla\dom\src\base\nsGlobalWindow.cpp, line 4074]
GlobalWindowImpl::TimerCallback
[d:\builds\seamonkey\mozilla\dom\src\base\nsGlobalWindow.cpp, line 4386]
nsTimerImpl::Process [d:\builds\seamonkey\mozilla\xpcom\threads\nsTimerImpl.cpp,
line 284]
PL_ProcessPendingEvents [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c,
line 524]
_md_EventReceiverProc [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line
1072]
KERNEL32.DLL + 0x248f7 (0xbff848f7)
0x00688c16
0x00058f64 

Updated

17 years ago
Keywords: testcase
(Reporter)

Comment 25

17 years ago
Note: the stack trace in comment #24 above compares to that in bug 116038
comment #33. 
(http://bugzilla.mozilla.org/show_bug.cgi?id=116038#c33)
(Reporter)

Comment 26

17 years ago
  Removing testcase keyword because it was added in conjunction with steps that 
reproduced bug 116038. 
  I have repeated the steps, duplicated that bug and am verifying those steps 
are invalid for this bug.

Currently crashing:
N621 (nsQueryInterface::operator):      402
M098 (nsQueryInterface::operator):       12
(3334418) - installed prefsbar (http://www.xulplanet.com/downloads
/view.cgi?category=applications&view=prefbar) and then deselected images.  just 
trying it out really :( URL: 
http://www.shellgeostar.com/route/route.asp?gammaDeltaState=merge&gammaDeltaCont
ent=email   Windows NT  4.0 build 1381
(3522279) -  Changed useragent string to report Win98  MSIE to access a website 
that was restricted to IE only. On next restart  java plug-in complained that I 
should use the 'IE' plugin with Internet Explorer  instead of the Netscape 
plugin. (Apparently the java Windows 98  4.10 build 67766446
(3567020) - Tried to change image setting from "no animation" to "as many as 
image wants to do".  Mozilla crashed when I pressed OK on preferences dialogue. 
URL: howstuffworks.com  Windows NT  5.0 build 2195
 
Trunk (nsQueryInterface::operator):        1
(3455111) - Build 2002022605 - changed in the preferences the navigator colors 
-> text color and background and wanted mozilla to override webdesigner 
settings. clicked the radiobutton and crashed URL: http://mozillazine.org  
Windows NT  5.0 build 2195
Keywords: testcase

Comment 27

17 years ago
->blaker, hoping this will go away when we delay theme switch to next startup.
Assignee: hyatt → blaker
Status: ASSIGNED → NEW

Comment 28

17 years ago
Updating summary again...I don't think this is really a crash related to
theme/skin switching.  It was originally a startup crash, but has since morphed
into something else: crash editing prefs.

Most of the recent incidents, including the latest M099 crashes mention making
various changes in perferences...which include changing font size, switching
themes and changing font/background colors.

Here is the most recent incident from Mozilla 0.9.9:
 Incident ID 4039485   
Stack Signature  nsQueryInterface::operator() eecc1e56
Trigger Time 2002-03-14 08:57:15
Email Address
URL visited
Build ID 2002031106
Product ID MozillaBranch
Platform
Operating System Win32
Module
Trigger Reason Access violation
User Comments
Stack Trace
nsQueryInterface::operator()
[d:\builds\seamonkey\mozilla\xpcom\glue\nsCOMPtr.cpp, line 52]
nsCOMPtr_base::assign_from_helper
[d:\builds\seamonkey\mozilla\xpcom\glue\nsCOMPtr.cpp, line 81]
nsCSSFrameConstructor::ConstructXULFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 5651]
nsCSSFrameConstructor::ConstructFrameInternal
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 7072]
nsCSSFrameConstructor::ConstructFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 6963]
nsCSSFrameConstructor::CreateAnonymousFrames
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 4981]
nsCSSFrameConstructor::CreateAnonymousFrames
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 4919]
nsCSSFrameConstructor::ConstructDocElementFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 3292]
nsCSSFrameConstructor::ReconstructDocElementHierarchy
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 7223]
StyleSetImpl::ReconstructDocElementHierarchy
[d:\builds\seamonkey\mozilla\content\base\src\nsStyleSet.cpp, line 1434]
PresShell::ReconstructFrames
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5208]
PresShell::SetPreferenceStyleRules
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 2079]
nsPresContext::PreferenceChanged
[d:\builds\seamonkey\mozilla\layout\base\src\nsPresContext.cpp, line 660]
nsPresContext::PrefChangedCallback
[d:\builds\seamonkey\mozilla\layout\base\src\nsPresContext.cpp, line 105]
pref_DoCallback [d:\builds\seamonkey\mozilla\modules\libpref\src\prefapi.cpp,
line 1345]
pref_HashPref [d:\builds\seamonkey\mozilla\modules\libpref\src\prefapi.cpp, line
1109]
PREF_SetIntPref [d:\builds\seamonkey\mozilla\modules\libpref\src\prefapi.cpp,
line 603]
nsPrefBranch::SetIntPref
[d:\builds\seamonkey\mozilla\modules\libpref\src\nsPrefBranch.cpp, line 257]
nsPrefService::SetIntPref
[d:\builds\seamonkey\mozilla\modules\libpref\src\nsPrefService.h, line 57]
nsPref::SetIntPref [d:\builds\seamonkey\mozilla\modules\libpref\src\nsPref.cpp,
line 245]
XPTC_InvokeByIndex
[d:\builds\seamonkey\mozilla\xpcom\reflect\xptcall\src\md\win32\xptcinvoke.cpp,
line 106]
XPCWrappedNative::CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednative.cpp, line 2027]
XPC_WN_CallMethod
[d:\builds\seamonkey\mozilla\js\src\xpconnect\src\xpcwrappednativejsops.cpp,
line 1267]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 790]
js_Interpret [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2746]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 806]
js_InternalInvoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 881]
JS_CallFunctionValue [d:\builds\seamonkey\mozilla\js\src\jsapi.c, line 3390]
nsJSContext::CallEventHandler
[d:\builds\seamonkey\mozilla\dom\src\base\nsJSEnvironment.cpp, line 1019]
GlobalWindowImpl::RunTimeout
[d:\builds\seamonkey\mozilla\dom\src\base\nsGlobalWindow.cpp, line 4125]
GlobalWindowImpl::TimerCallback
[d:\builds\seamonkey\mozilla\dom\src\base\nsGlobalWindow.cpp, line 4437]
nsTimerImpl::Process [d:\builds\seamonkey\mozilla\xpcom\threads\nsTimerImpl.cpp,
line 330]
PL_HandleEvent [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line 591]
PL_ProcessPendingEvents [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c,
line 524]
_md_EventReceiverProc [d:\builds\seamonkey\mozilla\xpcom\threads\plevent.c, line
1072]
Summary: M098 Trunk - Crash on startup / change skin [@ nsQueryInterface::operator] → M099 Trunk - Crash editing prefs [@ nsQueryInterface::operator]

Comment 29

17 years ago
nsbeta1- per ADT triage team. As it stands, this bug is not actionable.
qawanted: this bug is trying to morph, which is BAD.  Please determine what the
different problems are, and open a separate bug report for each one.
Keywords: nsbeta1+ → nsbeta1-
Target Milestone: mozilla1.0 → mozilla1.2
(Assignee)

Comment 30

17 years ago
well, marking fixed since theme switching happens on restart now.  not sure
that's the right solution (aren't dbaron and others interested in getting
dynamic switching working again?), but I assume that's why this was sent to me.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 31

15 years ago
Postmortem. This bug didn't really morph, it was filed with inconsistent
information the core of comment 0 is Bug 150769 appears to be the preferences
crasher so I will dupe this bug to that.

The N620 references in comment 0 are Bug 114043 appears to be the startup crasher.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 32

15 years ago

*** This bug has been marked as a duplicate of 150769 ***
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago15 years ago
Resolution: --- → DUPLICATE

Comment 33

9 years ago
removing qawanted as this was added a very long time ago, this bug has been resolved as a dup, and the primary bug has been fixes.
Crash Signature: [@ nsQueryInterface::operator]
You need to log in before you can comment on or make changes to this bug.