Closed Bug 1008039 Opened 8 years ago Closed 8 years ago

[Flame][Camera][1.4][2.0] Tapping the 'switch camera' button 4 times rapidly results in black viewfinder

Categories

(Firefox OS Graveyard :: Gaia::Camera, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.0 affected)

VERIFIED FIXED
2.0 S2 (23may)
Tracking Status
b2g-v2.0 --- affected

People

(Reporter: jlorenzo, Assigned: wilsonpage)

Details

(Whiteboard: [1.4-JB-bug-bash])

Attachments

(2 files)

Build Information

Device: Flame
Gaia      4ce973ef0732b0d52cb043210db598aa176b2ce9
Gecko     https://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/16ab7f6b18f8
BuildID   20140508000201
Version   30.0
ro.build.version.incremental=87
ro.build.date=Mon May  5 20:19:07 CST 2014

Description

Steps to Reproduce
Open the Camera App
Tap at least 20 times the switch front/back camera button

Expected Results
One of the cameras' feedback

Actual Results
Black feedback

Reproduction Frequency: 100%
s/Tap at least/Tap rapidly at least/
Summary: [Flame][Camera][1.4][2.0] Tapping 20 times the switch button make a black feedback → [Flame][Camera][1.4][2.0] Tapping 20 times rapidly the switch button make a black feedback
What's the minimum of switches you need to do between front & back camera before this bug reproduces?
Keywords: qawanted
(In reply to Jason Smith [:jsmith] from comment #2)
> What's the minimum of switches you need to do between front & back camera
> before this bug reproduces?

The minimum of switches to do between front & back camera before this bug reproduces is four. Following the STR from Comment 0 and beginning with 20 switches and working backward decrementing by 1 after each repro attempt, the last repro was 4 switches. Attempted three rapid-tapping switches for 15 cycles and could not reproduce. 

Environmental Variables:
Device: Flame 1.4 MOZ
BuildID: 20140509000203
Gaia: f19735d288d9bf1c6ee0c0ecc7941421365037c7
Gecko: 33aff135dc42
Version: 30.0
Base Image: v10F-3
Keywords: qawanted
QA Contact: mclemmons
Reworking title to indicate the min STR amount.
Summary: [Flame][Camera][1.4][2.0] Tapping 20 times rapidly the switch button make a black feedback → [Flame][Camera][1.4][2.0] Tapping 4 times rapidly the switch button make a black feedback
If I choose to switch between front & back 4 times at a slower speed, then does the bug reproduce?
Keywords: qawanted
(In reply to Jason Smith [:jsmith] from comment #5)
> If I choose to switch between front & back 4 times at a slower speed, then
> does the bug reproduce?

No. Switching between front & back 4 times at a slower speed does not reproduce the bug. Attempted 20 times at slower speed and did not experience the black feedback in any of the 20 attempts. 

Environmental Variables:
Device: Flame 1.4 MOZ
BuildID: 20140509000203
Gaia: f19735d288d9bf1c6ee0c0ecc7941421365037c7
Gecko: 33aff135dc42
Version: 30.0
Base Image: v10F-3
Keywords: qawanted
attachment 8422477 [details]: Unable to reproduce on latest 'master' build.
Adding qawanted here to double check that we can't reproduce this on master.
Keywords: qawanted
This issue DOES occur on today's Flame 1.5

Environmental Variables:
Device: Flame
BuildID: 20140514040204
Gaia: a13d42ab5240008e042d0c61bf9c9d05174e70e4
Gecko: 5c99d5136ad7
Version: 32.0a1

Rapidly tapping the switch camera button leads to a black screen.
Keywords: qawanted
Can we include a video here showing how to reproduce the bug?
Keywords: qawanted
Ah, I was testing the other switch. Updated the bug title for clarity.
Summary: [Flame][Camera][1.4][2.0] Tapping 4 times rapidly the switch button make a black feedback → [Flame][Camera][1.4][2.0] Tapping the 'switch camera' button 4 times rapidly results in black viewfinder
Assignee: nobody → wilsonpage
Attached file pull-request (master)
Attachment #8423246 - Flags: review?(jdarcangelo)
Comment on attachment 8423246 [details] [review]
pull-request (master)

Couple of nits that don't affect the code, otherwise looks good.
Attachment #8423246 - Flags: review?(jdarcangelo) → review+
Landed on 'master' https://github.com/mozilla-b2g/gaia/commit/764310e266221daba43aabe849458dc30692e941
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.0 S2 (23may)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.