darkwindowframe attribute should be set before the first paint

RESOLVED FIXED in Firefox 31

Status

()

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: dao, Assigned: dao)

Tracking

Trunk
Firefox 32
All
Windows 8
Points:
---
Dependency tree / graph
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(firefox31 fixed, firefox32 fixed)

Details

(Whiteboard: [qa-])

Attachments

(1 attachment)

Posted patch patchSplinter Review
It's currently being set in _delayedStartup, which is after the first paint.
Attachment #8420042 - Flags: review?(gijskruitbosch+bugs)
Comment on attachment 8420042 [details] [diff] [review]
patch

Review of attachment 8420042 [details] [diff] [review]:
-----------------------------------------------------------------

Assuming you're just moving things (it looks like that, but splinter is... nonoptimal... for checking it), rs=me
Attachment #8420042 - Flags: review?(gijskruitbosch+bugs) → review+
Comment on attachment 8420042 [details] [diff] [review]
patch

(In reply to :Gijs Kruitbosch from comment #1)
> Assuming you're just moving things (it looks like that, but splinter is...
> nonoptimal... for checking it), rs=me

I did some minor cleanup:

>-      let windows8WindowFrameColor = Cu.import("resource:///modules/Windows8WindowFrameColor.jsm", {}).Windows8WindowFrameColor;
>-      let windowFrameColor = windows8WindowFrameColor.get();

>+      let windowFrameColor = Cu.import("resource:///modules/Windows8WindowFrameColor.jsm", {})
>+                               .Windows8WindowFrameColor.get();
(In reply to Dão Gottwald [:dao] from comment #2)
> Comment on attachment 8420042 [details] [diff] [review]
> patch
> 
> (In reply to :Gijs Kruitbosch from comment #1)
> > Assuming you're just moving things (it looks like that, but splinter is...
> > nonoptimal... for checking it), rs=me
> 
> I did some minor cleanup:
> 
> >-      let windows8WindowFrameColor = Cu.import("resource:///modules/Windows8WindowFrameColor.jsm", {}).Windows8WindowFrameColor;
> >-      let windowFrameColor = windows8WindowFrameColor.get();
> 
> >+      let windowFrameColor = Cu.import("resource:///modules/Windows8WindowFrameColor.jsm", {})
> >+                               .Windows8WindowFrameColor.get();

Ship it! :-)
Flags: firefox-backlog+
https://hg.mozilla.org/mozilla-central/rev/d78df4c9cded
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 32
Blocks: 1012629
Comment on attachment 8420042 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 940393
User impact if declined: this is needed in order to uplift the patch in bug 1012629
Testing completed (on m-c, etc.): landed almost 2 weeks ago on m-c
Risk to taking this patch (and alternatives if risky): low; just moving code around, no new code
String or IDL/UUID changes made by this patch: none
Attachment #8420042 - Flags: approval-mozilla-aurora?
Attachment #8420042 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.