Closed Bug 1008190 Opened 7 years ago Closed 5 years ago

Scroll position is lost on Twitter when clicking a tweet and then back

Categories

(Core :: DOM: Navigation, defect)

defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox29 --- affected
firefox30 --- affected
firefox31 --- affected
firefox32 --- affected
firefox-esr24 --- affected

People

(Reporter: daniel.nr01, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: reproducible, testcase-wanted)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:32.0) Gecko/20100101 Firefox/32.0 (Beta/Release)
Build ID: 20140507030202

Steps to reproduce:

* Open a Twitter page using the new profile e.g. https://twitter.com/FirefoxNightly
* Click on a tweet to show the detailed view
* Hit backspace or the back button


Actual results:

The page is scrolled to the top.


Expected results:

The scroll position should be retained. This works in IE11 and Chrome 34.
Confirmed 32.0a1 (2014-05-11), Win 7 x64
Blocks: 251784
Status: UNCONFIRMED → NEW
Component: Untriaged → Document Navigation
Ever confirmed: true
Product: Firefox → Core
IE11 doesn't work for me (Chrome works).
I now get the the same behavior in IE as in Firefox (thought it worked the last time I tried...)

One thing I noted is that both IE and Firefox does do the scrolling but before the page content is changed. This is most notable if you click on a tweet with a long conversation. In IE you can even see the scrollbar jump to the bottom (if you have scrolled down a bit on the original page) before the page contents is updated.
I can reproduce this problem in Firefox 29 and even Firefox ESR 24. Chrome 35 restores the scroll position as expected.
Keywords: reproducible
OS: Windows 7 → All
Hardware: x86_64 → All
Version: 32 Branch → Trunk
Hi Daniel,

I have tested this issue on the latest Firefox (44.0.2) release, latest Nightly (47.0a1) build and I could not reproduce it. I have followed your provided steps and when I hit backspace, the scroll position is retained. Same behavior on Chrome and IE.

Firefox :44.0.2, Build ID: 20160210153822
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0
Firefox: 47.0a1, Build ID: 20160215030213
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0

Can you please test this on the latest Firefox release (44.0.2) or latest Nightly (47.0a1, https://nightly.mozilla.org/) and tell me if this still reproduces ? When doing this please use a new fresh Firefox profile, maybe also in safe mode (https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-problems). 


Thanks,
Cosmin.
Flags: needinfo?(daniel.nr01)
Hi, I can no longer reproduce it either.

I suspect Twitter fixed it on their side, but anyway the issue is gone :)
Flags: needinfo?(daniel.nr01)
Hi,

Thanks for the reply. Considering this I will close this issue as Resolved - WFM.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.