Closed Bug 1008334 Opened 7 years ago Closed 7 years ago

launching Gamebay app throws android.content.ActivityNotFoundException

Categories

(Firefox for Android :: Web Apps (PWAs), defect)

29 Branch
ARM
Android
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1007112

People

(Reporter: myk, Unassigned)

Details

(Whiteboard: [WebRuntime])

Attachments

(1 file)

Attached file logcat.txt
Installing and launching the Gameboy app <https://marketplace.firefox.com/app/gameboy/> on my non-debug tip build crashed for me with:

GeckoAppShell  E  >>> REPORTING UNCAUGHT EXCEPTION FROM THREAD 80692 ("Gecko")
GeckoAppShell  E  android.content.ActivityNotFoundException: No Activity found to handle Intent { act=android.intent.action.GET_CONTENT }
GeckoAppShell  E  at android.app.Instrumentation.checkStartActivityResult(Instrumentation.java:1632)

I also heard from bwalker that the app "almost always causes nightly to crash."

The full log from the point at which I launched the app is attached.  Note that it also shows "java.lang.IllegalArgumentException: Receiver not registered", which is bug 974578.

I wonder if this is the crasher reported in bug 995803 and attributed to "java.lang.IllegalStateException: Already registered Webapps:Preinstall" but which doesn't always happen in conjunction with that error.
I filed this as bug 1007112.
(In reply to Aaron Train [:aaronmt] from comment #1)
> I filed this as bug 1007112.

Indeed!
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1007112
You need to log in before you can comment on or make changes to this bug.