Closed Bug 1008423 Opened 6 years ago Closed 5 years ago

Android 4.0 Debug Shutdown | application crashed [@ mozilla::gl::GLContext::BeforeGLCall(char const*)] following testMasterPassword, testSettingsMenuItems

Categories

(Firefox for Android :: Testing, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: gbrown, Assigned: gbrown)

References

Details

Android 4.0 Debug robocop tests run only on Cedar currently.

In recent builds, there is a consistent shutdown crash following testMasterPassword and testSettingsMenuItems.

https://tbpl.mozilla.org/php/getParsedLog.php?id=39366372&tree=Cedar&full=1#error0

08:37:42     INFO -  51 INFO TEST-END | testMasterPassword | finished in 158291ms
08:37:42     INFO -  52 INFO TEST-START | Shutdown
08:37:42     INFO -  53 INFO Passed: 49
08:37:42     INFO -  54 INFO Failed: 0
08:37:42     INFO -  55 INFO Todo: 0
08:37:42     INFO -  56 INFO SimpleTest FINISHED
08:37:42     INFO -  INFO | automation.py | Application ran for: 0:02:42.870250
08:37:42     INFO -  INFO | zombiecheck | Reading PID log: /tmp/tmp8zVKTCpidlog
08:37:42     INFO -  Contents of /data/anr/traces.txt:
08:37:44     INFO -  mozcrash INFO | Downloading symbols from: https://ftp-ssl.mozilla.org/pub/mozilla.org/mobile/tinderbox-builds/cedar-android-debug/1399644062/fennec-32.0a1.en-US.android-arm.crashreporter-symbols.zip
08:37:56  WARNING -  PROCESS-CRASH | Shutdown | application crashed [@ mozilla::gl::GLContext::BeforeGLCall(char const*)]
08:37:56     INFO -  Crash dump filename: /tmp/tmp6slW90/6aa9e9a1-94e9-1e6c-5afab315-5a4ffb5a.dmp
08:37:56     INFO -  Operating system: Android
08:37:56     INFO -                    0.0.0 Linux 3.2.0+ #2 SMP PREEMPT Thu Nov 29 08:06:57 EST 2012 armv7l pandaboard/pandaboard/pandaboard:4.0.4/IMM76I/5:eng/test-keys
08:37:56     INFO -  CPU: arm
08:37:56     INFO -       2 CPUs
08:37:56     INFO -  Crash reason:  SIGSEGV
08:37:56     INFO -  Crash address: 0x0
08:37:56     INFO -  Thread 35 (crashed)
08:37:56     INFO -   0  libxul.so!mozilla::gl::GLContext::BeforeGLCall(char const*) [GLContext.h:52de77b56b2d : 617 + 0x1a]
08:37:56     INFO -       r4 = 0x68bb5800    r5 = 0x63b513cc    r6 = 0x00000000    r7 = 0x68d6d000
08:37:56     INFO -       r8 = 0x67b6bd84    r9 = 0x6379c874   r10 = 0x6379c874    fp = 0x00000001
08:37:56     INFO -       sp = 0x685ffb20    lr = 0x623b5a97    pc = 0x623b6566
08:37:56     INFO -      Found by: given as instruction pointer in context
08:37:56     INFO -   1  libxul.so!mozilla::gl::GLContext::fDeleteProgram(unsigned int) [GLContext.h:52de77b56b2d : 2036 + 0x7]
08:37:56     INFO -       r4 = 0x68bb5800    r5 = 0x00033453    r6 = 0x63b513cc    r7 = 0x68d6d000
08:37:56     INFO -       r8 = 0x67b6bd84    r9 = 0x6379c874   r10 = 0x6379c874    fp = 0x00000001
08:37:56     INFO -       sp = 0x685ffb40    pc = 0x623c0a05
08:37:56     INFO -      Found by: call frame info
08:37:56     INFO -   2  libxul.so!mozilla::layers::ShaderProgramOGL::~ShaderProgramOGL() [OGLShaderProgram.cpp:52de77b56b2d : 387 + 0xb]
08:37:56     INFO -       r4 = 0x68d6d000    r5 = 0x68d42d80    r6 = 0x67b6bdac    r7 = 0x68d6d000
08:37:56     INFO -       r8 = 0x67b6bd84    r9 = 0x6379c874   r10 = 0x6379c874    fp = 0x00000001
08:37:56     INFO -       sp = 0x685ffb50    pc = 0x6243ab59
08:37:56     INFO -      Found by: call frame info
08:37:56     INFO -   3  libxul.so!mozilla::layers::CompositorOGL::CleanupResources() [CompositorOGL.cpp:52de77b56b2d : 219 + 0x5]
08:37:56     INFO -       r4 = 0x67b6bd60    r5 = 0x68d42d80    r6 = 0x67b6bdac    r7 = 0x68d6d000
08:37:56     INFO -       r8 = 0x67b6bd84    r9 = 0x6379c874   r10 = 0x6379c874    fp = 0x00000001
08:37:56     INFO -       sp = 0x685ffb60    pc = 0x6243abaf
08:37:56     INFO -      Found by: call frame info
08:37:56     INFO -   4  libxul.so!mozilla::layers::LayerManagerComposite::Destroy() [LayerManagerComposite.cpp:52de77b56b2d : 136 + 0x5]
08:37:56     INFO -       r4 = 0x67b6be40    r5 = 0x68d4759c    r6 = 0x685ffb8c    r7 = 0x6406446c
08:37:56     INFO -       r8 = 0x68d4759c    r9 = 0x6379c874   r10 = 0x6379c874    fp = 0x00000001
08:37:56     INFO -       sp = 0x685ffb80    pc = 0x62423bab
08:37:56     INFO -      Found by: call frame info
08:37:56     INFO -   5  libxul.so!mozilla::layers::CompositorParent::RecvWillStop() [CompositorParent.cpp:52de77b56b2d : 284 + 0xf]
08:37:56     INFO -       r4 = 0x68d47400    r5 = 0x68d4759c    r6 = 0x685ffb8c    r7 = 0x6406446c
08:37:56     INFO -       r8 = 0x68d4759c    r9 = 0x6379c874   r10 = 0x6379c874    fp = 0x00000001
08:37:56     INFO -       sp = 0x685ffb88    pc = 0x6242c0cd
08:37:56     INFO -      Found by: call frame info
08:37:56     INFO -   6  libxul.so!mozilla::layers::PCompositorParent::OnMessageReceived(IPC::Message const&, IPC::Message*&) [PCompositorParent.cpp:52de77b56b2d : 551 + 0x7]
08:37:56     INFO -       r4 = 0x68d47400    r5 = 0x685ffc40    r6 = 0x685ffc70    r7 = 0x685ffbfc
08:37:56     INFO -       r8 = 0x6215f441    r9 = 0x6379c874   r10 = 0x6379c874    fp = 0x00000001
08:37:56     INFO -       sp = 0x685ffba8    pc = 0x621a8249
08:37:56     INFO -      Found by: call frame info


Logcat shows an assertion:

08:38:00     INFO -  05-09 08:37:38.632 I/Robocop ( 2719): 51 INFO TEST-END | testMasterPassword | finished in 158291ms
08:38:00     INFO -  05-09 08:37:38.632 I/Robocop ( 2719): 52 INFO TEST-START | Shutdown
08:38:00     INFO -  05-09 08:37:38.632 I/Robocop ( 2719): 53 INFO Passed: 49
08:38:00     INFO -  05-09 08:37:38.632 I/Robocop ( 2719): 54 INFO Failed: 0
08:38:00     INFO -  05-09 08:37:38.632 I/Robocop ( 2719): 55 INFO Todo: 0
08:38:00     INFO -  05-09 08:37:38.648 I/Robocop ( 2719): 56 INFO SimpleTest FINISHED
08:38:00     INFO -  05-09 08:37:38.648 I/GeckoDump( 2719): Robocop:Quit received -- requesting quit
08:38:00     INFO -  05-09 08:37:38.664 I/Gecko   ( 2719): [2719] WARNING: NS_ENSURE_SUCCESS(rv, QUIT_AND_RESUME) failed with result 0x8000FFFF: file /builds/slave/ced-and-d-00000000000000000000/build/toolkit/components/downloads/nsDownloadManager.cpp, line 1086
08:38:00     INFO -  05-09 08:37:38.664 I/Gecko   ( 2719): [2719] WARNING: NS_ENSURE_SUCCESS(rv, QUIT_AND_RESUME) failed with result 0x8000FFFF: file /builds/slave/ced-and-d-00000000000000000000/build/toolkit/components/downloads/nsDownloadManager.cpp, line 1086
08:38:00     INFO -  05-09 08:37:38.687 I/Gecko   ( 2719): nsWindow[0x69bc1000]::Show 0
08:38:00     INFO -  05-09 08:37:38.765 I/Gecko   ( 2719): ### Warning: Destroying window 0x69bc1000 and reparenting child 0x67b3b000 to null!
08:38:00     INFO -  05-09 08:37:38.765 I/Gecko   ( 2719): nsWindow::FindTopLevel(): couldn't find a toplevel or dialog window in this [0x67b3b000] widget's hierarchy!
08:38:00     INFO -  05-09 08:37:38.765 I/Gecko   ( 2719): --DOCSHELL 0x69b84000 == 2 [pid = 2719] [id = 2]
08:38:00     INFO -  05-09 08:37:38.765 I/Gecko   ( 2719): nsWindow::FindTopLevel(): couldn't find a toplevel or dialog window in this [0x67b3b000] widget's hierarchy!
08:38:00     INFO -  05-09 08:37:38.765 I/Gecko   ( 2719): nsWindow 0x67b3b000 destructor
08:38:00     INFO -  05-09 08:37:38.812 I/Gecko   ( 2719): nsWindow[0x6951f000]::Show 0
08:38:00     INFO -  05-09 08:37:38.812 I/Gecko   ( 2719): trying to show invisible window! ignoring..
08:38:00     INFO -  05-09 08:37:38.828 I/Gecko   ( 2719): ### Warning: Destroying window 0x6951f000 and reparenting child 0x67b13000 to null!
08:38:00     INFO -  05-09 08:37:38.828 I/Gecko   ( 2719): nsWindow::FindTopLevel(): couldn't find a toplevel or dialog window in this [0x67b13000] widget's hierarchy!
08:38:00     INFO -  05-09 08:37:38.828 I/Gecko   ( 2719): --DOCSHELL 0x69accc00 == 1 [pid = 2719] [id = 1]
08:38:00     INFO -  05-09 08:37:38.828 I/Gecko   ( 2719): nsWindow::FindTopLevel(): couldn't find a toplevel or dialog window in this [0x67b13000] widget's hierarchy!
08:38:00     INFO -  05-09 08:37:38.828 I/Gecko   ( 2719): nsWindow 0x67b13000 destructor
08:38:00     INFO -  05-09 08:37:38.843 I/Gecko   ( 2719): [2719] WARNING: NS_ENSURE_SUCCESS(rv, QUIT_AND_RESUME) failed with result 0x8000FFFF: file /builds/slave/ced-and-d-00000000000000000000/build/toolkit/components/downloads/nsDownloadManager.cpp, line 1086
08:38:00     INFO -  05-09 08:37:39.078 I/Gecko   ( 2719): [2719] WARNING: NS_ENSURE_SUCCESS(rv, QUIT_AND_RESUME) failed with result 0x8000FFFF: file /builds/slave/ced-and-d-00000000000000000000/build/toolkit/components/downloads/nsDownloadManager.cpp, line 1086
08:38:00     INFO -  05-09 08:37:40.023 I/Gecko   ( 2719): --DOCSHELL 0x6bb6f400 == 0 [pid = 2719] [id = 3]
08:38:00     INFO -  05-09 08:37:40.023 I/Gecko   ( 2719): [2719] WARNING: NS_ENSURE_SUCCESS(rv, QUIT_AND_RESUME) failed with result 0x8000FFFF: file /builds/slave/ced-and-d-00000000000000000000/build/toolkit/components/downloads/nsDownloadManager.cpp, line 1086
08:38:00     INFO -  05-09 08:37:40.109 I/Gecko   ( 2719): nsWindow 0x69bc1000 destructor
08:38:00     INFO -  05-09 08:37:40.109 F/MOZ_Assert( 2719): Assertion failure: IsCurrent(), at /builds/slave/ced-and-d-00000000000000000000/build/gfx/gl/GLContext.h:617
08:38:00     INFO -  05-09 08:37:40.953 W/NetworkManagementSocketTagger( 1402): setKernelCountSet(10047, 0) failed with errno -2
08:38:00     INFO -  05-09 08:37:40.953 I/WindowManager( 1402): WIN DEATH: Window{415366c0 org.mozilla.fennec/org.mozilla.fennec.App paused=false}
08:38:00     INFO -  05-09 08:37:40.953 W/WindowManager( 1402): Force-removing child win Window{4155d360 SurfaceView paused=false} from container Window{415366c0 org.mozilla.fennec/org.mozilla.fennec.App paused=false}
08:38:00     INFO -  05-09 08:37:40.953 I/ActivityManager( 1402): Process org.mozilla.fennec (pid 2719) has died.
Unable to reproduce since June 12.
Assignee: nobody → gbrown
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
It's back...

https://tbpl.mozilla.org/php/getParsedLog.php?id=44045221&tree=Cedar&full=1
Assignee: gbrown → nobody
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
We don't run Android 4.0 debug robocop now and likely won't try to run 4.3 debug robocop.
Assignee: nobody → gbrown
Status: REOPENED → RESOLVED
Closed: 6 years ago5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.