Closed Bug 1008426 Opened 7 years ago Closed 5 years ago

Android 4.0 Debug Shutdown | application crashed [@ mozilla::storage::Connection::~Connection()] following testAddSearchEngine

Categories

(Firefox for Android :: Testing, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: gbrown, Assigned: gbrown)

References

Details

Android 4.0 Debug robocop tests run only on Cedar currently.

In recent builds, there is a consistent shutdown crash following testAddSearchEngines.

https://tbpl.mozilla.org/php/getParsedLog.php?id=39366729&tree=Cedar&full=1

08:36:07     INFO -  20 INFO TEST-END | testAddSearchEngine | finished in 47619ms
08:36:07     INFO -  21 INFO TEST-START | Shutdown
08:36:07     INFO -  22 INFO Passed: 18
08:36:07     INFO -  23 INFO Failed: 0
08:36:07     INFO -  24 INFO Todo: 0
08:36:07     INFO -  25 INFO SimpleTest FINISHED
08:36:27     INFO -  INFO | automation.py | Application ran for: 0:01:18.219414
08:36:27     INFO -  INFO | zombiecheck | Reading PID log: /tmp/tmpFnpyOVpidlog
08:36:28     INFO -  Contents of /data/anr/traces.txt:
08:36:29     INFO -  mozcrash INFO | Downloading symbols from: https://ftp-ssl.mozilla.org/pub/mozilla.org/mobile/tinderbox-builds/cedar-android-debug/1399644062/fennec-32.0a1.en-US.android-arm.crashreporter-symbols.zip
08:36:35  WARNING -  PROCESS-CRASH | Shutdown | application crashed [@ mozilla::storage::Connection::~Connection()]
08:36:35     INFO -  Crash dump filename: /tmp/tmpYcwA1J/108440ec-b4d1-9745-516ca967-4411ccb4.dmp
08:36:35     INFO -  Operating system: Android
08:36:35     INFO -                    0.0.0 Linux 3.2.0+ #2 SMP PREEMPT Thu Nov 29 08:06:57 EST 2012 armv7l pandaboard/pandaboard/pandaboard:4.0.4/IMM76I/5:eng/test-keys
08:36:35     INFO -  CPU: arm
08:36:35     INFO -       2 CPUs
08:36:35     INFO -  Crash reason:  SIGSEGV
08:36:35     INFO -  Crash address: 0x0
08:36:35     INFO -  Thread 15 (crashed)
08:36:35     INFO -   0  libxul.so!mozilla::storage::Connection::~Connection() [mozStorageConnection.cpp:52de77b56b2d : 490 + 0x14]
08:36:35     INFO -       r4 = 0x6758dac0    r5 = 0x00000000    r6 = 0x00000001    r7 = 0x6971a9f0
08:36:35     INFO -       r8 = 0x6cf38ce4    r9 = 0x5d74391f   r10 = 0x00000001    fp = 0x5c12063c
08:36:35     INFO -       sp = 0x5d743840    lr = 0x62382a77    pc = 0x623845b2
08:36:35     INFO -      Found by: given as instruction pointer in context
08:36:35     INFO -   1  libxul.so!mozilla::storage::Connection::Release() [mozStorageConnection.cpp:52de77b56b2d : 520 + 0x3]
08:36:35     INFO -       r4 = 0x6758dac0    r5 = 0x00000000    r6 = 0x00000001    r7 = 0x6971a9f0
08:36:35     INFO -       r8 = 0x6cf38ce4    r9 = 0x5d74391f   r10 = 0x00000001    fp = 0x5c12063c
08:36:35     INFO -       sp = 0x5d743848    pc = 0x6238468d
08:36:35     INFO -      Found by: call frame info
08:36:35     INFO -   2  libxul.so!nsRefPtr<mozilla::storage::Connection>::~nsRefPtr() [nsAutoPtr.h:52de77b56b2d : 895 + 0x3]
08:36:35     INFO -       r4 = 0x6cf38ce0    r5 = 0x6cf38ce4    r6 = 0x00000001    r7 = 0x6971a9f0
08:36:35     INFO -       r8 = 0x6cf38ce4    r9 = 0x5d74391f   r10 = 0x00000001    fp = 0x5c12063c
08:36:35     INFO -       sp = 0x5d743860    pc = 0x623846bd
08:36:35     INFO -      Found by: call frame info
08:36:35     INFO -   3  libxul.so!nsTArray_Impl<nsRefPtr<mozilla::storage::Connection>, nsTArrayInfallibleAllocator>::RemoveElementsAt(unsigned int, unsigned int) [nsTArray.h:52de77b56b2d : 536 + 0x3]
08:36:35     INFO -       r4 = 0x00000006    r5 = 0x6cf38ce4    r6 = 0x00000001    r7 = 0x6971a9f0
08:36:35     INFO -       r8 = 0x6cf38ce4    r9 = 0x5d74391f   r10 = 0x00000001    fp = 0x5c12063c
08:36:35     INFO -       sp = 0x5d743868    pc = 0x62391b5f
08:36:35     INFO -      Found by: call frame info
08:36:35     INFO -   4  libxul.so!mozilla::storage::Service::unregisterConnection(mozilla::storage::Connection*) [nsTArray.h:52de77b56b2d : 1308 + 0x9]
08:36:35     INFO -       r4 = 0x6971a9c0    r5 = 0x6758dac0    r6 = 0x6cf38ce4    r7 = 0x00000001
08:36:35     INFO -       r8 = 0x00000001    r9 = 0x5d74391f   r10 = 0x00000001    fp = 0x5c12063c
08:36:35     INFO -       sp = 0x5d743888    pc = 0x623923d1
08:36:35     INFO -      Found by: call frame info
08:36:35     INFO -   5  libxul.so!mozilla::storage::Connection::Release() [mozStorageConnection.cpp:52de77b56b2d : 514 + 0xd]
08:36:35     INFO -       r4 = 0x6758dac0    r5 = 0x00000001    r6 = 0x5d7438e4    r7 = 0x00000001
08:36:35     INFO -       r8 = 0x00000001    r9 = 0x5d74391f   r10 = 0x00000001    fp = 0x5c12063c
08:36:35     INFO -       sp = 0x5d7438a8    pc = 0x62384677
08:36:35     INFO -      Found by: call frame info
08:36:35     INFO -   6  libxul.so!nsHtml5RefPtrReleaser<nsHtml5StreamParser>::Run() [nsHtml5RefPtr.h:52de77b56b2d : 22 + 0x7]
08:36:35     INFO -       r4 = 0x5c120600    r5 = 0x5d7438d8    r6 = 0x5d7438e4    r7 = 0x00000001
08:36:35     INFO -       r8 = 0x00000001    r9 = 0x5d74391f   r10 = 0x00000001    fp = 0x5c12063c
08:36:35     INFO -       sp = 0x5d7438c0    pc = 0x6209cce3
08:36:35     INFO -      Found by: call frame info
08:36:35     INFO -   7  libxul.so!nsThread::ProcessNextEvent(bool, bool*) [nsThread.cpp:52de77b56b2d : 715 + 0xb]
08:36:35     INFO -       r4 = 0x5c120600    r5 = 0x5d7438d8    r6 = 0x5d7438e4    r7 = 0x00000001
08:36:35     INFO -       r8 = 0x00000001    r9 = 0x5d74391f   r10 = 0x00000001    fp = 0x5c12063c
08:36:35     INFO -       sp = 0x5d7438c8    pc = 0x620e5025
08:36:35     INFO -      Found by: call frame info
08:36:35     INFO -   8  libxul.so!NS_ProcessNextEvent(nsIThread*, bool) [nsThreadUtils.cpp:52de77b56b2d : 263 + 0xd]
08:36:35     INFO -       r4 = 0x5c120600    r5 = 0x00000001    r6 = 0x5c1a3640    r7 = 0x6d141310
08:36:35     INFO -       r8 = 0x5d743938    r9 = 0x5d263f80   r10 = 0x409f3f44    fp = 0x5d743c04
08:36:35     INFO -       sp = 0x5d743918    pc = 0x620a00f9
08:36:35     INFO -      Found by: call frame info
08:36:35     INFO -   9  libxul.so!nsThread::Shutdown() [nsThread.cpp:52de77b56b2d : 559 + 0x7]
08:36:35     INFO -       r4 = 0x6d141300    r5 = 0x00000000    r6 = 0x5c1a3640    r7 = 0x6d141310
08:36:35     INFO -       r8 = 0x5d743938    r9 = 0x5d263f80   r10 = 0x409f3f44    fp = 0x5d743c04
08:36:35     INFO -       sp = 0x5d743930    pc = 0x620e7d71
08:36:35     INFO -      Found by: call frame info
08:36:35     INFO -  10  libxul.so!nsUrlClassifierDBService::Shutdown() [nsUrlClassifierDBService.cpp:52de77b56b2d : 1526 + 0x7]
08:36:35     INFO -       r4 = 0x5d74396c    r5 = 0x6d141300    r6 = 0x67573898    r7 = 0x67573880
08:36:35     INFO -       r8 = 0x00000000    r9 = 0x5d263f80   r10 = 0x409f3f44    fp = 0x5d743c04
08:36:35     INFO -       sp = 0x5d743960    pc = 0x6306804f
08:36:35     INFO -      Found by: call frame info


Logcat shows an assertion:

08:36:37     INFO -  05-09 08:35:57.468 I/Robocop ( 2547): 20 INFO TEST-END | testAddSearchEngine | finished in 47619ms
08:36:37     INFO -  05-09 08:35:57.468 I/Robocop ( 2547): 21 INFO TEST-START | Shutdown
08:36:37     INFO -  05-09 08:35:57.468 I/Robocop ( 2547): 22 INFO Passed: 18
08:36:37     INFO -  05-09 08:35:57.468 I/Robocop ( 2547): 23 INFO Failed: 0
08:36:37     INFO -  05-09 08:35:57.468 I/Robocop ( 2547): 24 INFO Todo: 0
08:36:37     INFO -  05-09 08:35:57.468 I/Robocop ( 2547): 25 INFO SimpleTest FINISHED
08:36:37     INFO -  05-09 08:35:57.468 I/GeckoDump( 2547): Robocop:Quit received -- requesting quit
08:36:37     INFO -  05-09 08:35:57.515 I/Gecko   ( 2547): nsWindow[0x69dc1000]::Show 0
08:36:37     INFO -  05-09 08:35:57.562 I/Gecko   ( 2547): ### Warning: Destroying window 0x69dc1000 and reparenting child 0x67b3b000 to null!
08:36:37     INFO -  05-09 08:35:57.562 I/Gecko   ( 2547): nsWindow::FindTopLevel(): couldn't find a toplevel or dialog window in this [0x67b3b000] widget's hierarchy!
08:36:37     INFO -  05-09 08:35:57.562 I/Gecko   ( 2547): nsWindow::FindTopLevel(): couldn't find a toplevel or dialog window in this [0x67b3b000] widget's hierarchy!
08:36:37     INFO -  05-09 08:35:57.562 I/Gecko   ( 2547): nsWindow 0x67b3b000 destructor
08:36:37     INFO -  05-09 08:35:57.593 I/Gecko   ( 2547): nsWindow[0x6971f000]::Show 0
08:36:37     INFO -  05-09 08:35:57.593 I/Gecko   ( 2547): trying to show invisible window! ignoring..
08:36:37     INFO -  05-09 08:35:57.593 I/Gecko   ( 2547): ### Warning: Destroying window 0x6971f000 and reparenting child 0x67b13000 to null!
08:36:37     INFO -  05-09 08:35:57.601 I/Gecko   ( 2547): nsWindow::FindTopLevel(): couldn't find a toplevel or dialog window in this [0x67b13000] widget's hierarchy!
08:36:37     INFO -  05-09 08:35:57.601 I/Gecko   ( 2547): --DOCSHELL 0x69ccd000 == 2 [pid = 2547] [id = 1]
08:36:37     INFO -  05-09 08:35:57.601 I/Gecko   ( 2547): nsWindow::FindTopLevel(): couldn't find a toplevel or dialog window in this [0x67b13000] widget's hierarchy!
08:36:37     INFO -  05-09 08:35:57.601 I/Gecko   ( 2547): nsWindow 0x67b13000 destructor
08:36:37     INFO -  05-09 08:35:57.796 I/Gecko   ( 2547): [2547] WARNING: A runnable was posted to a worker that is already shutting down!: file /builds/slave/ced-and-d-00000000000000000000/build/dom/workers/WorkerPrivate.cpp, line 2198
08:36:37     INFO -  05-09 08:35:57.796 I/Gecko   ( 2547): [2547] WARNING: Failed to dispatch offline status change event!: file /builds/slave/ced-and-d-00000000000000000000/build/dom/workers/WorkerPrivate.cpp, line 2989
08:36:37     INFO -  05-09 08:35:58.343 I/Gecko   ( 2547): --DOCSHELL 0x69d84400 == 1 [pid = 2547] [id = 2]
08:36:37     INFO -  05-09 08:35:58.343 I/Gecko   ( 2547): --DOCSHELL 0x6bd2b800 == 0 [pid = 2547] [id = 3]
08:36:37     INFO -  05-09 08:35:58.343 I/Gecko   ( 2547): [2547] WARNING: NS_ENSURE_TRUE(asyncCloseWasCalled) failed: file /builds/slave/ced-and-d-00000000000000000000/build/storage/src/mozStorageConnection.cpp, line 1113
08:36:37     INFO -  05-09 08:35:58.343 F/MOZ_Assert( 2547): Assertion failure: !mAsyncExecutionThread (AsyncClose has not been invoked on this connection!), at /builds/slave/ced-and-d-00000000000000000000/build/storage/src/mozStorageConnection.cpp:491
08:36:37     INFO -  05-09 08:35:59.101 F/libc    ( 2547): Fatal signal 11 (SIGSEGV) at 0x00000000 (code=1)
08:36:37     INFO -  05-09 08:35:59.328 I/DEBUG   ( 2458): *** *** *** *** *** *** *** *** *** *** *** *** *** *** *** ***
08:36:37     INFO -  05-09 08:35:59.328 I/DEBUG   ( 2458): Build fingerprint: 'pandaboard/pandaboard/pandaboard:4.0.4/IMM76I/5:eng/test-keys'
08:36:37     INFO -  05-09 08:35:59.328 I/DEBUG   ( 2458): pid: 2547, tid: 2568  >>> org.mozilla.fennec <<<
08:36:37     INFO -  05-09 08:35:59.328 I/DEBUG   ( 2458): signal 11 (SIGSEGV), code 1 (SEGV_MAPERR), fault addr 00000000
Summary: Android 4.0 Debug Shutdown | application crashed [@ mozilla::gl::GLContext::BeforeGLCall(char const*)] following testMasterPassword, testSettingsMenuItems → Android 4.0 Debug Shutdown | application crashed [@ mozilla::storage::Connection::~Connection()] following testAddSearchEngine
Unable to reproduce since June 12.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
It's back...

https://tbpl.mozilla.org/php/getParsedLog.php?id=44045634&tree=Cedar&full=1
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
See Also: → 1024686, 994484
We don't run Android 4.0 debug robocop now and likely won't try to run 4.3 debug robocop.
Assignee: nobody → gbrown
Status: REOPENED → RESOLVED
Closed: 7 years ago5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.