When working on a file that was previously saved, changing the size of text also changes the size of table spacing

VERIFIED WORKSFORME

Status

SeaMonkey
Composer
VERIFIED WORKSFORME
17 years ago
13 years ago

People

(Reporter: TucsonTester2, Unassigned)

Tracking

({polish, qawanted})

Trunk
Future
x86
All
polish, qawanted

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.4)
Gecko/20010913 Netscape6/6.2
BuildID:    2001091303

This may be a duplicate of bug #98535, but I dont believe so, so I am submitting
it as new.

If you use the mouse to select all text in a table, and then use either the
toolbar buttons to change text size, or use the keyboard shortcut to change text
size, then the spacing in the table increases, leaving large gaps between the
cells.  This ONLY happens if you are working on a file that was created
previously and then reopened in composer.  If you simply create a page in
composer, this does not happen until you save it, open a new page, and then open
the file in the new page.  This also does not happen if you chage text size
using the format menu, only when using keyboard shortcut or toolbar buttons.


Reproducible: Always
Steps to Reproduce:
1.Open a new composer page
2.Click on button to insert a table and select default table
3.Enter text in table cells
4.Click on file and select save
5.After saving file, open a new composer page
6.Select file, and then select open file
7.Select the file you have just saved and open it
8.With mouse, select all text in table
9.Click on toolbar button to increase text size

Actual Results:  The cells change size to adjust for the new text size, but the
spacing around the cells also changes size. 

Expected Results:  The cells should change size to adjust to the text, but the
spacing should not change

Bug 98535 refers to problems in redrawing when chnaging cell size, but this does
not appear to me to be a redraw problem.  If you check the Show All Tags view
(or the html source view), it shows that tags (labelled BIG) have been placed in
the spaces between the cells.  If you save this file and then open it in a
webbrowser, the table does appear to be correct (without the extra spacing you
see in composer), but if you view the source code, it does show the extra html
coding that should not be there.

Comment 1

16 years ago
Confirmed on win 2k using build 2001110703.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

16 years ago
Created attachment 59284 [details]
what I see when I do this

I see a problem in the 11/26/2001 nightly (WinNT), not the same as described,
but weird nonetheless.

Updated

16 years ago
Target Milestone: --- → M1

Updated

16 years ago
Target Milestone: M1 → Future

Updated

16 years ago
Status: NEW → ASSIGNED

Updated

16 years ago
Keywords: nsbeta1, polish
Summary: When working on a file that was previiously saved, changing the size of text also changes the size of table spacing → When working on a file that was previously saved, changing the size of text also changes the size of table spacing

Comment 3

15 years ago
reassign to new placeholder
Assignee: syd → composer
Status: ASSIGNED → NEW

Comment 4

15 years ago
Composer triage team: need info (still reproducible?)
Keywords: qawanted
Whiteboard: [need info]

Comment 5

15 years ago
Based on the steps provided, I can't reproduce the problem described using the 
2003-02-04-08 Win32 build. Cell spacing is not changed when increasing the font
size of the text. Tested under Windows XP.
Composer triage team: nsbeta1-
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Keywords: nsbeta1 → nsbeta1-
Resolution: --- → WORKSFORME
Whiteboard: [need info]

Comment 7

15 years ago
Verified works for me.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.