Closed Bug 1008574 Opened 5 years ago Closed 5 years ago

Setting Home page doesn't work

Categories

(Firefox :: Untriaged, defect)

29 Branch
x86
macOS
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jackdegolia, Unassigned)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140506152807

Steps to reproduce:

I opened the page I wanted to be my home page, went to Preferences/general, selected "use current page," and then quit Firefox.  On restarting Firefox my homepage was secondary to a Mozilla page called "Committed to You."


Actual results:

The real home page was this Mozilla page that now I have to close to get what I want.  I've tried resetting the home page several times, but still can't get rid of the Mozilla page.


Expected results:

My home page should be the only page displaying.
Actually, fact is the button name is "use current pages". That means, the pages(plural) opened in the Firefox, will be added as your homepage.

If you only would like to add "Gmail" as your homepage, please open Gmail only and click on "use current pages".
That's what I did.  The Mozilla page shows up anyway.  I did NOT have the Mozilla page open when I clicked to set the home page.  

And by the way, the button changes depending on how many pages you have open.  With a single page it's "Use Current Page."  With two or more, it's "Use Current Pages."
P.S.  With Firefox open, I've clicked on the home page icon and then I get what I set up if it's a single page and sometimes, I get the second homepage I tried to set up.  But, when I shut down and reopen, the Mozilla page is there and predominant, along with only one of my two home pages.
It is not happening in Windows. I think this problem only happening in Mac!
I'm running OS 10.9.2.  Yes, Mac.
Hey Jack, this doesn't look right. Could you provide a copy of the raw data from the "about:support" page? Visit about:support in the address bar and click "Copy raw data to clipboard" and then add it as an attachment to this report by going to https://bugzilla.mozilla.org/attachment.cgi?bugid=1003924&action=enter and click the text link "paste text as attachment" and then paste into the textbox that appears, give a description and submit the form.

Also, could you let us know if this computer is managed by an IT staff of sorts (ie is this a work/enterprise computer, or a home machine?)
Flags: needinfo?(jackdegolia)
Maybe the https://support.mozilla.com/kb/Preferences are not saved.
I don't understand your request.  I have a Mac Mini, OS 10.9.2, at home.  I don't see this about:support page...

What I do know is that this page: https://www.mozilla.org/en-US/firefox/29.0.1/whatsnew/?oldversion=28.0  Keeps showing up on top of my selected home page.  I can send a screen shot of this if you want.
Flags: needinfo?(jackdegolia)
(In reply to Jack from comment #8)
> I don't understand your request.  I have a Mac Mini, OS 10.9.2, at home.  I
> don't see this about:support page...
>
> What I do know is that this page:
> https://www.mozilla.org/en-US/firefox/29.0.1/whatsnew/?oldversion=28.0 
> Keeps showing up on top of my selected home page.  I can send a screen shot
> of this if you want.

Thanks for the info about where your machine is. No screenshot necessary, I know what that page looks like. I understand this is really frustrating. I'm sorry about that. I'd like to help fix it, but for that I first need to understand why/how it's happening, and having the information from "about:support" will be really helpful in sorting that out.

You can open the about:support page by using the Help menu in the OS X menu bar, and clicking on "Troubleshooting information". The "Copy raw data to clipboard" button is right at the top of the page that opens. You can then attach it to the bug here:

https://bugzilla.mozilla.org/attachment.cgi?bugid=1008574&action=enter

(please use the above link, the one in my previous comment here was wrong)

Click the "paste text as attachment" link, and paste the data copied by the Troubleshooting information page.

Let me know if you have any more questions.
Flags: needinfo?(jackdegolia)
Flags: needinfo?(jackdegolia)
This is super odd. Matt, can you help figure out why this is still happening, despite the mstone pref being set correctly? (per attachment 8420980 [details])
Flags: needinfo?(MattN+bmo)
Thanks for the description for finding this troubleshooting feature.  I followed your steps and hope you have the info.
(In reply to Jack from comment #12)
> Thanks for the description for finding this troubleshooting feature.  I
> followed your steps and hope you have the info.

Yes, thank you for providing this info! But it's puzzling (that is, from the information, I'm still not sure why this is happening), so I'm asking a colleague to help figure this out. He's on holiday today, but should be back tomorrow (with a full plate of work, so it may take a bit longer).

I can only think of two more things to ask you in the meantime that might help shed light on the situation...

- just above the home page setting in the options, I presume you have it set to "When Firefox starts, show my home page" ?
- and, on the same troubleshooting page from which you copied the information, near the top, under the section "Application Basics", there's a line for "Profile Folder" with a button to "Show in Finder". If you click that button, and locate the file "prefs.js", can you open that file in TextEdit (not to edit it, just to have a look...). Using the find feature of textedit (cmd+f), can you find the lines, and paste them in a comment, that have the word "mstone" in them?
Flags: needinfo?(jackdegolia)
I found two lines with "mstone" in them:

user_pref("browser.startup.homepage_override.mstone", “28.0");


user_pref("gecko.mstone", "28.0")
Flags: needinfo?(jackdegolia)
One other thing that I've not had happen before: every time I startup Firefox, a small screen appears called something like "Checking Compatibility of Add-ons with this version of Firefox."  Sometimes the check goes quickly, sometimes it goes for a little while.

This all started after an Apple technician helped me solve some other problems by migrating my data and apps from one user on my Mac Mini to a new one.  No doubt some settings have gone haywire.
(In reply to Jack from comment #15)
> One other thing that I've not had happen before: every time I startup
> Firefox, a small screen appears called something like "Checking
> Compatibility of Add-ons with this version of Firefox."  Sometimes the check
> goes quickly, sometimes it goes for a little while.
> 
> This all started after an Apple technician helped me solve some other
> problems by migrating my data and apps from one user on my Mac Mini to a new
> one.  No doubt some settings have gone haywire.

Ahhhh. So this makes sense. The values you quoted in comment #14 don't match the ones in the attachment you uploaded. This indicates Firefox hasn't managed to write the new, correct values to disk. Based on what you're saying, it's likely that after the migration, Firefox doesn't have permission to write to the profile you're using (because it was copied from the other computer, possibly with a different user account name/id).

The simplest way to fix this is likely to be doing a "reset". On the aforementioned Troubleshooting page, on the right-hand side, there's a section labeled "Reset Firefox to its default state". This will:

- keep your bookmarks and history
- try to keep your homepage (this is also stored in the file that Firefox is having trouble writing to, so I'm not 100% sure it'll work - in any case, it's only one page to restore)
- keep your saved passwords and form history
- keep your cookies

It will also create a backup folder on your desktop in case you lose something important. Assuming the reset goes well, you could trash this backup.

It will *not* keep the one add-on that you have installed (as listed in your support information), so you'd need to reinstall that. It will also "forget" other custom settings. However, it should fix this issue. :-)

Because this is an issue specific to your computer, I'm going to mark it as "works for me". If the above information isn't clear, perhaps https://support.mozilla.org/en-US/kb/reset-firefox-easily-fix-most-problems can help, or you can email me privately as before.

Thanks for helping to make Firefox better!

PS: I'm going to have a look to see if we can improve what feedback Firefox provides in cases like these, because figuring this out took much longer than either of us should have liked!
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Flags: needinfo?(MattN+bmo)
Resolution: --- → WORKSFORME
I reset as you suggested.  That fixed the problems!  Thanks!
You need to log in before you can comment on or make changes to this bug.