Closed Bug 1008618 Opened 8 years ago Closed 5 months ago

pdf.js doesn't work with dom.storage.enabled = false

Categories

(Firefox :: PDF Viewer, defect, P3)

defect

Tracking

()

RESOLVED FIXED
Tracking Status
firefox31 --- wontfix
firefox32 --- fixed

People

(Reporter: cork, Unassigned)

References

Details

(Keywords: regression, Whiteboard: [pdfjs-c-ff-integration])

pdf.js depends on dom.storage.enabled = true and fails to render if you disable it.

STR:
 1. Create a clean profile
 2. Make sure options/preferences > applications > Portable Document Format (PDF) is "Preview in Nightly/Aurora"
 3. Open about:config?filter=dom.storage and toggle dom.storage.enabled to false
 4. Load random pdf file of your choice ex. https://people.mozilla.org/~yboily/browserid_secreview.pdf

Expected result:
 pdf.js should render the pdf in all its glory.

Actual result:
 pdf.js only shows a toolbar and a loading progress.


Replacing step 3 with the following "fixes" the problem
 3. Open about:config?filter=dom.storage and change dom.storage.default_quota to 0


Last good revision: c3878c9f598d
First bad revision: d481f89fee96
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=c3878c9f598d&tochange=d481f89fee
Can you replicate that with the latest nightly? Bug 1007627 fixes the similar issue. Dup of bug 1000777 ?
With latest Nightly the PDF is shown. There is the error message though:

TypeError: sessionStorage is null
Stack trace:
ViewHistory_readFromStorage/<@resource://pdf.js/web/viewer.js:641
ViewHistory_readFromStorage@resource://pdf.js/web/viewer.js:639
ViewHistory@resource://pdf.js/web/viewer.js:600
pdfViewLoad@resource://pdf.js/web/viewer.js:3182
getDocumentCallback@resource://pdf.js/web/viewer.js:2938
 viewer.js:3292
Priority: -- → P3
Whiteboard: [pdfjs-c-ff-integration]

The bug seems to be fixed by:
Ryan VanderMeulen — Bug 1007627 - Update pdf.js to version 1.0.162. r=yury, r=Mossop
on 2014-05-09 as MOPZREGRESSION shows the bug until 2014-05-09 and not any more afterwards.

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=5bbc85136202&tochange=4b6d63b05a0a

Status: NEW → RESOLVED
Closed: 5 months ago
Depends on: 1007627
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.