Closed Bug 1008844 Opened 8 years ago Closed 8 years ago

Disable/re-enable "instagram panel" displays the home panel empty with no possibility to log-in again

Categories

(Firefox for Android Graveyard :: General, defect)

31 Branch
ARM
Android
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: TeoVermesan, Assigned: Margaret)

Details

Tested with:
Device: LG Nexus 4 (Android 4.4.2)
Steps to reproduce:
1. Install instagram panel (https://addons.mozilla.org/en-US/android/addon/instagram-panel/)
2. Go to about:addons and disable the panel
3. Re-enable it

Actual results:
- The instagram panel from about:home is empty and in about:addons, the option checkbox becomes white, with no possibility to log-in.

Expected results:
- The instagram panel from about:home shows the feeds and in about:addons, the option checkbox appear "log in/log out".
This looks like a problem with the add-on, I'll fix it there.
Assignee: nobody → margaret.leibovic
(In reply to :Margaret Leibovic from comment #2)
> Can you try this version? I believe this fixed it:
> https://addons.mozilla.org/en-US/firefox/addon/instagram-panel/versions/
> ?page=1#version-0.4

After you tap the disable button, the checkbox option turns from "Log out" to "Log in" and you have to tap once again the disable button to disable the addon. After tapping the enable button, the panel appears in the about:home and the checkbox options is "Log in". After tapping it, I am logged once again with my account and the feeds are displayed in the panel.
(In reply to Teodora Vermesan (:TeoVermesan) from comment #3)
 
> ... and you have to tap once again the disable button to disable the
> addon.

This sounds like a bug in the add-ons manager. I filed bug 1009415 about this.

Otherwise, it sounds like this bug is fixed.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
I will mark the bug as VERIFIED FIXED since after you disable/enable the add-on, the user can log-in again 

(In reply to Teodora Vermesan (:TeoVermesan) from comment #3)

> After tapping the enable button, the panel appears in the about:home
> and the checkbox options is "Log in". After tapping it, I am logged once
> again with my account and the feeds are displayed in the panel.
Status: RESOLVED → VERIFIED
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.