Closed Bug 1008954 Opened 6 years ago Closed 4 years ago

[Homescreen] Crashes when I toggle edit mode with too many icons.

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

x86_64
Linux
defect
Not set

Tracking

(tracking-b2g:backlog)

RESOLVED WONTFIX
tracking-b2g backlog

People

(Reporter: julienw, Unassigned)

References

Details

Attachments

(1 file)

STR;
* have more than 35 icons
* long press an icon

Expected:
* toggle edit mode

Actual:
* homescreen crashes

Peak 1.4.

Depending on the exact number of icons, you sometimes need to try to move an icon to another page.

See bug 1004988 comment 2 for a logcat. Clearly we see an out of graphic memory issue, so it may be specific to Peak. But it may also reproduces on other devices, just using more icons.

I tried removing the animation for edit mode and it fixes the issue for me. Maybe we could try to detect a previous crash and disable the animation after the restart?

QA: can you try this on Open C 1.4? If the bug is not triggered, can you try with more icons? Thanks !
Note that once he has enough icons the user can't escape this bug, because he can't remove an icon because of the bug.
QA Contact: ckreinbring
Unable to repro on Open C 1.4, tried with 60 icons and the device entered Edit mode with no errors.

Build ID: 20140512040203
Gecko: https://hg.mozilla.org/mozilla-central/rev/6f5597d4d3e3
Gaia: c1a8cbaac1d921cfb50e3a2600720b75cf5afabd
Platform Version: 32.0a1
Firmware Version: P821A10V1.0.0B06_LOG_DL
Keywords: qawanted
Backlog per comment 2 - since we can't reproduce on a production device.
blocking-b2g: 1.4? → backlog
Here is the patch I use to make my peak work.
blocking-b2g: backlog → ---
Mass update: Resolve wontfix all issues with legacy homescreens.

As of 2.6 we have a new homescreen and having these issues open is confusing. All issues will block bug 1231115 so we can use that to re-visit any of these if needed.
Blocks: 1231115
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.