Off-by-one-error when scrolling down

VERIFIED FIXED

Status

()

defect
P3
normal
VERIFIED FIXED
20 years ago
3 years ago

People

(Reporter: mwa, Assigned: duncan)

Tracking

Trunk
x86
BeOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(1 attachment)

A 1 pixel set of semi-random-looking trail is left when scrolling down (but not up).

(NB: BeOS R4.5)
QA Contact: leger → mwa
Assignee: don → hyatt
Component: Browser-General → XP Toolkit/Widgets
Dave, is this a bug for you?
Assignee: hyatt → duncan
No.  It's reported on the BeOS, so I'm giving it to duncan.
Status: NEW → ASSIGNED
Afaik, the port has been updated to require BeOS 5.0.  At least, that's what I think all of the current developers are using.  I was unable to reproduce the bug in my latest cvs build.

Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → WORKSFORME
This bug is back with a vengeance in Mozilla 0.9.7. I have found and corrected three off-by-one errors in the following files:/mozilla/gfx/src/beos/nsDrawingSurfaceBeOS.cpp/mozilla/gfx/src/beos/nsScreenBeOS.cpp/mozilla/gfx/src/beos/nsRegionBeOS.cppCurrently testing this fix. It is the cause of the missing line when scrolling, but also of the one pixel of garbage around all views, the missing bottom line of the URL history drop down menu, etc.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Blocks: 114349
No longer blocks: 114349
*** Bug 114349 has been marked as a duplicate of this bug. ***
This patches the files mentioned above by Daniel.  Everything seems to be
working fine, now.
Can I get an r= on this?
Comment on attachment 62795 [details] [diff] [review]
Minor changes mentioned above

I see the problem now.	With the patch, the problem goes away but scrolling
seems to be a bit choppier (or maybe that's my imagination).   r=cls
Attachment #62795 - Flags: review+
Patch committed.  Marked fixed.
Status: REOPENED → RESOLVED
Closed: 19 years ago18 years ago
Resolution: --- → FIXED
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.