[UX] Finalize design spec for the new downloads panel

RESOLVED DUPLICATE of bug 1269956

Status

()

Firefox
Downloads Panel
RESOLVED DUPLICATE of bug 1269956
3 years ago
a year ago

People

(Reporter: phlsa, Unassigned)

Tracking

(Blocks: 1 bug)

31 Branch
x86
All
Points:
8
Bug Flags:
firefox-backlog +
qe-verify -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [ux], URL)

The design for the downloads panel has been on hold for some time now.
We need to figure out if there are any changes left to make on the spec before implementing it.

https://people.mozilla.org/~shorlander/mockups-interactive/australis-interactive-mockups/osx.html
https://people.mozilla.org/~shorlander/mockups-interactive/australis-interactive-mockups/windows8.html
Flags: firefox-backlog+

Updated

3 years ago
Whiteboard: [ux] p=0

Updated

3 years ago
Whiteboard: [ux] p=0 → [ux] p=8

Updated

3 years ago
Assignee: nobody → jboriss
Status: NEW → ASSIGNED
Whiteboard: [ux] p=8 → [ux] p=8 s=it-32c-31a-30b.2 [qa-]

Updated

3 years ago
Whiteboard: [ux] p=8 s=it-32c-31a-30b.2 [qa-] → [ux] p=8 s=it-32c-31a-30b.3 [qa-]

Updated

3 years ago
Whiteboard: [ux] p=8 s=it-32c-31a-30b.3 [qa-] → [ux] p=8 s=33.1 [qa-]

Updated

3 years ago
Iteration: --- → 33.2
Points: --- → 8
QA Whiteboard: [qa-]
Whiteboard: [ux] p=8 s=33.1 [qa-] → [ux]

Updated

3 years ago
Iteration: 33.2 → 33.3
Removed from Iteration 33.3
Assignee: jboriss → nobody
Status: ASSIGNED → NEW
Iteration: 33.3 → ---

Updated

3 years ago
QA Whiteboard: [qa-]
Flags: qe-verify-

Comment 2

3 years ago
What is the state of this bug?

Comment 3

2 years ago
Philipp, can we re-prio this?
Flags: needinfo?(philipp)
Sadly I don't think we have the resources for this right now. Is there a specific reason why it is coming up again?
Flags: needinfo?(philipp) → needinfo?(gijskruitbosch+bugs)

Comment 5

2 years ago
(In reply to Philipp Sackl [:phlsa] please use needinfo from comment #4)
> Is there a specific reason why it is coming up again?

bug 963745 comment 14
Flags: needinfo?(gijskruitbosch+bugs) → needinfo?(philipp)
Ah, so it's mostly about getting the spec ready for contributors. That makes sense.

Stephen, did you have any specific further changes in mind for this? Looking at it today, it actually looks (and feels) fine to me.
Flags: needinfo?(philipp) → needinfo?(shorlander)
(In reply to Philipp Sackl [:phlsa] please use needinfo from comment #6)
> Ah, so it's mostly about getting the spec ready for contributors. That makes
> sense.
> 
> Stephen, did you have any specific further changes in mind for this? Looking
> at it today, it actually looks (and feels) fine to me.

No, what is in those mockups is meant to fix/refine some of the issues we still had after the initial implementation of the Downloads panel. But it isn't a "spec" exactly.
Flags: needinfo?(shorlander)

Comment 8

a year ago
Sorry if I'm being annoying, but I'd like to bring this issue up again. I made comment related to this almost a year ago and Downloads panel still looks the same. It is the only native panel which is still not being changed to reflect new design. Quite tacky if you ask me.

Also would to mention that all panels have different "offset". Some are only touching button, some are overlapping it. I described in following  bug:

https://bugzilla.mozilla.org/show_bug.cgi?id=1137671

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1269956
You need to log in before you can comment on or make changes to this bug.