Closed Bug 1009083 Opened 6 years ago Closed 6 years ago

[B2G][Tarako][Contacts]Unable to edit contacts imported from Facebook

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.3T+, b2g-v1.3 unaffected, b2g-v1.3T verified, b2g-v1.4 unaffected, b2g-v2.0 unaffected)

VERIFIED FIXED
blocking-b2g 1.3T+
Tracking Status
b2g-v1.3 --- unaffected
b2g-v1.3T --- verified
b2g-v1.4 --- unaffected
b2g-v2.0 --- unaffected

People

(Reporter: rkuhlman, Assigned: sergi)

References

Details

(Keywords: regression, Whiteboard: [sprd311069])

Attachments

(2 files)

The edit contact button is not functional for contacts imported from facebook. Tapping the edit button causes the button to change colors indicating that it has been tapped. Otherwise, nothing happens. The edit contact page is never displayed, and the user can continue to navigate the phone without other issues.

Repro Steps:
1) Update a Tarako to BuildID: 20140512014001
2) Launch contacts
3) Import a contact from facebook
4) In contact list, tap on imported contact to view contact details.
5) Tap on edit contact button in upper right corner

Actual:
Button flashes to indicate it has been tapped, but nothing else happens

Expected:
Edit contact page is launched

v1.3t Environmental Variables:
Device: Tarako v1.3t
BuildID: 20140512014001
Gaia: cf039fa2749a2e0f25357e4c8ca97170ad670073
Gecko: ddf4740dacc6
Version: 28.1
Firmware Version: SP6821a-Gonk-4.0-4-29


Repro frequency: 100%
See attached: logcat
this does NOT reproduce on trunk or 1.4 on Open_C, 'qawanted' to test on 1.3 on Buri
Edit contacts page can be opened without issue on the Buri v1.3. Unable to repro.
Noming.  This is a regression.
blocking-b2g: --- → 1.3T?
note to QA who's going to work on regression-window: 
the issue does not reproduce on last Monday's build (05/05), does reproduce on Friday's (05/09), please narrow down further
QA Contact: jzimbrick
Note: This issue does NOT occur in the latest Buri 1.3, 1.4, or central builds.

Tarako 1.3T Tinderbox Regression Window:

Last Working Environmental Variables:
Device: Buri
BuildID: 20140507122712
Gaia: 93e0130c6f38e2adc5ce9c159c5b7796d6aa4523
Gecko: 1c942edae31e
Version: 28.1
Base Image: v1.2-device.cfg

First Broken Environmental Variables:
Device: Buri 
BuildID: 20140507130817
Gaia: dddecf2ffe46bec137fd87f2ad99e5a22116b608
Gecko: 61708375c269
Version: 28.1
Base Image: v1.2-device.cfg

Last Working Gaia / First Broken Gecko: Issue does NOT occur.
Gaia: 93e0130c6f38e2adc5ce9c159c5b7796d6aa4523
Gecko: 61708375c269

First Broken Gaia / Last Working Gecko: Issue DOES occur.
Gaia: dddecf2ffe46bec137fd87f2ad99e5a22116b608
Gecko: 1c942edae31e

Gaia Pushlog: https://github.com/mozilla-b2g/gaia/compare/93e0130c6f38e2adc5ce9c159c5b7796d6aa4523...dddecf2ffe46bec137fd87f2ad99e5a22116b608
Broken by bug 992120.
Blocks: 992120
Sergi - Can you take a look?
Flags: needinfo?(sergi.mansilla)
I noticed that there is an error in the "device" and "base image" fields in Comment 5.

Corrected Variables:

Device: Tarako
Base Image: sp6821a-Gonk4.0-4-29

Apologies for any confusion.
Assignee: nobody → sergi.mansilla
Flags: needinfo?(sergi.mansilla)
Noemi, Jose do you think Sergi is the best person to handle this ?
Flags: needinfo?(noef)
Flags: needinfo?(jmcf)
We don't have Tarako devices. Sergi, probably can check

thanks
Flags: needinfo?(jmcf)
triage: 1.3T+ regression
blocking-b2g: 1.3T? → 1.3T+
Is it the same as 1007573?
Depends on: 1007573
Whiteboard: [sprd311069]
Flags: needinfo?(noef)
No longer depends on: 1007573
Duplicate of this bug: 1007573
Currently working on this.
Attached file Github Pull Request
I believe the problem here was that IndexedDB (through AsyncStorage) tries to store an object that contains not only JS data structures, but native ones as well, such as possibly some XPCOM wrappers. At that point, it crashes.

This fix stores the stringified contact object, and that solves the problem. Whenever a 'draft' is detected in the DB upon opening the contacts app, that string is parsed.

I got the insight from https://bugzilla.mozilla.org/show_bug.cgi?id=930839#c7
Attachment #8424983 - Flags: review?(bkelly)
Comment on attachment 8424983 [details] [review]
Github Pull Request

Looks good.  I have not validated on device.

Unfortunately travis appears to be perma-red on v1.3t at the moment due to some call log telephony mock being missing.  That's not this patches fault, but it would be nice to see that fixed before landing.
Attachment #8424983 - Flags: review?(bkelly) → review+
The tests have been fixed now. Merged 7d879b1f038fb2ef1bb2f42476e1554e96cdfd2f
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
User can successfully edit their Facebook contacts. Verified as fixed against latest v1.3T Tarako build:

v1.3T Environmental Variables:
Device: Tarako v1.3T MOZ RIL
BuildID: 20140523014001
Gaia: e76fc9fc64a027d84b2ec311fc624f4c3459dca9
Gecko: 52c1f97caee9
Version: 28.1
Firmware Version: SP6821A-Gonk-4.0-5-12
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.