Closed Bug 1009099 Opened 6 years ago Closed 5 years ago

Ween GaiaTestCase off wait_for_* methods

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect)

x86_64
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1074117

People

(Reporter: zcampbell, Unassigned)

References

Details

Attachments

(1 file)

46 bytes, text/x-github-pull-request
Bebe
: review+
rwood
: review+
Details | Review
No description provided.
Assignee: nobody → zcampbell
I actually have an old patch for this that I could rebase, update, and provide as a starting point, if you want?
I've actually already done it for all except wait_for_condition and except for GaiaEnduranceTestCase (which I'll avoid disrupting):
https://github.com/zacc/gaia/commit/5c24cf20c2242207683579e3fe60f0ce64d48a43

Do you think your part will fit in for the `wait_for_condition` part that I still need to do?
Ah, my patch removed all the wait_for methods, including those in the app objects. I'll hold onto it and rebase in the future, it's not a priority.
Ok, I didn't see the need to be that aggressive just yet, or at least we can do it in steps.
Assignee: zcampbell → nobody
Attached file github pr
This pull is not intended to resolve this bug in one go, it's just a small step to unweaving it to avoid having a large difficult pull request.
Attachment #8458591 - Flags: review?(rwood)
Attachment #8458591 - Flags: review?(florin.strugariu)
Comment on attachment 8458591 [details] [review]
github pr

LGTM and all of the modified tests passed for me on Flame
Attachment #8458591 - Flags: review?(rwood) → review+
Comment on attachment 8458591 [details] [review]
github pr

All looks OK
Attachment #8458591 - Flags: review?(florin.strugariu) → review+
Flags: needinfo?(florin.strugariu)
https://github.com/mozilla-b2g/gaia/commit/0680a4b5ca9cc8ae692572ae101b4fd1ef4a2b4d
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(florin.strugariu)
Resolution: --- → FIXED
sorry had to revert this change for test failures like https://tbpl.mozilla.org/php/getParsedLog.php?id=46927889&tree=B2g-Inbound
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
QA Whiteboard: [fxosqa-auto-backlog+]
Zac mentioned on irc this is a dupe of bug 1074117.
Status: REOPENED → RESOLVED
Closed: 6 years ago5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1074117
QA Whiteboard: [fxosqa-auto-backlog+] → [fxosqa-auto-dropped-s1]
You need to log in before you can comment on or make changes to this bug.