wocs.com - Browser hangs when JS Strict warnings enabled.

VERIFIED DUPLICATE of bug 78179

Status

()

--
critical
VERIFIED DUPLICATE of bug 78179
18 years ago
17 years ago

People

(Reporter: bugzilla, Assigned: khanson)

Tracking

({hang, perf})

Trunk
x86
All
hang, perf
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Try going to:
http://wocs.com
Mozilla becomes totally unavailable and you have to trash it!

build 20010920

Comment 1

18 years ago
wfm 2001092012 trunk mac and 2001092021 trunk linux

Comment 2

18 years ago
wfm using build 2001092003 on Win2k.

Comment 3

18 years ago
wfm 2001092103 windows me

Comment 4

18 years ago
WFM Win98SE 2001092103, in view of all WFM's changing to INVALID
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
(Reporter)

Comment 5

17 years ago
Try turning on javascript strict warnings in the "Edit -> Prefs -> Debug" and 
then go to the site again...
Status: RESOLVED → REOPENED
Resolution: INVALID → ---

Comment 6

17 years ago
Confirming on Win2k with build 2001092503 with Debug ticked.
I see many warnings about document.all so I guess this could be moved to Tech
Evangelism.
There's another bug about implementing a policy to avoid JavaScript loops
trashing Mozilla but can't remember of.

Comment 7

17 years ago
See bug 13350 to avoid JS loops.

Comment 8

17 years ago
->TE
Assignee: asa → bclary
Status: REOPENED → NEW
Component: Browser-General → English: US
Product: Browser → Tech Evangelism
QA Contact: doronr → zach
Version: other → unspecified

Comment 9

17 years ago
looks like danish or something similar to me... -> Europe West
Assignee: bclary → nitot
Component: English: US → Europe: West
QA Contact: zach → caillon

Updated

17 years ago
Summary: Browser becomes unavailable when going to http://wocs.com → wocs.com - Browser becomes unavailable
Whiteboard: [PROPRIETARY-JS]

Comment 10

17 years ago
WFM in N62 on Win2K.
No messages in the javascript console.
same with 20011010 Moz build on linux.

The site has been fixed, I guess.

Marking Resolved fixed.
Status: NEW → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 11

17 years ago
Mozilla 20011112 become totally unavailable to a long time ½-1 min.

Please turn on javascript strict warnings in the "Edit -> Prefs -> Debug" and 
then go to the site again...

Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 12

17 years ago
Should we bother to evangelize a site that works fine unless the browser is in
debug mode w/ strict warnings... 
Setting P5. accepting bug.
Status: REOPENED → ASSIGNED
Priority: -- → P5
Sending this to JS Engine people.  I don't think this an evang issue since we
load the page fine with strict warnings off.

Very noticable hang here with strict warnings on.
Severity: normal → critical
Status: ASSIGNED → NEW
Keywords: hang, perf
OS: Windows 2000 → All
Priority: P5 → --
Summary: wocs.com - Browser becomes unavailable → wocs.com - Browser hangs when JS Strict warnings enabled.
Whiteboard: [PROPRIETARY-JS]
->JS Engine, could be DOM 0.
Assignee: nitot → rogerl
Component: Europe: West → Javascript Engine
Product: Tech Evangelism → Browser
QA Contact: caillon → pschwartau
Version: unspecified → other

Comment 15

17 years ago
This warning stands out. It repeats ad infinitum in the JS Console:

      Warning: reference to undefined property document.all
      Line: 81
      Source File: http://wocs.com

This is caused by the code below: window.onerror is set to a function
which itself produces a JS-strict warning. This causes the infinite loop -

window.onerror=reapply;
function reapply()
{
  setTimeout("slideit()",2000)
  return true
}

function slideit()
{
  if (!document.images)
    return
  if (document.all)  <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<< LINE 81
  slide.filters.blendTrans.apply()
  document.images.slide.src=eval("image"+step+".src")
  if (document.all)
    slide.filters.blendTrans.play()
    whichimage=step
      if (step<number_of_images)
      step++
  else
    step=1
  if (document.all)
    setTimeout("slideit()",speed*1000+3000)
  else
    setTimeout("slideit()",speed*1000)
}
So this is possibly a dupe of bug 13350 then.  The strict warning comes from the
test of document.all existing or not  but from what I can tell, it doesn't
really affect the page... They just have MS specific code which they hide by
enclosing it within the if blocks.

Is window.onerror supposed to be triggered for warnings as well?  Should this be
duped or sent back to evangelism?

Comment 17

17 years ago
Note, too, the site authors define the above script in JS1.2:

           <script language="JavaScript1.2">

I don't know if this is a contributing factor as well. It seems that
this bug is DOM-related: what should the browser do if window.onerror
is a function which itself causes an error? 

Compare bug 13350:
"DOM needs to police JS infinite loops, schedule garbage collection"

Reassigning to Kenton; cc'ing Brendan to ask whether this is a dupe
of bug 13350 or is actually a JS Engine issue -
Assignee: rogerl → khanson
This sounds like bug 81279 or bug 78179.
:D I don't think you can get a bug which is much more of a dupe than this.  The
URL for this bug and the URl for bug 78179 point to identical pages... one is
clearly a mirror of the other.

Feel free to reopen if you disagree.


*** This bug has been marked as a duplicate of 78179 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 20

17 years ago
verified dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.