"JavaScript error: , line 0: can't access dead object" when disabling add-on using page-worker

RESOLVED DUPLICATE of bug 1001833

Status

RESOLVED DUPLICATE of bug 1001833
5 years ago
5 years ago

People

(Reporter: webtoure, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

7.14 KB, application/x-xpinstall
Details
(Reporter)

Description

5 years ago
Posted file bug.xpi
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140506152807

Steps to reproduce:

I was working with the "page-worker" module and noticed the "JavaScript error: , line 0: can't access dead object" when I did some testing on disabling the add-on I was working on.

Add-on SDK version 1.16.

To reproduce create a project with the following code in the "main.js" file:

var pgWorker = require("sdk/page-worker").Page({
});
I suspect that this is bug 985332. Can you test with a beta or aurora version of Firefox?
Flags: needinfo?(webtoure)
(Reporter)

Comment 2

5 years ago
Yes, it's still showing up unfortunately: TypeError: can't access dead object tabbrowser.xml:1097 (I've taken this from the Browser Console).
Flags: needinfo?(webtoure)
Matteo, could this be bug 1001833?
Flags: needinfo?(zer0)
(Reporter)

Comment 4

5 years ago
(In reply to Dave Townsend [:mossop] from comment #1)
> I suspect that this is bug 985332. Can you test with a beta or aurora
> version of Firefox?

So, in Firefox Aurora 31.0a2 (2014-05-12) the error is still showing up. I also get a similar error when using the SDK's "sdk/ui" ActionButton component: "JavaScript error: chrome://browser/content/tabbrowser.xml, line 1094: can't access dead object"
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(zer0)
Resolution: --- → DUPLICATE
Duplicate of bug: 1001833
(Reporter)

Comment 6

5 years ago
(In reply to Matteo Ferretti [:matteo] [:zer0] from comment #5)
> 
> *** This bug has been marked as a duplicate of bug 1001833 ***

I am sorry, I don't understand why this has been marked as "Resolved" since obviously the bug is still present. Is this just the norm? Thank you!
(In reply to Andrei from comment #6)

> I am sorry, I don't understand why this has been marked as "Resolved" since
> obviously the bug is still present. Is this just the norm? Thank you!

It's "resolved" as duplicate of bug 1001833. This bug it's just the same of the one we're already working on. You can follow the progress there!

> Thank you!

You're welcome!
(Reporter)

Comment 8

5 years ago
I understand, thank you for explaining it to me! It just makes more sense to me to be "Verified" and "Duplicate" (now that I understand) I suppose.
You need to log in before you can comment on or make changes to this bug.