If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Javascript open function does not work correctly

VERIFIED DUPLICATE of bug 97396

Status

()

Core
JavaScript Engine
--
critical
VERIFIED DUPLICATE of bug 97396
16 years ago
16 years ago

People

(Reporter: patrick, Assigned: rogerl (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20010913
BuildID:    2001091311

I am having repeated problems with sites that use the javascript open command,
either to create popups when a page is loaded or called when an href is clicked
on. This is an intermittent bug, when it occurs the mozilla icon goes blank and
no new window is opened. Currently opened windows work fine, unless they use any
javascript open functions. The "File->New Navigator Window" menu option does not
work. Closing the browser will close all windows, but the mozilla processes do
not exit, they have to be killed manually. Once all processes are killed and
mozilla is restarted, the window size of the first window will be the size
specified in the javascript open function call that caused the problem.
This problem has existsed since at least 0.9.3, but is definately much worse in
the current mozilla.
This is by far the worst bug I have experiences since 0.9.3.

Reproducible: Sometimes
Steps to Reproduce:
The most reliable way to reproduce the problem is to use a somewhat
controversial site, so I hope I do not offend anyone:
 1. Go to: http://www.edrugtrader.com/
 2. Click on one of the drug links on the right (such as morphine), this should
result in a popup window, but sometimes doesn't.

Comment 1

16 years ago
This is the same issue as bug 97396. And, for future reference, it's far more
likely that this kind of bug is a bug with the 'XPapps' component rather than
Javascript engine.

*** This bug has been marked as a duplicate of 97396 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

16 years ago
Marking Verified -
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.