Closed Bug 1009576 Opened 7 years ago Closed 2 years ago

Investigate importance of PDF Viewer two-page view

Categories

(Firefox :: PDF Viewer, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 62

People

(Reporter: yury, Unassigned)

References

Details

(Whiteboard: [pdfjs-c-ux] https://github.com/mozilla/pdf.js/pull/3723)

Is this functionality needed for any PDF viewer? If yes, what will be a best way to implement this.

It blocks review for https://github.com/mozilla/pdf.js/pull/3723
Here's our use-case: Our xulrunner/HTML-based literacy software (bloomlibrary.org) is being used by a group in Uganda making paper school books for kids in 12 minority languages, but laid out in html. They need to see that things are lined up properly across a page spread, without wasting paper/ink printing it out at each step. Two-up view is needed for this.
Architectual and urban planning reports contain many maps on spreads. A two-up view (with cover page option) would greatly improve the readability of such reports.
Looking at PDFs on a wide-screen monitor is a waste of space if I can only view 1 page at a time.
Continuous Two-Page Layout would allow for a better experience.
I'm not sure this feature should be enabled by default but it sure should exist as an option since the current mode is a waste of space in wide screens.  Here are a few suggestions on how this option may be toggled:
* As a button on the top bar.  This is probably the simplest and most convenient.
* As a right-click option or under the Tools button, in case it's not considered a frequently used feature (I really prefer the first option).
* Automatically set 1 or 2 pages (or even more) depending on the zoom:  fit as many pages as possible without a horizontal scroll bar (MS Word does this).

The default view mode could be:
* Memorized as a setting, so next time a PDF is opened it remembers the setting of the previous PDF.
* Selectable through an option in the global Settings menu or as an entry in about:config.
* Memorized per document, so next time a certain PDF is opened the last mode used for that PDF is used.  (There should still be a way to select the default mode for PDF documents opened for the first time.)
(In reply to cousteau from comment #4)
> I'm not sure this feature should be enabled by default but it sure should
> exist as an option since the current mode is a waste of space in wide
> screens.

It's not only a waste of space, it also affects usability on cases where the content was intended to be viewed two-pages at a time, such as with magazines, or maps - like comment 2 mentions.

The github issue from comment 1 has a PR waiting for more than a year.

What's blocking this feature?
Duplicate of this bug: 864440
Duplicate of this bug: 786602
See Also: → 1158610
Bumping this.  This is pretty basic pdf viewing functionality. As per Comment 5:  What is blocking this feature?
Each day, narrow displays get rarer.
Typical PDFs are in DIN A4 or LETTER format, which are narrow enough that 2 of them side-by-side is the recommended way of viewing them.
Firefox only allows for 1 page, which leaves us with a lot of negative space.
2-page view is necessary if user wants to use it as a reader of e-book. Especially if it's a cartoon (comic) because sometimes one picture is painted across 2 pages. It shouldn't be displayed as separated pages.

Please note that Japanese cartoon (comic) usually starts from only left page. Then, turn the pages from left to right (i.e., right side is even-numbered page, left side is odd-numbered page. different from books written in Western languages).  So, if there is a information of the direction, it should be respected.  Otherwise, needs a UI to toggle the direction easily (even in Japan, a lot of books, e.g., magazines starts from right page and turning the pages from right to left).
Also see github #590 / https://github.com/mozilla/pdf.js/issues/590#issuecomment-287236189

Is there any reason why this functionality has to be implemented in pdf.js itself instead of in a read application based on pdf.js? It took me all of a few minutes to adapt an existing pdf.js example to provide two-page functionality:

https://jsfiddle.net/Yetangitu/1egqfefu/4/

Click the left/right page or the buttons to change pages. Don't click too fast or you'll get display corruption as I did not implement any safeguards against such. As said, this was a few minutes work.
Status: NEW → RESOLVED
Closed: 2 years ago
Depends on: 1459248
Resolution: --- → FIXED
Target Milestone: --- → Firefox 62
You need to log in before you can comment on or make changes to this bug.