browser freezes when both Java and Javascript are enabled

VERIFIED WORKSFORME

Status

Core Graveyard
Java: OJI
VERIFIED WORKSFORME
17 years ago
8 years ago

People

(Reporter: Minko Markov, Assigned: edburns)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:0.9.4) Gecko/20010913
BuildID:    2001091311

M 0.9.4 freezes every time I open this URL,
provided that both Java and Javascript are
enabled. If only one, or none, is enabled,
there is no freeze.



Reproducible: Always
Steps to Reproduce:
1. open http://gbg.bg
2.
3.

Actual Results:  The browser freezes completely. I have to
kill it to get rid of the mozilla-bin processes
that were spawned.

The page uses flash animation. The freeze
occurs both when the flash plug-in (Netscape 6.1)
is installed, and when it is not installed.


I use Java plug-in, loaded by opening
ftp://ftp.netscape.com/pub/netscape6/english/6.1/unix/linux22/jre.xpi

The URL is updated frequently, and it used to work well
with Mozilla in the past. So, they may soon update
it again and it may start working with Mozilla once more ??
I am positive the URL works with IE.

Comment 1

17 years ago
A Shockwave plugin is document.written at the site by this included JS file:

<!-- Maxx -->
<script language="JavaScript"         
        src="http://adv.abv.bg/new/getBan.php?SID=2&PID=5500"         
        type="text/javascript">
</script><br>
<img SRC=i/c.gif height=4><br>
<!-- /Maxx -->



Here is the script in this file, given in full:

document.write('<embed src="http://gbg.bg/f/maxx.swf"
quality=high 
pluginspage="http://www.macromedia.com/shockwave/download/index.cgi?P1_Prod_Vers                                                             
                                                             ion=ShockwaveFlash" 
type="application/x-shockwave-flash" width="750" height="70"></embed>')

Comment 2

17 years ago
wfm using build 2001092103 on Win2k with JRE 1.3.1.
Crashes with build 20010921 on Linux but I guess this is bug 86591 blocking.
Here's a Talkback ID just in case: TB35704923Y.

Comment 3

17 years ago
Reassigning to OJI. I cannot reproduce this on my Linux box,
and it's not likely to be a JS Engine issue.

Assignee: rogerl → edburns
Component: Javascript Engine → OJI
QA Contact: pschwartau → pmac

Comment 4

17 years ago
Also WORKSFORME with these Mozilla trunk binaries on Linux:

                        2001090921
                        2001091708
                        2001091808
                        2001091908

I do not hang at the site with any of them. Marking WORKSFORME -

mmarkov@home.com: once bug 86591 is fixed, could you try the site again
with a more recent build, and see if you still hang? If the site loads OK,
you can mark this bug "Verified"; otherwise, you can reopen it - thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

17 years ago
Today the site is OK. Worksforme.

As I said when I reported the bug,
the layout of the site changes
often, the content changes daily,
if not even more often, so it is
a moving target. Workstoday != Workedyesterday.
Status: RESOLVED → VERIFIED

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.