Background vanishes when text size changed

RESOLVED DUPLICATE of bug 100650

Status

()

--
minor
RESOLVED DUPLICATE of bug 100650
17 years ago
17 years ago

People

(Reporter: T.J.Hunt, Assigned: attinasi)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.4+) Gecko/20010919
BuildID:    2001091903

This page has a nice background image, but after certain sequences of actions
involving changing the stylesheet and then the text size, BODY starts being
rendered with a white background.

Reproducible: Always
Steps to Reproduce:
1. Go to the above URL:
http://www.meyerweb.com/eric/css/edge/complexspiral/demo.html
2. Select View -> Use Stylesheet -> Shuttle from the menu 
3. Select View -> Text Size -> 120 %

Actual Results:  As well as the text size increasing, the background of BODY
goes white.

Expected Results:  Changing the text size should not change the background!

Appologies if I have got the wrong component. I have no idea what could be
causing this.

Note that this problem does not occur until you have changed stylesheet at least
once, but then it happens with any stylesheet. Once this bug has occurred, then
just changing the stylesheet does not fix the problem, but shift-reload does.
(Reporter)

Comment 1

17 years ago
Created attachment 50255 [details]
Testcase: the html file
(Reporter)

Comment 2

17 years ago
Created attachment 50256 [details]
Testcase: CSS file 1
(Reporter)

Comment 3

17 years ago
Created attachment 50257 [details]
Testcase: CSS file 2
(Reporter)

Comment 4

17 years ago
Simplified testcase attached. You need to save these 3 files into one directory,
then load the HTML file, the backgroud should be green. Choose View -> Use
Stylesheet -> Red, and the background goes red. Choose View -> Text Size -> 120
% and the background goes white, which is a bug.

This bug also occurs in build 2001092103, Win98.

Oh, and if someone could point me to some instructions on how to successfully
attach multiple file testcases to a bug then I would be most grateful.
Summary: Background image vanishes when text size changed → Background vanishes when text size changed
The way to add multi-file testcases to the bug is to add the files in reverse
order.  Add the files that reference nothing first (eg your css files). Then
change the html to reference the bugzilla attachment urls.  Then attach the
HTML.
Duplicate of "Alternate stylesheet background disappears on text resize" (filed
by the guy who created that meyerweb website, btw).

*** This bug has been marked as a duplicate of 100650 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.