WebClient 1.1-Input Button masks don't work

VERIFIED FIXED in mozilla0.9.6

Status

Core Graveyard
Java APIs to WebShell
--
critical
VERIFIED FIXED
17 years ago
6 years ago

People

(Reporter: Jeet Shahani, Assigned: edburns)

Tracking

Trunk
mozilla0.9.6
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
if (0 != (modifiers & InputEvent.BUTTON1_MASK))
returns a false when it should return true when click button1
or left button in Windows.  (This worked in WebClient 1.0 and has broken in 1.1).
I have been using it mainly for mouseReleased, MouseEntered methods.
See sample example.

public void mousePressed(java.awt.event.MouseEvent e){
if (0 != (modifiers & InputEvent.BUTTON1_MASK)) {
	if (e instanceof WCMouseEvent) {
		System.out.println("wcmevent"+e);
	}
}
(Reporter)

Comment 1

17 years ago
if(0 != (modifiers & InputEvent.BUTTON3_MASK) doesn't seem to be working too!

It looks like:
the left button doesn't genrate a number,
the middle button(scroll wheel) is generating a 8,
the right button(used for popups is generating a 16.
(Assignee)

Comment 2

17 years ago
Reassign to Joe as I'm leaving the role of OJI module owner.
Status: UNCONFIRMED → NEW
Component: Java APIs to WebShell → OJI
QA Contact: avm → pmac
Target Milestone: --- → mozilla0.9.5
(Assignee)

Comment 3

17 years ago
Ressign to Joe Chou, as I am no longer working officially on OJI.
Assignee: edburns → joe.chou
Target Milestone: mozilla0.9.5 → mozilla0.9.6
(Assignee)

Comment 4

17 years ago
Ed Burns
Assignee: joe.chou → edburns
Component: OJI → Java APIs to WebShell
(Assignee)

Comment 5

17 years ago
It looks like nsIDOMMouseEvent->GetButton() returns either 0 in the case of 
mouse move, or 2 in the case of a secondary button press.  It never returns 1.
Status: NEW → ASSIGNED
Ever confirmed: true
(Assignee)

Comment 6

17 years ago
Bug 74468 was the key to solving this.
(Assignee)

Comment 7

17 years ago
Fix checked in to Blackwood Netscape 6.1 branch.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 8

17 years ago
Based on the reporter, this bug is no longer exist in Netscape 6.1. Verified.
Status: RESOLVED → VERIFIED
(Reporter)

Updated

17 years ago
Blocks: 58526
Component: Java APIs to WebShell → Java APIs to WebShell
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.