Closed Bug 1009660 Opened 8 years ago Closed 8 years ago

[Settings] Buttons get taps accidentally when the user scrolls

Categories

(Core :: Panning and Zooming, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1022956

People

(Reporter: dmarcos, Unassigned)

References

Details

Attachments

(3 files)

When scrolling up and down the settings menu I often get accidental taps. To capture the user intent a small delay might be needed before accepting the tap.  This is particularly bad when having options that can be changed without the user noticing. (Look attached videos)
Attached video settingsScroll1.MOV
Attached video settingsScroll2.MOV
I am pretty sure this is an APZC issue as we often see this with any app and apz scrolling.
Component: Gaia::System → Panning and Zooming
Product: Firefox OS → Core
Summary: [Settings] Buttons get taps accidentally when the user scrolls → [APZC] Buttons get taps accidentally when the user scrolls
OS: Mac OS X → Gonk (Firefox OS)
Summary: [APZC] Buttons get taps accidentally when the user scrolls → [Settings] Buttons get taps accidentally when the user scrolls
What device(s) can you reproduce this on?
Flags: needinfo?(dmarcos)
It's a problem I've seen in every device. The video is taken on a Nexus 4.
Flags: needinfo?(dmarcos)
This remains unfixed and it's very frustrating:

1. The user cannot scroll properly.
2. When scrolling checkboxes, sliders and buttons get tapped by accident. In the attached video I'm changing volume settings when trying to scroll.

This should clearly block 2.1 and even 2.0 as well.

I attached a new video using flame and this is the gaia/gecko combo used:

Gaia      f42ebc93554979501d3ac52bcf9e69cb4b310a4f
Gecko     https://hg.mozilla.org/mozilla-central/rev/9dc0ffca10f4
BuildID   20140610040208
Version   33.0a1
blocking-b2g: --- → 2.1?
Flags: needinfo?(jsmith)
Flags: needinfo?(bugmail.mozilla)
Attached video scrollIssueFlame.MOV
blocking-b2g: 2.1? → 2.0?
We have a UX decision in bug 1022956 that will change the behavior of the platform. I'm not sure if we're going to use that bug to track the work, or it will be done in a different bug, but I think it makes sense to dupe against that as UX and kats have chimed in there. Let me know if this is incorrect or you don't think it should be a dupe. Thanks!
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1022956
Flags: needinfo?(bugmail.mozilla)
Will respond in the dupe.
Flags: needinfo?(jsmith)
blocking-b2g: 2.0? → ---
You need to log in before you can comment on or make changes to this bug.