Closed Bug 1009749 Opened 6 years ago Closed 6 years ago

crash in mozilla::dom::WrapperPromiseCallback::Call(JS::Handle<JS::Value>)

Categories

(Core :: DOM: Events, defect)

31 Branch
All
macOS
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1009675

People

(Reporter: lizzard, Unassigned)

Details

(Keywords: crash, topcrash)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-c4886383-35e1-492b-9554-e5bc72140512.
=============================================================

This crash signature first appeared on 2014-02-07 and is the #18 crash for Firefox 31.0a2 with 72 out of 8660 crashes in the last week. 

From the comments and urls in the crash reports, it appears to commonly happen during pull requests or merges on github. 


Crashing thread:
0 	XUL 	mozilla::dom::WrapperPromiseCallback::Call(JS::Handle<JS::Value>) 	obj-firefox/x86_64/dist/include/jsfriendapi.h
1 	XUL 	mozilla::dom::Promise::RunTask() 	dom/promise/Promise.cpp
2 	XUL 	mozilla::dom::PromiseResolverTask::Run() 	dom/promise/Promise.cpp
3 	XUL 	nsThread::ProcessNextEvent(bool, bool*) 	xpcom/threads/nsThread.cpp
4 	XUL 	NS_ProcessPendingEvents(nsIThread*, unsigned int) 	xpcom/glue/nsThreadUtils.cpp
5 	XUL 	nsBaseAppShell::NativeEventCallback() 	widget/xpwidgets/nsBaseAppShell.cpp
6 	XUL 	nsAppShell::ProcessGeckoEvents(void*) 	widget/cocoa/nsAppShell.mm
7 	CoreFoundation 	CoreFoundation@0x12b31 	
8 	CoreFoundation 	CoreFoundation@0x12455 	
9 	CoreFoundation 	CoreFoundation@0x357f5 	
10 	AppKit 	AppKit@0x119b37
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1009675
You need to log in before you can comment on or make changes to this bug.